Search found 264 matches

by mike.dld
Mon May 06, 2019 5:27 am
Forum: General
Topic: Unnecessary connection?
Replies: 1
Views: 197

Re: Unnecessary connection?

vm4.transmissionbt.com is an internal name for a server that does also serve dht.transmissionbt.com. I presume Transmission connects to the latter since you have DHT enabled in settings.
by mike.dld
Sat Apr 27, 2019 9:06 am
Forum: Windows Support
Topic: Transmission quits/crashes shortly after startup
Replies: 2
Views: 884

Re: Transmission quits/crashes shortly after startup

If possible, please try the nightly build (x86, x64) and see if it helps. Regardless, take a look in Event Viewer (Start -> Run -> eventvwr.msc) and provide additional information from there regarding the crashes.
by mike.dld
Sat Apr 27, 2019 8:56 am
Forum: General
Topic: Segmentation fault in in tr_isTorrent
Replies: 4
Views: 315

Re: Segmentation fault in in tr_isTorrent

The idea was to reproduce the issue, sending SIGKILL means you weren't able to do that. If you were to succeed, AddressSanitized would print some helpful information. Please try a few more times if possible.
by mike.dld
Thu Apr 25, 2019 5:33 am
Forum: General
Topic: Segmentation fault in in tr_isTorrent
Replies: 4
Views: 315

Re: Segmentation fault in in tr_isTorrent

Since you seem to be building Transmission from sources, and if you're using recent enough compiler, try adding `-fsanitize=address` to your CFLAGS and reproducing this again.
by mike.dld
Wed Mar 20, 2019 6:38 pm
Forum: Windows Support
Topic: Possibe bug? or is it just me?
Replies: 2
Views: 416

Re: Possibe bug? or is it just me?

When using transmission-deamon on Windows, it gets registered as a service and runs under LocalService account. This means that LOCALAPPDATA environment variable is specific to that LocalService user, not the user you're using yourself. On Windows 10, it would expand to something like "C:\Windo...
by mike.dld
Mon Feb 25, 2019 8:11 am
Forum: Mac Support
Topic: Download scripts no longer running?
Replies: 3
Views: 358

Re: Download scripts no longer running?

And if you wonder what the working directory is for your script at any point, do `echo "$PWD" > /tmp/pwd.txt`, or `env > /tmp/pwd.txt` to see the whole environment.
by mike.dld
Mon Feb 25, 2019 8:10 am
Forum: Mac Support
Topic: Download scripts no longer running?
Replies: 3
Views: 358

Re: Download scripts no longer running?

Both of your test scripts are using relative paths to write to a file. One does not really know what Transmission's working directory (which is what those paths are relative to by default) would be upon script execution, and need to be explicit by providing full paths to files the script is working ...
by mike.dld
Tue Feb 19, 2019 8:05 pm
Forum: Mac Support
Topic: What's the purpose of Tab Bar?
Replies: 3
Views: 708

Re: What's the purpose of Tab Bar?

Once upon a time Apple decided it would be a good idea add this menu item to each and every program. No, Transmission doesn't support tabs (there's no good use-case for them at the moment) and the item will be removed in the upcoming 3.00 release.
by mike.dld
Sat Feb 16, 2019 6:02 am
Forum: Windows Support
Topic: script-torrent-done-filename nzbToMedia TorrentToMedia.py Windows 10 daemon
Replies: 1
Views: 393

Re: script-torrent-done-filename nzbToMedia TorrentToMedia.py Windows 10 daemon

You're specifying a command instead of a single file for script path, this won't work. Since we don't currently support running .py scripts directly, you'll need to create a wrapper .bat/.cmd script (specifying path to it in settings.json instead) and do whatever you want in it, including running Py...
by mike.dld
Tue Nov 06, 2018 8:48 pm
Forum: Requests
Topic: Please add dark mode in macOS
Replies: 1
Views: 979

Re: Please add dark mode in macOS

by mike.dld
Sat Oct 13, 2018 10:09 am
Forum: Support
Topic: Really bad news. All data deleted.
Replies: 6
Views: 504

Re: Really bad news. All data deleted.

Removing everything in / sounds even less like Transmission (or any other non-system process really) unless you're running it with root privileges which is never a good idea.
by mike.dld
Fri Oct 12, 2018 7:59 pm
Forum: Support
Topic: [SOLVED] All Torrents Missing Following Upgrade
Replies: 3
Views: 286

Re: All Torrents Missing Following Upgrade

Which client are you using (web UI, GTK+, Qt)? If you SSH into the box and execute `transmission-remote -l`, are the torrents being listed? If you SSH into the box, execute `transmission-remote -si`, take "Configuration directory" path from the output and do `ls <that directory>/torrents`,...
by mike.dld
Fri Oct 12, 2018 7:12 pm
Forum: Support
Topic: Really bad news. All data deleted.
Replies: 6
Views: 504

Re: Really bad news. All data deleted.

What I'm saying is that even if you don't mount the drive, you could still see stuff in the directory. That's how things work. Are you absolutely sure that it's mounted (i.e. did you check `mount` or `df` commands output) or are you saying it is based on the directory being non-empty? I can't see an...
by mike.dld
Fri Oct 12, 2018 7:04 am
Forum: Support
Topic: Really bad news. All data deleted.
Replies: 6
Views: 504

Re: Really bad news. All data deleted.

This looks more like the case of unmounted drive than of Transmission deleting arbitrary files when it wasn't asked to at this point. Did you check that your `HDD_2TB` is still mounted?
by mike.dld
Mon Oct 08, 2018 8:02 am
Forum: Web Interface
Topic: Web interface malfunctioning
Replies: 4
Views: 968

Re: Web interface malfunctioning

Did you guys check that nothing weird is selected in torrent state and tracker combos and/or entered into filter text input? If that's not the case, please open up Developer Tools (with F12 or something) and check out error/warning messages in Console tab (excluding "Synchronous XMLHttpRequest&...

Go to advanced search