Search found 1 match

by tadek1981
Thu Jan 11, 2018 1:55 pm
Forum: Mac Requests
Topic: I am using OS 10.6.8 on a mid 2011 27" iMac. Will this operate?
Replies: 0
Views: 3249

I am using OS 10.6.8 on a mid 2011 27" iMac. Will this operate?

I am using OS 10.6.8 on a mid 2011 27" iMac. Will this operate?