QNAP v2.84 b24 not completing downloads properly

Discussion of Transmission that doesn't fit in the other categories
Post Reply
rabies
Posts: 3
Joined: Sat Mar 19, 2016 12:14 am

QNAP v2.84 b24 not completing downloads properly

Post by rabies »

Hi.

I have Transmission v2.84 b24 running on my QNAP TS-251. Everything works and all seems fine EXCEPT when the torrent is >4GB.
When I get a torrent file or use a magnetic link with a torrent which exceeds 4GB the file sometimes doesn't complete properly.
The size is correct but the checksum differs.
This presents itself as momentary corruption in a video file, or errors when installing an application/game.

To fix this I launch uTorrent on my PC, point it at the same "complete" file and it starts downloading the missing bits, anywhere from 1mb to 200mb depending on the size of the file.

If I verify the file through transmission it verifies completely.

I've reinstalled, de/increase the cache... and now I'm suck hence this post.

Any help would be appreciated.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: QNAP v2.84 b24 not completing downloads properly

Post by x190 »

>4GB.
Some filesystems have 4GB as a limit. Is that an issue here? Transmission couldn't verify a file to 100% if pieces were missing.
killemov
Posts: 441
Joined: Sat Jul 31, 2010 5:04 pm

Re: QNAP v2.84 b24 not completing downloads properly

Post by killemov »

Got to agree with with x190 here. There are no known 4GB file size limits with Transmission. So it has to be the file system. (Or something VERY weird with the QNAP firmware.) My guess would be FAT32. Please use a native Linux file system for downloading.
rabies
Posts: 3
Joined: Sat Mar 19, 2016 12:14 am

Re: QNAP v2.84 b24 not completing downloads properly

Post by rabies »

Thanks for your responses.
The file system is EXT4, and has no issues.
The incomplete torrents happen on 2 different drivers and volumes.

I think the important thing to remember here is uTorrent completes the torrents correctly. I don't move or touch the files, they stay exactly where they are, I just tell uTorrent to save the torrent where it is.

Example:

Torrent = SolarSystemInHD.mvk.torrent.
Save to = \\Videos\Documentaries\SolarSystemInHD.mvk
Open with Transmission
Transmission says 100% complete.

Open with uTorrent.
uTorrent says 99% complete.

The problem doesn't happen with smaller files, and even sometimes with 8GB files, but with anything over say 10GB it's guaranteed to happen.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: QNAP v2.84 b24 not completing downloads properly

Post by x190 »

Transmission says 100% complete.
Then it's 100%, assuming you mean a 'fresh' verify.
Open with uTorrent.
uTorrent says 99% complete.
We don't support µT.

You could try PMing me a torrent that demonstrates this issue every time complete with checksums.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: QNAP v2.84 b24 not completing downloads properly

Post by x190 »

Through a process of elimination Transmission on my QNAP NAS has the issue, but the OSX client doesn't have it, only the QNAP version has it.
Both use exactly the same verification code from libtransmission, so by the process of elimination, the problem must lie with your NAS (you could check with their support) or that other thing.

Are you deselecting any small files? Are webseeds present in the problematic torrent(s)?
rabies
Posts: 3
Joined: Sat Mar 19, 2016 12:14 am

Re: QNAP v2.84 b24 not completing downloads properly

Post by rabies »

I do usually deselect previews, subs and smaller files.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: QNAP v2.84 b24 not completing downloads properly

Post by x190 »

rabies wrote:I do usually deselect previews, subs and smaller files.
viewtopic.php?f=1&t=3415

Perhaps you didn't when using that 'other thing'?

EDIT: Alternately, perhaps you subsequently deleted the 'part' files that Transmission must download to verify pieces, even though they were deselected. That 'other thing' may hide such files.
Post Reply