[Solved]Problems with transmission-remote-cli

Discussion of Transmission that doesn't fit in the other categories
Post Reply
Wiking
Posts: 6
Joined: Sun Mar 20, 2016 8:34 pm

[Solved]Problems with transmission-remote-cli

Post by Wiking »

Hi,

I using Raspberry PI (512MB) with raspbian ( wheezy ) and transmission-daemon and working fine, very fine. Very :D

Now I tried to use transmission-remote-client and begin the problems. Its impossible to connect with a daemon.

The configuration file is standart and run with the user debian-transmission and the config file is in /etc/transmission-daemon/settings.json I tried to connect with this instruccions :

Code: Select all

transmission-remote-cli -c usuario:password@localhost:9091
transmission-remote-cli -c usuario:password@127.0.0.1:9091
transmission-remote-cli -c usuario:password@192.168.6.5:9091
With the firts instrucction, the result is Can not connect to localhost: 9091 : This address family is not supported by the protocol. I find that the problem is in localhost.
With the second and the third instruccion, the result is Can not connect to 127.0.0.1:9091 : Could not connect. Timeout or Can not connect to 192.168.6.5:9091 : Could not connect. Timeout.

If I connect in the same net with the web any problem and any problem if connect to the other site ( outsite ) with web. I understand that the problem not is in the configfile ( hope ).

Can I help me?? Is possible that the RPI not support this funcionality??

Thanks a lot.

PS: I have a other test in a virtualbox and debian jessie ( for the problem is in the config file ). The same configuration file, the same installation, all the same and perfectly work with web and transmission-remote-cli
Last edited by Wiking on Tue Mar 22, 2016 6:32 pm, edited 1 time in total.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Problems with transmission-remote-cli

Post by x190 »

Run daemon with --logfile path and then check the RPC settings in the settings.json file that Transmission says it is loading.

Note: The client should be closed before making changes, otherwise settings will be reverted to it's previous state.
Wiking
Posts: 6
Joined: Sun Mar 20, 2016 8:34 pm

Re: Problems with transmission-remote-cli

Post by Wiking »

Hi,

I put the file log.

Code: Select all

[18:54:51.395] Transmission 2.52 (13304) started (session.c:718)
[18:54:51.396] RPC Server Adding address to whitelist: * (rpc-server.c:803)
[18:54:51.396] RPC Server Serving RPC and Web requests on port 127.0.0.1:9091/transmission/ (rpc-server.c:997)
[18:54:51.396] RPC Server Whitelist enabled (rpc-server.c:1001)
[18:54:51.396] RPC Server Password required (rpc-server.c:1004)
[18:54:51.396] Port Forwarding Stopped (port-forwarding.c:181)
[18:54:51.396] DHT Reusing old id (tr-dht.c:305)
[18:54:51.396] DHT Bootstrapping from 167 IPv4 nodes (tr-dht.c:153)
[18:54:51.396] Using settings from "/etc/transmission-daemon" (daemon.c:488)
[18:54:51.396] Saved "/etc/transmission-daemon/settings.json" (bencode.c:1731)
[18:54:51.396] transmission-daemon requiring authentication (daemon.c:508)
And the config file is :

Code: Select all

{
    "alt-speed-down": 50, 
    "alt-speed-enabled": false, 
    "alt-speed-time-begin": 540, 
    "alt-speed-time-day": 127, 
    "alt-speed-time-enabled": false, 
    "alt-speed-time-end": 1020, 
    "alt-speed-up": 50, 
    "bind-address-ipv4": "0.0.0.0", 
    "bind-address-ipv6": "::", 
    "blocklist-enabled": true, 
    "blocklist-url": "http://list.iblocklist.com/?list=bt_level1&fileformat=p2p&archiveformat=gz", 
    "cache-size-mb": 10, 
    "dht-enabled": true, 
    "download-dir": "/media/Torrents", 
    "download-limit": 100, 
    "download-limit-enabled": 0, 
    "download-queue-enabled": true, 
    "download-queue-size": 5, 
    "encryption": 1, 
    "idle-seeding-limit": 30, 
    "idle-seeding-limit-enabled": false, 
    "incomplete-dir": "/media/Torrents", 
    "incomplete-dir-enabled": true, 
    "lpd-enabled": false, 
    "max-peers-global": 200, 
    "message-level": 2, 
    "peer-congestion-algorithm": "", 
    "peer-limit-global": 240, 
    "peer-limit-per-torrent": 60, 
    "peer-port": 51413, 
    "peer-port-random-high": 65535, 
    "peer-port-random-low": 49152, 
    "peer-port-random-on-start": false, 
    "peer-socket-tos": "default", 
    "pex-enabled": true, 
    "port-forwarding-enabled": false, 
    "preallocation": 1, 
    "prefetch-enabled": 1, 
    "queue-stalled-enabled": true, 
    "queue-stalled-minutes": 30, 
    "ratio-limit": 2, 
    "ratio-limit-enabled": false, 
    "rename-partial-files": true, 
    "rpc-authentication-required": true, 
    "rpc-bind-address": "0.0.0.0", 
    "rpc-enabled": true, 
    "rpc-password": "{87c74417b9d1164d7f7da16d3a24ae19bc528c8eSAKGN9mS", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "myuser", 
    "rpc-whitelist": "*", 
    "rpc-whitelist-enabled": true, 
    "scrape-paused-torrents-enabled": true, 
    "script-torrent-done-enabled": false, 
    "script-torrent-done-filename": "", 
    "seed-queue-enabled": false, 
    "seed-queue-size": 10, 
    "speed-limit-down": 100, 
    "speed-limit-down-enabled": false, 
    "speed-limit-up": 100, 
    "speed-limit-up-enabled": false, 
    "start-added-torrents": true, 
    "trash-original-torrent-files": false, 
    "umask": 2, 
    "upload-limit": 100, 
    "upload-limit-enabled": 0, 
    "upload-slots-per-torrent": 14, 
    "utp-enabled": true
}
Thanks a lot.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Problems with transmission-remote-cli

Post by x190 »

Does the Web Interface work (you are using a third-party utility)?

With the daemon stopped, try whitelisting "rpc-whitelist": "127.0.0.1", explicitly for localhost, and *.*.*.* for all addresses.
Wiking
Posts: 6
Joined: Sun Mar 20, 2016 8:34 pm

Re: Problems with transmission-remote-cli

Post by Wiking »

Thanks a lot.

Yes, the web work perfectly. I dont install anything, only transmission-daemon, transmission-remote-cli.

I stoped transmission-daemon, modify settings.json with this :

Code: Select all

"rpc-whitelist":"127.0.0.1,localhost,*.*.*.*"
And the result is

Code: Select all

transmission-remote-cli -c user:password@192.168.0.102:9091 --> Cannot connect to 192.168.0.102:9091: It expired on connection time
transmission-remote-cli -c user:password@localhost:9091 --> Cannot connect to localhost:9091: This address family is not supported by the protocol
Sorry but I dont have the problem. Is a mistery... :?: :?: :?: :cry: :cry: :cry:

Thanks a lot
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Problems with transmission-remote-cli

Post by x190 »

I don't understand. Is your problem solved?
Wiking
Posts: 6
Joined: Sun Mar 20, 2016 8:34 pm

Re: Problems with transmission-remote-cli

Post by Wiking »

x190 wrote:I don't understand. Is your problem solved?
Sorry, the problem is not solved.

I dont is important or not, but when i make

Code: Select all

netstat -an | grep LISTEN
I see this :

Code: Select all

tcp        0      0 0.0.0.0:4712            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:51413           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:4662            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:9091            0.0.0.0:*               LISTEN     
unix  2      [ ACC ]     STREAM     LISTENING     6733     /var/run/minissdpd.sock
unix  2      [ ACC ]     SEQPACKET  LISTENING     4177     /run/udev/control
unix  2      [ ACC ]     STREAM     LISTENING     6548     /var/run/dbus/system_bus_socket
I dont know where is the problem??
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Problems with transmission-remote-cli

Post by x190 »

transmission-remote-cli -c user:password@localhost:9091 --> Cannot connect to localhost:9091: This address family is not supported by the protocol
Try using 127.0.0.1:9091 (or try 192.168.6.5:9091 again) and take "localhost" out of your whitelist. Make sure the daemon is running and hasn't exited unexpectedly.

This sounds like a trc issue, so you should try to contact its developer.

EDIT:
[18:54:51.395] Transmission 2.52 (13304) started
Can you update to v2.92?
Wiking
Posts: 6
Joined: Sun Mar 20, 2016 8:34 pm

Re: Problems with transmission-remote-cli

Post by Wiking »

Thanks a lot.

This afternoon try your answerd and try to update a new version. Is possible that the problema is for version?? :( :( :o :o

Thanks a lot
Wiking
Posts: 6
Joined: Sun Mar 20, 2016 8:34 pm

Re: Problems with transmission-remote-cli

Post by Wiking »

x190 wrote:
transmission-remote-cli -c user:password@localhost:9091 --> Cannot connect to localhost:9091: This address family is not supported by the protocol
Try using 127.0.0.1:9091 (or try 192.168.6.5:9091 again) and take "localhost" out of your whitelist. Make sure the daemon is running and hasn't exited unexpectedly.

This sounds like a trc issue, so you should try to contact its developer.

EDIT:
[18:54:51.395] Transmission 2.52 (13304) started
Can you update to v2.92?
Thanks for all...

I solved the problem.

WTF :o :o :x :x
Im a stupid human. Say with me. You ( I ) are a stupid human...

The problem is in the /etc/network/interfaces. Not configurate lo and you say what??

Yes my interfaces file dont have

Code: Select all

auto lo
iface lo inet loopback
I put in the file and sorprise. All working. Please shot me or kick me...

Thanks for all.

King regards
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: [Solved]Problems with transmission-remote-cli

Post by x190 »

Please shot me or kick me...
How'll it be if I just cuff ya' upside the ears, a la Bill Clinton? :D
Post Reply