power hit... Verify Local Data Not Working? [solved]

Discussion of Transmission that doesn't fit in the other categories
RootlessAgrarian
Posts: 2
Joined: Fri Dec 24, 2010 6:58 pm

power hit... Verify Local Data Not Working? [solved]

Postby RootlessAgrarian » Tue Apr 10, 2018 1:54 am

This is a new problem, not experienced before. I usually have a few torrents running on a semi-retired host. In the past, it has weathered the occasional power hit without trouble. However, recently we had an outage which perhaps occurred during a disk write or logfile update; at any rate when I restarted Transmission, one of my torrents (a download) was reporting an "input/output error" on one file. (I was at about 50 pct of 30 GB so I'm quite motivated to recover rather than start over!) I googled around and found that the recommended fix was to "Verify Local Data."

OK, so I managed to find this option in the menus and selected it for the afflicted torrent. The progress bar has now turned yellow but there is no indication of anything else happening. There is no "percentage verified" indicator for example. There is no "waiting to..." text. There is no "verifying" text. That torrent appears to be frozen. Apart from turning yellow, there's no indication that any verification is taking place. The "Error: Input/output error..." text is still displayed below the progress bar.

Is this normal? How long should I wait before concluding that it's not working? Does it usually work? Is there something else I have to do? A clue or two would be most welcome.

UPDATE:

Not finding any answers I decided to try something: just shut down Transmission and start it again. Not sure why, but this seemed to fix the problem. I still don't understand what happened or why Verify Local Data seemed to do nothing. However, my transfer is live again and should complete in a month or two :-)

Return to “General”