High CPU usage and slow speed (Atom 525MW, CentOS 8)

Discussion of Transmission that doesn't fit in the other categories
Post Reply
Posts: 1
Joined: Mon Nov 11, 2019 8:40 am

High CPU usage and slow speed (Atom 525MW, CentOS 8)

Post by kt368 » Mon Nov 11, 2019 8:56 am

Hi everyone!
I have a small home server based on Intel Atom D525 CPU, 4 GB RAM, 1 TB WD black with ext4 filesystem.
I've build Transmission 2.94 by myself (there is no transmission-daemon in Centos8 repos), run it and see huge CPU usage and small download speed. One core of CPU is fully loaded by transmission, download speed is around 2-3 MB/s. RPC (thru web browser or windows app) suffer big lagging...
It's Interesting that when at this PC was the previous version of CentOS (7) and transmission was installed from repos, download speed was around 8-10 MB/s with same CPU usage.
How I can examine why transmission behaves this way?

Code: Select all

cat .config/transmission-daemon/settings.json
    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "http://www.example.com/blocklist",
    "cache-size-mb": 32,
    "dht-enabled": true,
    "download-dir": "/mnt/D/Shared/Temp",
    "download-queue-enabled": false,
    "download-queue-size": 10,
    "encryption": 0,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/mnt/D/Shared/Temp",
    "incomplete-dir-enabled": false,
    "lpd-enabled": false,
    "message-level": 1,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 2000,
    "peer-limit-per-torrent": 200,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": false,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "rename-partial-files": true,
    "rpc-authentication-required": false,
    "rpc-bind-address": "",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": false,
    "rpc-password": "{8ff3bd33491990ba06264f00533edc46e61357687VDfXjfY",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "",
    "rpc-whitelist": ",::1",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": true,
    "script-torrent-done-filename": "/home/kt368/.config/transmission-daemon/chmod_after_dl.sh",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-slots-per-torrent": 14,
    "utp-enabled": false

Post Reply