Any updated news about an official windows build?

Feature requests for the Windows version of Transmission
kIssGlaY
Posts: 22
Joined: Sat Jun 29, 2013 11:13 am

Re: Any updated news about an official windows build?

Postby kIssGlaY » Sun Apr 03, 2016 4:18 pm


On 14729, still got crash on path/file name with invalid characters, but under slightly different situation as before. This is how I reproduce the crash:
1. Add a torrent with destination folder name including any invalid character and start the torrent. Now the torrent will stop instead of crashing the client after a while.
2. Remove the torrent from list(no matter trash with data or not). Wait for the client to do the next update to the "resume" dir under config dir. This is when the client crash.

According to the log, the client still tries to update the state of the torrent with invalid path name every time it's updating the "resume" dir, even though it stopped with an error. Auto replacing the invalid character, as what the unofficial transmission-qt does, would definitely be a better solution.

BTW, the long path naming issue seems to have been fixed.
Last edited by kIssGlaY on Sun Apr 03, 2016 5:09 pm, edited 3 times in total.

ruinit
Posts: 2
Joined: Sun Apr 03, 2016 1:09 pm

Re: Any updated news about an official windows build?

Postby ruinit » Sun Apr 03, 2016 4:43 pm

Is there a script for cleaning up completed torrents?

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: Any updated news about an official windows build?

Postby x190 » Sun Apr 03, 2016 5:15 pm

Please use "Windows Support" for support issues and "Windows Requests" for feature requests.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

biezel
Posts: 3
Joined: Wed Mar 30, 2016 9:06 pm

Re: Any updated news about an official windows build?

Postby biezel » Mon Apr 04, 2016 9:58 pm

mike.dld wrote:
biezel wrote:I just installed the Transmission Windows client and got it up and running with Sonarr. Only one problem: torrents only show up when I look in the web ui, but not in the actual desktop client. Anyone else run into this?

I would guess that you have installed both the Qt client and the daemon. I would also guess that both are running at the same time, and Qt client isn't connected to the daemon's session but has started its own. You need to either connect Qt client to the daemon session (via Edit menu -> Change Session…) or set different ports for the two (via Edit menu -> Preferences dialog -> Remote tab -> Remote Control group for the Qt client and via %sysroot%\ServiceProfiles\LocalService\AppData\Local\transmission-daemon\settings.json for the daemon). Note that you could also change daemon's HTTP port via Qt client after you have connected to daemon's session, and there's also settings.json file for Qt client I'm not mentioning here.


This was totally it. I uninstalled and reinstalled without the daemon, working like a charm now. Thanks for the help!

Calidude
Posts: 33
Joined: Wed Mar 28, 2012 6:47 pm

Re: Any updated news about an official windows build?

Postby Calidude » Wed Apr 06, 2016 6:05 am

Would it be possible to include an option to only install the daemon as a Windows service so that we can use TransGUI with it?

mike.dld
Transmission Developer
Posts: 184
Joined: Wed Dec 25, 2013 10:56 pm

Re: Any updated news about an official windows build?

Postby mike.dld » Wed Apr 06, 2016 7:20 am

Either I don't understand what you're asking for or it's already there. You need to select daemon and deselect all the other options during installation.


Return to “Windows Requests”