main window not appearing on Windows 7

Ask for help and report issues with the Windows version of Transmission
vollha
Posts: 2
Joined: Sat Oct 19, 2013 1:05 pm

main window not appearing on Windows 7

Postby vollha » Sat Oct 19, 2013 1:37 pm

Hi guys,

I'm using Transmission on Windows 7 and since yesterday, I'm having troubles with it. At first I thought it's caused by an update because whenever a new version is available something weird is happening or it stops working, but I updated to 2.82 and nothing. The problem is, I can't view the main window. Below are some screenshots to illustrate:

Image
The program is running, the icon is visible on the right, and the silver border around the icon the left indicates that I should be seeing the main window.

Image
I left click to check if there's anything to do: not really, it should be visible.

http://i.imgur.com/LQb6kqb.jpg (link instead of the image because it was cut off)
Aaaaaaand the window is nowhere to be seen.

It started yesterday; I've since updated the program, rebooted my laptop at least four times and googled for a solution. It's still working, I can add torrents, download and so on, I just can't see the main window. I couldn't find anyone with a similar problem; do you have any idea what to do next?

(btw while I'm not an idiot and there's no need to ask me questions like 'do you know where to find control panel', I'd really appreciate replies as simple as possible; English is not my native language, so the simpler the technical stuff, the easier for us all ;) )

rb07
Posts: 1400
Joined: Sun Aug 24, 2008 3:14 am

Re: main window not appearing on Windows 7

Postby rb07 » Sun Oct 20, 2013 11:07 pm

vollha wrote:since yesterday, I'm having troubles with it

That's the only clue: what did you change yesterday? or somebody who has access to your computer?

My guess: a joker (i.e. person) is having fun by moving the window almost out of the screen, so that only a little piece of it is showing, but in such a way that you don't see it -- like under the task bar. Yep, I used to work with one of those pranksters.

vollha
Posts: 2
Joined: Sat Oct 19, 2013 1:05 pm

Re: main window not appearing on Windows 7

Postby vollha » Mon Oct 21, 2013 8:02 am

I live with my parents and they both have better things to do than to mess around with my computer, so it's definitely not a prank :) I didn't change anything, in fact, I haven't been using Transmission for a few days. The only thing that's happened was the update. Also, There has never been a Windows download on Transmission website, so I just google for it, and I suspect that someone messed something up. In which case I'll have to wait until next update...

rb07
Posts: 1400
Joined: Sun Aug 24, 2008 3:14 am

Re: main window not appearing on Windows 7

Postby rb07 » Mon Oct 21, 2013 5:25 pm

There is no official Transmission for Windows.

The closest is Transmission-Qt for Windows, which is a port from the original code to Windows (with some changes). I do that port, and make it available, as installers (32-bit & 64-bit) on SourceForge.

That "project" has its own forum, in fact with the latest installers I leave Web links on the "Windows Start All Programs Transmission-Qt" Menu pointing to that forum (marked as Windows support), and this forum (marked as general support). You shouldn't be using this forum for Windows support (because there is no Windows release).

Nevertheless I don't think your "problem" is typical, probably nobody knows the answer. It has to be something you did, or somebody else did.

I also find odd your comments about "whenever a new version is available something weird is happening or it stops working", that doesn't happen (has not been reported) to the more than 10,000 users (estimated, actually the last version has been downloaded more than 67,000 times, and the only real problem reported is with the un-installer).

Also "The only thing that's happened was the update"... what do you mean? My installer doesn't update automatically, and the last version was released more than 2 months ago.

rb07
Posts: 1400
Joined: Sun Aug 24, 2008 3:14 am

Re: main window not appearing on Windows 7

Postby rb07 » Mon Oct 21, 2013 5:40 pm

Here's a way to force the main window to show:

  1. Stop the application (Quit on the menu you showed).
  2. Use a good editor (not Notepad) to open C:\Users\<your user>\AppData\Roaming\transmission\settings.json
  3. Check the line that says

    Code: Select all

        "start-minimized": false,
  4. Check the lines with:

    Code: Select all

        "main-window-height": 372,
        "main-window-width": 658,
        "main-window-x": 231,
        "main-window-y": 220,
  5. Save (make sure line endings are not changed -- that's why I said not Notepad, but Wordpad is almost as bad, at least it has the option -- I use Notepad++).
  6. Start the application.
On the "start-minimized" make sure it says false (I've never used this option, I don't know if it can cause the problem you are seeing).

On the size and position lines you can use my values, those are sure to work putting the window on a visible place.

moodragonx
Posts: 1
Joined: Mon Nov 07, 2016 3:05 am

Re: main window not appearing on Windows 7

Postby moodragonx » Mon Nov 07, 2016 3:13 am

I realize this topic is a bit over 3 years old but I am a user of transmission-QT on 64-bit Windows 10 and as of a few weeks ago I have not been able to view or interact with the main transmission window.
I finally got fed up with it and crawled the internet looking for a solution and rb07's suggestion was very helpful.

I inspected this json file and saw the x-position had somehow been set to some extreme value (>2500). I'm not sure how this happened, I don't share this computer and I certainly didn't manually put the window so far to the right of the edge of my desktop. Regardless, closing transmission, setting it to something more reasonable, and reopening immediately resolved the problem.
I figured I'd register, reply, and revive this long-dead thread just in case this was afflicting someone else :)


Return to “Windows Support”