Transmission process sometimes keeps running after exit

Ask for help and report issues with the Windows version of Transmission
Post Reply
culinko
Posts: 3
Joined: Wed May 03, 2017 2:22 am

Transmission process sometimes keeps running after exit

Post by culinko »

Sometimes after I exit Transmission, the GUI closes, but the transmission-qt.exe process still remains in the windows processes and torrents even keep being downloaded/seeded if there are any active. This only happens sometimes and most of the time the program closes properly. I am closing it by clicking the X at the top right corner. I am not aware if the same bug happens also when clicking on File/Quit from the menu bar. I'll try to start closing it from the menu bar to see if the bug occurs this way as well. (Btw. I don't have the tray icon enabled because Transmission will only get minimized and not closed if you click the X at the top right window.)

I'm wondering, is there any way to debug this issue and find out why it's happening? Thanks a lot for any feedback, much appreciated.
mike.dld
Transmission Developer
Posts: 296
Joined: Wed Dec 25, 2013 10:56 pm

Re: Transmission process sometimes keeps running after exit

Post by mike.dld »

It's a UI issue. GTK+ client handles this more user-friendly, so that when you select the menu item or close the window the messages "Closing connections" & "Sending upload/download totals to tracker..." appear with Quit button to force the termination w/o the wait. Qt client does exactly the same (i.e. tries to notify all trackers of its shutdown) but doesn't tell the user what's happening. It's expected that the process will terminate eventually on its own. Feel free to create an issue on GitHub, or (even better) a pull request.
culinko
Posts: 3
Joined: Wed May 03, 2017 2:22 am

Re: Transmission process sometimes keeps running after exit

Post by culinko »

mike.dld wrote:Qt client does exactly the same (i.e. tries to notify all trackers of its shutdown) but doesn't tell the user what's happening. It's expected that the process will terminate eventually on its own.
I was waiting up to 20 minutes after I closed it, so yeah, definitely not the expected behavior.
mike.dld wrote:Feel free to create an issue on GitHub, or (even better) a pull request.
Unfortunately, I'm not a programmer, so can't do a pull request, but created an issue here: https://github.com/transmission/transmission/issues/287
vn23427
Posts: 1
Joined: Sat Dec 19, 2020 11:12 pm

Re: Transmission process sometimes keeps running after exit

Post by vn23427 »

This is still happening, Win10, version 3...

Has this been reported as a bug yet?
Post Reply