How to always start with remote session instead of local ?

Ask for help and report issues with the Windows version of Transmission
Post Reply
Smitty
Posts: 9
Joined: Thu Apr 07, 2016 8:39 pm

How to always start with remote session instead of local ?

Post by Smitty » Sat Jul 08, 2017 5:44 am

i'm trying to load the qt client on start on my laptop to be notified of finished downloads in the win10 notification center.

is there a way ?
Windows 7 , 8.1 , 10 all x64 (Transmission 2.92 for Windows)
Nas: Qnap ts-212 (arm5), 2x3TB wd red (Qtransmission 2.92)

mike.dld
Transmission Developer
Posts: 285
Joined: Wed Dec 25, 2013 10:56 pm

Re: How to always start with remote session instead of local ?

Post by mike.dld » Sat Jul 08, 2017 10:21 am

Qt client should remember whether it was connected to the remote last time you used it, and do exactly what you expect next time you start it. As for starting it with the system - just google it, e.g. http://www.howto-connect.com/windows-10 ... t-startup/

Smitty
Posts: 9
Joined: Thu Apr 07, 2016 8:39 pm

Re: How to always start with remote session instead of local ?

Post by Smitty » Sun Jul 09, 2017 8:17 am

thanks, idk why the 1st time it didn't remember the settings. it works fine.
Windows 7 , 8.1 , 10 all x64 (Transmission 2.92 for Windows)
Nas: Qnap ts-212 (arm5), 2x3TB wd red (Qtransmission 2.92)

Telaso
Posts: 1
Joined: Tue Sep 01, 2020 4:48 am

Re: How to always start with remote session instead of local ?

Post by Telaso » Tue Sep 01, 2020 5:00 am

I know this is extremely late but incase anyone was wondering about this for future reference.

Open up the following file in a text editor.

Code: Select all

%UserProfile%\AppData\Local\transmission\settings.json
Lines 48-54 for me are following:
by default they are:

Code: Select all

"remote-session-enabled": false,
"remote-session-host": "localhost",
"remote-session-password": "",
"remote-session-port": 9091,
"remote-session-requres-authentication": false,
"remote-session-username": "",

Code: Select all

"remote-session-enabled": true,
"remote-session-host": "mywebserver.com",
"remote-session-password": "mypassword",
"remote-session-port": 9091,
"remote-session-requres-authentication": true,
"remote-session-username": "username",
Doing this will make transmission automatically open and connect without any prompts to your local or remote server.

Post Reply