Windows client prepends C:/ to paths when using daemon on linux

Ask for help and report issues with the Windows version of Transmission
Post Reply
soffigy
Posts: 1
Joined: Mon Nov 11, 2019 1:19 pm

Windows client prepends C:/ to paths when using daemon on linux

Post by soffigy » Mon Nov 11, 2019 1:31 pm

I run transmission-daemon on my linux server but use the windows QT client on my laptop to control it.
When I add a torrent, instead of using the 'Save To' location specified in Preferences>Download, it falsely assumes the location is local and needs a Windows drive prefix and adds 'C:/' to the beginning of the path. This is obviously an invalid path on the server which is hosting the daemon and it complains if you try to add the torrent without deleting the prefix each time.
It's easy enough to work around this little bug but it's a bit annoying having to do it each and every time.

Also a bit annoying is that I don't get the drop down box for selecting recent folders to save to which exists on the linux GUI but not on the windows one, so I have to manually change it if I want to switch from stuff which should go in the Music folder to the Films folder etc.

bjr53
Posts: 1
Joined: Fri Jan 10, 2020 5:45 pm

Re: Windows client prepends C:/ to paths when using daemon on linux

Post by bjr53 » Fri Jan 10, 2020 6:10 pm

Hi,

I just wanted to add support to this issue. I run transmission on a linux server and connect to it via an android app, the web interface, and windows clients.

The windows client (2.94) is giving me the same problem by prepending c: to the download path specified in settings, which is /mnt/nas/downloads, that then becomes c:/mnt/nas/downloads. Obviously, c:/mnt/nas/downloads isn't a valid path on my nix server.

This prevents auto adding the torrent when a magnet file is clicked because it fails due to the non existent destination path. Instead I must opt for the add torrent dialog box in order to correct the download destination before submitting the torrent. This slows down the process of adding a torrent by a factor of 20... at least, especially given the clunky touchpad integrated logitech keyboard I use for this in my living room.

I've been using this solution for many years and this issue was not present in previous versions.

It would be ** fantastic ** if someone was able to correct this wee issue :)

Thanks for the good work!!

boril
Posts: 2
Joined: Sat Jan 25, 2020 4:08 pm

Re: Windows client prepends C:/ to paths when using daemon on linux

Post by boril » Sat Jan 25, 2020 4:13 pm

Hi,

I had the same problem with running Transmission server on my NAS and client couldn't not start downloading. So I downaloaded one of the nighth builds of Transmission 3.0 and everything is OK with download.
I have another problem now - Transmission 3.0 always spawn a new instance of the client :) at the end, but at least add new torrent window doesn't complain of missing C:\ in the path

Post Reply