Port Forwarding Help

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
timbolinisan
Posts: 1
Joined: Wed Oct 11, 2017 6:49 pm

Port Forwarding Help

Postby timbolinisan » Wed Oct 11, 2017 6:59 pm

Hi,

I'm unable to open the port in Transmission. Transmission previously worked for me, but suddenly stopped working with the dreaded "Port is closed" error.

In my modem settings (Telus T1200H) I can confirm that UPNP is turned on, DMZ mode is disabled, and the port has not been manually forwarded.

Here is the Message Log output after toggling "Automatically map port"

2017-10-11 18:45:27 +0000 port-forwarding.c:180 [Info] Port Forwarding: Stopped
2017-10-11 18:45:28 +0000 natpmp.c:70 [Info] Port Forwarding (NAT-PMP): initnatpmp succeeded (0)
2017-10-11 18:45:28 +0000 natpmp.c:70 [Info] Port Forwarding (NAT-PMP): sendpublicaddressrequest succeeded (2)
2017-10-11 18:45:28 +0000 upnp.c:235 [Debug] Port Forwarding (UPnP): UPNP_GetValidIGD failed (errno 0 - Undefined error: 0)
2017-10-11 18:45:28 +0000 upnp.c:238 [Debug] Port Forwarding (UPnP): If your router supports UPnP, please make sure UPnP is enabled!
2017-10-11 18:45:28 +0000 port-forwarding.c:92 [Info] Port Forwarding: State changed from "Not forwarded" to "Starting"
2017-10-11 18:45:36 +0000 natpmp.c:75 [Debug] Port Forwarding (NAT-PMP): readnatpmpresponseorretry failed. Natpmp returned -7 (the gateway does not support nat-pmp); errno is 61 (Connection refused)
2017-10-11 18:45:36 +0000 port-forwarding.c:92 [Info] Port Forwarding: State changed from "Starting" to "???"

I've also tried setting up port forwarding manually to a static IP address on my Mac, but get the same error.

Any suggestions? Many thanks in advance.

Tim

ThePowerTool
Posts: 9
Joined: Wed May 29, 2013 4:00 pm

Re: Port Forwarding Help

Postby ThePowerTool » Fri Nov 17, 2017 11:20 pm

What changed?

I thought about stopping, here, as the answer to that question is probably the answer to your problem. You have a firewall on your system. You have a firewall-router-wifi combo (your T1200H). That's just the start. Ports can be blocked at any point and require a step-by-step approach. The log message is probably unimportant (your primary indicator is "port is closed."). Check your local firewall and recheck your router config. Those are the likely culprits. You will need to find step-by-step instructions to help you review both configurations because one setting at any point can block your port. You can also look for a firmware update for your router--important note: I'm not familiar with your router and an update may resolve your problem immediately (look for update docs and forum posts with the firmware update as the solution) and it may leave you in worse shape than when you started.

Good Luck!

One additional resource (in case you missed it in the sticky): https://github.com/transmission/transmi ... -closed%3F


Return to “Support”