disabling IPv6 in transmission-daemon

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
mr-4
Posts: 2
Joined: Tue Apr 12, 2011 10:34 pm

disabling IPv6 in transmission-daemon

Postby mr-4 » Tue Apr 12, 2011 10:43 pm

I am using transmission 2.12 and wish to disable IPv6 permanently as I have (administratively) prohibited IPv6 throughout my entire system.
When I start transmission-daemon I am getting constant kernel module loading errors (the module in question is net-pf-10 which I believe is responsible for IPv6) - is there a setting I could use to disable IPv6 in transmission permanently?

I tried setting "bind-address-ipv6" to "" instead of the default "::" in settings.json, but it did not work. Help would be much appreciated. Thanks!

lkraav
Posts: 6
Joined: Tue Sep 22, 2009 9:04 am

Re: disabling IPv6 in transmission-daemon

Postby lkraav » Thu Dec 29, 2011 3:30 pm

bump, also looking for this

mr-4
Posts: 2
Joined: Tue Apr 12, 2011 10:34 pm

Re: disabling IPv6 in transmission-daemon

Postby mr-4 » Thu Dec 29, 2011 4:35 pm

Well, apparently, the "solution" from what I could tell is to set this in settings.json:

"bind-address-ipv6": "fe80::"

That's how I did it, but I also have IPv6 disabled completely on the entire system and also prevented the daemon accessing any of the kernel modules - for good measure.

lkraav
Posts: 6
Joined: Tue Sep 22, 2009 9:04 am

Re: disabling IPv6 in transmission-daemon

Postby lkraav » Thu Dec 29, 2011 7:09 pm

yep, i commented about the same solution in the bug you filed. thanks for the reply.

robross0606
Posts: 1
Joined: Sat May 05, 2018 4:21 am

Re: disabling IPv6 in transmission-daemon

Postby robross0606 » Sat May 05, 2018 4:23 am

I tried this option but it doesn't seem to work. When I restart Transmission, it wipes the "fe80::" and puts "::" in the field all by itself.


Return to “Support”