Magnet link stuck with "torrent metadata needed"

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
brucehobbs
Posts: 4
Joined: Sun Mar 08, 2009 11:50 pm

Magnet link stuck with "torrent metadata needed"

Post by brucehobbs » Sat Apr 07, 2012 7:22 am

v2.50 (13236), Mac OS X 10.6.8

After downloading a magnet link from http://tracker.example.com.se although Transmission adds the torrent it displays the message "torrent metadata needed," but even after several hours the torrent does not begin downloading. When I allow uTorrent to open the same magnet link it almost immediately begins downloading the torrent. Thoughts/suggestions?

blacke4dawn
Posts: 552
Joined: Sun Dec 13, 2009 10:44 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by blacke4dawn » Sat Apr 07, 2012 9:03 am

Only thing I can think of is that it didn't manage to connect to any peer to get the metadata. Did you have uTP and/or DHT enabled in Transmission, if not then that probably was the major reasons but not the only ones.

brucehobbs
Posts: 4
Joined: Sun Mar 08, 2009 11:50 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by brucehobbs » Sat Apr 07, 2012 4:03 pm

Thanks for the response! uTP and DHT are both enabled. :-(

I should also have mentioned that Transmission did successfully handle magnet links a couple of times several weeks back although it did take it a few minutes to get the needed torrent metadata. I left one alone all night that has now been waiting over 9.5 hours.

Any logs I can browse or other info I can supply that might indicate the problem?

aladsto
Posts: 1
Joined: Sun Apr 22, 2012 12:17 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by aladsto » Sun Apr 22, 2012 12:19 pm

I have exactly the same problem. This magnets work perfectly with other clients, though.

mattball
Posts: 3
Joined: Sun May 06, 2012 2:13 am

Re: Magnet link stuck with "torrent metadata needed"

Post by mattball » Sun May 06, 2012 2:20 am

I am also having this problem with magnet links; Transmission 2.51 (the current latest) and OS X 10.7.3. These links work perfectly well in µTorrent, but remain stuck at "torrent metadata needed" in Transmission.

:(

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Magnet link stuck with "torrent metadata needed"

Post by x190 » Sun May 06, 2012 2:41 am

mattball wrote:I am also having this problem with magnet links; Transmission 2.51 (the current latest) and OS X 10.7.3. These links work perfectly well in µTorrent, but remain stuck at "torrent metadata needed" in Transmission.

:(
Is Transmission connecting to peers? Try a torrent pause/resume or Transmission quit/restart.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

mattball
Posts: 3
Joined: Sun May 06, 2012 2:13 am

Re: Magnet link stuck with "torrent metadata needed"

Post by mattball » Sun May 06, 2012 5:09 am

x190 wrote:Is Transmission connecting to peers? Try a torrent pause/resume or Transmission quit/restart.
Tried both of those already, neither of which helped. Transmission has no problems connection to or downloading from peers with non-magnetized transfers (that is, .torrent files).

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Magnet link stuck with "torrent metadata needed"

Post by x190 » Sun May 06, 2012 5:31 am

v2.50/1 works very well with magnet links. .torrents for the same transfer often list different trackers which by itself can bring in many more peers.
x190 wrote:Is Transmission connecting to peers?
Are ports, encryption levels, or blocklists an issue?
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

mattball
Posts: 3
Joined: Sun May 06, 2012 2:13 am

Re: Magnet link stuck with "torrent metadata needed"

Post by mattball » Sun May 06, 2012 4:52 pm

x190 wrote:Are ports, encryption levels, or blocklists an issue?
Today I tested all 4 combinations of {checked or unchecked} x {Prefer encrypted peers, Prevent peers in blocklist from connecting} and magnet links seem to be working in all cases. For some specific torrents, however, I had to uncheck both boxes for the magnet link to work.

Going forward I'm going to keep using Transmission, and keep both "Prefer encrypted peers" and "Prevent peers in blocklist from connecting" checked, but uncheck them temporarily when having issues with magnet links.

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Magnet link stuck with "torrent metadata needed"

Post by x190 » Sun May 06, 2012 7:14 pm

"Prevent peers in blocklist from connecting" checked, but uncheck them temporarily when having issues with magnet links.
Just be careful about "dancin' with the devil". :wink:
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

Silizium
Posts: 20
Joined: Fri Nov 16, 2007 11:24 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by Silizium » Wed Jun 13, 2012 11:46 pm

Same problem here, I tried everything. Switch off and on many things in the preferences. Port is open (UPNP). But the 14 Magnet Links I entered don't start. Even they have more then 100 Seeders. Please have an eye on that issue.
OSX 10.5.1

blacke4dawn
Posts: 552
Joined: Sun Dec 13, 2009 10:44 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by blacke4dawn » Thu Jun 14, 2012 4:08 pm

Silizium wrote:Same problem here, I tried everything. Switch off and on many things in the preferences. Port is open (UPNP). But the 14 Magnet Links I entered don't start. Even they have more then 100 Seeders. Please have an eye on that issue.
How long did you wait? Like with any torrent it can take a long time before it actually gets going.

Doesn't matter if a torrent has over a million seeds, you won't be downloading anything unless you actually get a download slot with someone, and that is not something they can force.

Silizium
Posts: 20
Joined: Fri Nov 16, 2007 11:24 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by Silizium » Thu Jun 21, 2012 1:09 am

For some I waited 24h or longer. But when I download the torrent it starts very quick. Maybe not the Programs fault. Can be that the seeders block some service?
OSX 10.5.1

blacke4dawn
Posts: 552
Joined: Sun Dec 13, 2009 10:44 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by blacke4dawn » Thu Jun 21, 2012 12:12 pm

Fully possible that there is some block somewhere. There are so many steps in this that it's very hard to pinpoint the exact place of failure, and there is only so much the devs of the client can do.

drohr
Posts: 1
Joined: Sat Jun 23, 2012 9:05 pm

Re: Magnet link stuck with "torrent metadata needed"

Post by drohr » Sat Jun 23, 2012 9:07 pm

I'm having the same issue. Never had any issues with Transmission before. Installed a new computer at home. Migrated my settings. After this every magnet link gets stuck. They where working instantly before.

Tried redownloading, removing settings. Nothing works. Tested uTorrent, and that works perfectly. Seems to be some issue that stops Transmission from working with magnet links.

Post Reply