Suddenly Pausing

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
themacguru
Posts: 2
Joined: Thu Feb 07, 2013 5:56 pm

Suddenly Pausing

Post by themacguru » Thu Feb 07, 2013 5:59 pm

I've been using Transmission for YEARS without a problem and then suddenly, today, once I start a torrent (magnet link usually) after it starts going about 2 minutes it automatically pauses. AND if I had ticked a few boxes of the downloads (not needed) in the info/file pane they all come back ticked.

Any ideas?

Jordan
Transmission Developer
Posts: 2311
Joined: Sat May 26, 2007 3:39 pm
Location: Titania's Room

Re: Suddenly Pausing

Post by Jordan » Thu Feb 07, 2013 6:33 pm

Is there an error message for that torrent?

One thing I've seen that has symptoms similar to this is if you start downloading to a directory that you don't have permissions to, or is full, etc... the torrent will download blocks into its memory cache, and then after a few minutes hit an I/O error writing to disk, set the error message, and pause the torrent.

themacguru
Posts: 2
Joined: Thu Feb 07, 2013 5:56 pm

Re: Suddenly Pausing

Post by themacguru » Thu Feb 07, 2013 9:35 pm

Thanks for replying, Jordan.

I didn't get an error message but, because of what you said, I quit Transmission after deleting the paused torrents and changed my download directory to something else (and back to what it was) and redownloaded the torrents and (as of now) it's all working. Seems like it was the directory thing and somehow permissions may have gotten messed up somewhere, though I don't know how.

Cheers
Brian

btw I am running OSX

magneticmoose
Posts: 3
Joined: Sat Mar 23, 2013 12:40 am

Re: Suddenly Pausing

Post by magneticmoose » Sat Mar 23, 2013 12:54 am

I've been experiencing this pausing of torrents all of a sudden. I recently moved my directory/seed folder to a new hard drive, but all my existing seeds work and I am able to download some files. I have a feeling it has to do with a 'full disk' issue, but both my internal hard drive (where I have downloaded the torrent) and external drive (where both my Transmission data directory and where the 'Incomplete' folder is) have plenty of room. The files begin to download and then pause and I get the yellow triangle/exclamation point and then they're stuck.

I've disk checked the external drive and set it to ignore ownership, too. I've also tried themacguru's method above with changing the directory location and redownloading the torrents, but all to no avail.

Anyone have any ideas? These are larger files (over 1GB); is there a memory cache setting/configuration I'm missing? I've downloaded files of this size previously... Thanks in advance for any help.

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Suddenly Pausing

Post by x190 » Sat Mar 23, 2013 6:34 am

What is the error message for that torrent? Check logs (debug or level 3) and gui.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

magneticmoose
Posts: 3
Joined: Sat Mar 23, 2013 12:40 am

Re: Suddenly Pausing

Post by magneticmoose » Sat Mar 23, 2013 7:16 pm

I tried it out again this morning by downloading a smaller file (200 MB) and I'm now getting a "Couldn't create volume..." error, a "Permissions denied" error and a "No data found error" (see attached). As mentioned in my earlier post, I've repaired the external hard disk, told it to ignore ownership and have ensured that Transmission is looking in the right place for the directory of seeds. As I said, yesterday it was also giving me the "disk full" error with larger files.

Thanks!
Screen Shot 2013-03-23 at 12.04.25 PM.png
Screen Shot 2013-03-23 at 12.04.25 PM.png (93.33 KiB) Viewed 5434 times

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Suddenly Pausing

Post by x190 » Sun Mar 24, 2013 8:06 pm

"No data found error" (see attached).
You need to pay attention to that message and point Transmission to the data and verify as necessary. Always fully mount your external drive before starting Transmission and quit Transmission before unmounting your external drive.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

magneticmoose
Posts: 3
Joined: Sat Mar 23, 2013 12:40 am

Re: Suddenly Pausing

Post by magneticmoose » Mon Mar 25, 2013 8:30 pm

That's what's so confusing (and frustrating) about my experience. I'm pointing Transmission to the right volume/folder, have tried 'move data file to' for new transfers, have tried 'verifying local data' and, through this episode, I have left my external disk connected (it's actually never unmounted while Transmission is running). As far as I can see, I've done everything I need to do...

I still think it has something to do with my recent switch to a new hard drive. Even though I got existing files to continue seeding, new ones cannot be added. However, I can add new files via a newly installed torrent downloader...

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Suddenly Pausing

Post by x190 » Tue Mar 26, 2013 4:28 pm

What is the exact name of your external drive? Have you tried a clean install?

#1 Move the following folders/files to your Desktop for later disposal.

~/Library/Application Support/Transmission (.torrents can be found here and can be re-added to Transmission. Use "Move Data File To..." (enclosing folder) and "Verify Local Data" as necessary.)
~/Library/Preferences/org.m0k.transmission.LSSharedFileList.plist
~/Library/Preferences/org.m0k.transmission.plist (re-do Preferences after installation)
~/Library/Caches/org.m0k.transmission

"~" = your home folder.
http://osxdaily.com/2011/07/22/access-u ... os-x-lion/

#2 Trash the .app.

#3 D/l a fresh copy and re-install application.

http://www.transmissionbt.com/download/
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

dashwood
Posts: 4
Joined: Mon Jun 06, 2011 6:42 pm

Re: Suddenly Pausing

Post by dashwood » Mon Dec 08, 2014 7:53 pm

Having the exact same problem. Super annoying.

Post Reply