Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
The_TiPi
Posts: 2
Joined: Mon Nov 23, 2015 8:57 pm

Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Post by The_TiPi » Mon Nov 23, 2015 9:17 pm

Hi all.

All is in the title.

I'm using Transmission-daemon on a Raspberry Pi 2 using Raspbian.
Until Sunday, I was using Wheezy Raspbian with Transmission 2.7x (don't remember the exact version) and everything was fine in my world.
I updated to Jessie Raspbian and also update Transmission to 2.84 (14307).
Transmission was not working properly.
I spent 3 hours to find that /etc/transmission-daemon/settings.json (with all my ports/directory/user name & password) must bo moved to /var/lib/transmission-daemon/.config/transmission-daemon/settings.json to be read.
I fixed the good values to the new file. All works fine (I cans access remotely, files download where they are suposed to be) except one thing : the owner of the new downloaded files.
They are all owned by debian-transmission.

This new version of Transmission-daemon don't read my /etc/init.d/transmission-daemon (the one setting the owner).
With the wrong owner, I can't easily move, rename or delete files.

Where must I go to make transmission-daemon change by itself the owner of a downloaded file ??

Thanks to the one who can point me the right direction :)

dentex
Posts: 4
Joined: Thu Jan 07, 2016 1:39 pm

Re: Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Post by dentex » Thu Jan 07, 2016 2:05 pm

The_TiPi wrote:...
I spent 3 hours to find that /etc/transmission-daemon/settings.json (with all my ports/directory/user name & password) must be moved to /var/lib/transmission-daemon/.config/transmission-daemon/settings.json to be read...
Hi,
I came here searching for the reason why my transmission-daemon needs a `sudo service transmission-daemon reload` at every boot, for the web interface to be accessed (but that's probably unrelated).

Anyway, coming at you: from what I understand, the config file in /etc must NOT be moved into /var/lib, because there you have already its symlink; from my RPi:

Code: Select all

sudo ls -l /var/lib/transmission-daemon/.config/transmission-daemon/
total 20
drwxr-xr-x 2 debian-transmission debian-transmission 4096 Jan  7 11:44 blocklists
-rw------- 1 debian-transmission debian-transmission  622 Jan  7 14:29 dht.dat
drwxr-xr-x 2 debian-transmission debian-transmission 4096 Jan  7 14:36 resume
lrwxrwxrwx 1 root                root                  38 Dec 25  2014 settings.json -> /etc/transmission-daemon/settings.json  <--- LOOK HERE
-rw------- 1 debian-transmission debian-transmission  142 Jan  7 13:05 stats.json
drwxr-xr-x 2 debian-transmission debian-transmission 4096 Jan  7 13:07 torrents
AFAIK, to change the downloads ownership, you should manually change the $USER variable into the init script at /etc/init.d/transmission-daemon. I never tried this for security reasons.
Instead, to prevent any permission issue, I changed the umask value in /etc/transmission-daemon/settings.json to be 0, as suggested into the wiki
I also have the download folder in my /home/pi and this is world-writable; this comes from previous trials/errors and possibly it's not needed.

mailliw
Posts: 2
Joined: Tue Mar 10, 2015 4:44 pm

Re: Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Post by mailliw » Wed Jan 27, 2016 7:49 pm

The_TiPi. Did you resolve this? I've spent four hours on it until I found your post. I'm certain it must be a bug in the Jessie build. It's impossible to change the user and/or permissions. Can't write locally or remotely.

I am going mad! Any progress?

The_TiPi
Posts: 2
Joined: Mon Nov 23, 2015 8:57 pm

Re: Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Post by The_TiPi » Sat Feb 06, 2016 3:43 pm

Hi,

In fact I gave up and went back to Whezzy.
As my torrent source stoped push conexion to Transmission to RSS only, I manage to setup flexget following this tutorial ( http://tinyurl.com/hev2bnj ).

With this running smooth, I finaly decided to move to Jessie again.

@Dentex : Don't know if it's because it's a system update (that brake the symlink) but I do have to move the .json pref file to be read.
As you mentioned, I did changed $USER in the /etc/init.d/transmission-daemon file. This file is not read (AFAIK) That THE problem that make me open this topic ;)
The owner problem is this one for me : I access my download directory on my Mac. I identify myself as pi, but as the files are owned by debian-transmission, I can't move or delete them on the Mac side.
I first have to chown the files in SSH, then I can to what I want on the Mac side.

This is a little con side of the Jessie update as on the pro side I gain a more reactive Owncloud server on my Raspbery Pi :)

@mailliw: A little "sudo chown pi:pi yourDownloadedStuff" (add -R if it's a directory for recurciv action) should fix the thing.
My download directory is chown root:root and chmod 777

killemov
Posts: 413
Joined: Sat Jul 31, 2010 5:04 pm

Re: Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Post by killemov » Sat Mar 26, 2016 12:38 pm

Debian Jessie moved to systemd as the default service framework making /etc/init.d scripts useless.

chernyshaw
Posts: 1
Joined: Tue Jan 28, 2020 6:47 pm

Re: Transmission-daemon 2.84 don't read /etc/init.d/ start pref file

Post by chernyshaw » Tue Jan 28, 2020 7:03 pm

Got it!

All this changes don't take effect:
/etc/default/transmission-daemon
/etc/init.d/transmission-daemon
/etc/init/transmission-daemon.conf

In fact you should change this one:
/lib/systemd/system/transmission-daemon.service

You can specify user and settings.json:

Code: Select all

...
User=your_user
ExecStart=/usr/bin/transmission-daemon -f --log-error --config-dir your_path_to_settings.json_dir
...

Post Reply