Transmission on linux and yet another permissions problem

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
last_of_us
Posts: 1
Joined: Mon Oct 15, 2018 9:50 am

Transmission on linux and yet another permissions problem

Post by last_of_us » Mon Oct 15, 2018 10:51 am

Hi!

Ok, here is the situation...

Transmission is working as transmission-daemon on Debian 9.5 Stretch.
Incomplete dir is: /home/share/temp
Complete dir is: /home/share/volume1/Downloads

Now, incomplete directory is local, and complete directory is remote. Remote directory is on different linux machine and /home/share/volume1/ is a mountpoint. It looks like this:

/home/share/volume1/Downloads
blue - local, green - remote

Remote directory Downloads is set to 0777 for nobody:nogroup.

From local machine shell:
ls -ld Downloads/
drwxrwxrwx 5 nobody nogroup 0 Oct 14 17:30 Downloads/
From remote machine shell:
ls -ld Downloads/
drwxrwsrwx 287 nobody nobody 36864 Oct 14 13:41 Downloads/
Now here is problem. After Transmission download torrent it tries to move to Downloads directory, and fails. One thing is it can create folder inside Downloads directory, but can't create file inside it. Here's an example:
ls -l
drwxr-xr-x 2 nobody nobody 4096 Oct 14 16:41 Example.Movie.Directory.x264-ZZZ
And You can see it, Transmission create directory with no write permissions for group and other and that's why it fails.

In settings.json I had umask set to 2, I even try to set it to 0 but it still not working as should.

So my question is how to force Transmission to create directory with write permissions?

This is command used to mount remote filesystem:
mount -t cifs //[LOCAL_IP_HERE]/Volume_1 /home/share/volume1 -o rw,_netdev,iocharset=utf8,guest,uid=nobody,gid=nogroup,x-systemd.automount
PS. This worked for me until I changed system on remote machine. It was outdated linux distro then, and it's different linux distro now.

Post Reply