QNAP Debian, high CPU usage

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
vstancea
Posts: 1
Joined: Sat Jan 19, 2019 1:23 pm

QNAP Debian, high CPU usage

Post by vstancea » Sat Jan 19, 2019 1:47 pm

Hello,

I've been using Transmission for years now on my old QNAP TS 212P, until I replaced the original firmware with Debian since it started to get extremely laggy. Transmission used to work flawlessly without any issues.

On Debian, I've installed the official package, only the deamon and CLI. When I download even one torrent, Transmission uses almost 100% of my CPU and the load is at 1.2-1.4.

The hardware isn't the best, a single core Marvell arm5 1Ghz with 512mb but until now, transmission run without any issues.

I've included all the info I thought my be of any help.

Code: Select all

vstancea@192-168-0-100:~$ uname -a
Linux 192-168-0-100 4.9.0-8-marvell #1 Debian 4.9.130-2 (2018-10-27) armv5tel GNU/Linux

Code: Select all

free -h
              total        used        free      shared  buff/cache   available
Mem:           501M         81M         98M        2.8M        322M        406M
Swap:          488M        2.1M        486M

Code: Select all

    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "http://www.example.com/blocklist",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/home/vstancea/Downloads/Downloaded",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/home/vstancea/Downloads/Incomplete",
    "incomplete-dir-enabled": true,
    "lpd-enabled": false,
    "max-peers-global": 200,
    "message-level": 1,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 200,
    "peer-limit-per-torrent": 50,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": false,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 0,
    "ratio-limit-enabled": true,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": true,
    "rpc-password": "{7d5e682c083da272ad9fedccfbf1fab4fdb64859CzIqikBk",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "vstancea",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": true,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-limit": 100,
    "upload-limit-enabled": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true,
    "watch-dir": "/home/vstancea/Downloads/Watch",
    "watch-dir-enabled": true

killemov
Posts: 419
Joined: Sat Jul 31, 2010 5:04 pm

Re: QNAP Debian, high CPU usage

Post by killemov » Tue Jan 22, 2019 8:40 am

vstancea wrote:I've been using Transmission for years now on my old QNAP TS 212P, until I replaced the original firmware with Debian since it started to get extremely laggy. Transmission used to work flawlessly without any issues.
So first no issues, then laggy, then replace with Debian and then 100% CPU usage. I have almost the same setup and only get that load when starting Transmission or verifying torrents. Run top and iotop for a while to see what's what. It could be as simple as running on the wrong filesystem (NTFS).

Post Reply