Transmission (CLI) on Ubuntu: "No data found" and "Permission denied" errors, despite fully writeable?

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
Theo Racle
Posts: 7
Joined: Sun Mar 15, 2015 10:23 am

Transmission (CLI) on Ubuntu: "No data found" and "Permission denied" errors, despite fully writeable?

Post by Theo Racle » Wed Jan 08, 2020 2:43 pm

Just installed the latest CLI version of Transmission on Ubuntu (used `sudo apt install transmission-daemon transmission-common transmission-cli`).

Then I stopped the service, edited the /etc/transmission-daemon/settings.json file to specify the following settings:

Code: Select all

"download-dir": "/home/theo/torrents/download",
"incomplete-dir": "/home/theo/torrents/incomplete",
"incomplete-dir-enabled": true,
First I created these folders and made them fully writable (using `chmod 777`). And then restarted the service.

However, when I add a torrent, it seems to download the first 4MB (i.e. the cache size) and then gives one of these errors:
Error: No data found! Ensure your drives are connected or use "Set Location". To re-download, remove the torrent and re-add it.
or
Error: Permission denied (/home/theo/torrents/download/ubuntu-19.10-live-server-amd64.iso)
I see these errors when I query the individual torrents' info, using `transmission-remote -t 1 -i`.

I even tried changing ownership of the download and incomplete folders to debian-transmission (using `sudo chown debian-transmission download` and similar for incomplete). And stopped + restarted the service again, and even rebooted the entire system, and added the torrents anew. But to avail.

Nothing appears in either folder.

It seems to be a permission issue, but I have no clue what's causing it.

I remember struggling with this a long time ago, on a previous system, but can't remember how I worked around this. As for the "No data found! Ensure your drives are connected" error, obviously the folders are there. I can access them just fine myself. Also there's plenty of space available (over 600 GB).

What am I doing wrong?
The dilemma for the individual is NOT that it can't get what it wants, the dilemma IS the individual. ~Tony Parsons

Post Reply