Unable to set rmem_max and wmem_max

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
brisdude
Posts: 5
Joined: Wed May 23, 2018 10:36 am

Unable to set rmem_max and wmem_max

Post by brisdude » Tue Jan 21, 2020 4:38 pm

[Ubuntu 18.04.3]

I'm getting the following non-fatal warnings when I start up transmission:

Code: Select all

UDP Failed to set receive buffer: requested 4194304, got 425984 (tr-udp.c:84)
UDP Failed to set send buffer: requested 1048576, got 425984 (tr-udp.c:95)
so I've added the following lines to /etc/sysctl.conf:

Code: Select all

net.core.rmem_max = 4194304
net.core.wmem_max = 1048576
However, when I run

Code: Select all

sysctl -p
I get:

Code: Select all

sysctl: cannot stat /proc/sys/net/core/rmem_max: No such file or directory
sysctl: cannot stat /proc/sys/net/core/wmem_max: No such file or directory
I can't see any way that I can modify /proc/sys/net/core to allow the values to be written there, so I'm stuck. I've enabled root and tried, for example:

Code: Select all

sudo -s -H
echo 4199304 > /proc/sys/net/core/rmem_max
but all this returns is:

Code: Select all

bash: /proc/sys/net/core/rmem_max: No such file or directory
Does anyone know how to get around this please?

Post Reply