[Server][Apache][Https] Error 404 : Object not found

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
definer
Posts: 1
Joined: Sat Apr 11, 2020 8:20 am

[Server][Apache][Https] Error 404 : Object not found

Post by definer » Sat Apr 11, 2020 8:35 am

Hi,
i installed transmission-cli on my archlinux server. The daemon is working since i can reach it through tunneling from my remote desktop.
I tried setting up apache for web access but I only got the error in the object.

As I said, I'm using Apache as webserver, and Let's Encrypt as certificate provider. This is my transmission.conf:

Code: Select all

<VirtualHost *:80>
        ServerName example.com
        ServerAlias www.example.com
        Redirect permanent /transmission https://example.com/transmission
</Virtualhost>

<VirtualHost *:443>
        ServerName example.com
        ServerAlias www.example.com
        Redirect permanent /transmission https://example.com/transmission

        RewriteEngine on
        RewriteRule /transmission[/]?$ /transmission/web/ [R]

        ProxyRequests On
        ProxyPreserveHost Off

        <Proxy *>
                Order allow,deny
                Allow from all
        </Proxy>

        <location /transmission>
                ProxyPass http://127.0.0.1:9091/transmission
                ProxyPassReverse http://127.0.0.1:9091/transmission
        </location>
</Virtualhost>
This is my settings.json:

Code: Select all

{
    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "http://www.example.com/blocklist",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/data/Torrents/Downloads",
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/data/Torrents/Downloads",
    "incomplete-dir-enabled": false,
    "lpd-enabled": false,
    "message-level": 1,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 200,
    "peer-limit-per-torrent": 50,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": true,
    "rpc-password": "MASKED",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "hereiam",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist-enabled": true,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true
}
Any idea about the problem? Tell me if you need more info.
Very thanks

EDIT:
I tried the following urls, without luck:
https://example.com/transmission
https://example.com/transmission/
https://example.com/transmission/web
https://example.com/transmission/web/

Post Reply