Tranmission-daemon with watch-dir

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
naruto
Posts: 4
Joined: Thu Jan 07, 2010 7:47 pm

Tranmission-daemon with watch-dir

Post by naruto » Thu Jan 07, 2010 7:56 pm

Hi,

I recently bought a Qnap 219p and installed Tranmission on it.

Transmission daemon, scripts, autorun, ... are running smoothly.
It also runs as another users with sudo command.

The only thing missing and not working is the watch-dir.

I tried to troubelshoot it, but for now I'm stuck.

Build of transmission that I'm using:
Package: transmission
Version: 1.76-1
This is however a ipkg specifically for the arm architecture of the qnap.
Probably the once using the intel architecture on the qnap experience the same problem.

Transmission-daemon fails to start with watch dir enabled.
I tried this with the settings.json file and as the command option -c or --watch-dir

The problem is I don't see any error message, not even when I redirect the output to a file. (not sure if I do this correctly)

I have seen the same issue on one of the networkmediatank forums.
Somebody was using a popcorn media hour and had the exact same problem.
This issue is still not fixed neither.

Maybe this will be solved with the new release (1.80)?
Or do I need to compile it myself (no idea how)

Can anybody help me or point me in the good direction.

Update 1:
So it seems there is an option to do a littlebit of debugging.
Ran transmission-daemon with option -f.
Following messages apear
[10:59:36.162] Watching "/opt/etc/transmission/watch/" for new .torrent files
[10:59:36.162] Using inotify to watch directory "/opt/etc/transmission/watch/"
[10:59:36.162] Unable to watch "/opt/etc/transmission/watch/": Function not implemented

At at the end a "segmentation fault".
I only get the segmetation fault when the watch dir settings in the config are enabled

Does this mean it is not compiled with the watch-dir option?
Also I tried to export_nopoll= 0 or 1
Same result

Cheers
Pascual
Last edited by naruto on Wed Jan 27, 2010 4:06 pm, edited 1 time in total.

elBradford
Posts: 4
Joined: Sun Dec 27, 2009 6:48 pm

Re: Tranmission-daemon with watch-dir

Post by elBradford » Fri Jan 22, 2010 9:29 pm

I can confirm it works on 1.80. I just installed it and the watch directory works just fine on my armel architecture. This was my first build from source and it was really easy, just look at this page for instructions (they're very easy to follow if you're on ubuntu/debian): http://trac.transmissionbt.com/wiki/Building

ahallam
Posts: 1
Joined: Sat Jan 23, 2010 3:55 pm

Re: Tranmission-daemon with watch-dir

Post by ahallam » Sat Jan 23, 2010 4:05 pm

I'm having the same problems. Attempting to enable watch-dir on my QNAP TS410 (transmission 1.80 installed via ipkg) results in a segmentation fault, where Transmission then overwrites settings.json with defaults. The previous 1.7 build indicated that the watch-dir feature wasn't enabled, before doing much the same thing and wiping the settings.

I'm not knowledgeable enough to really go about debugging the thing myself, though I consider Transmission's behaviour in returning to default settings badly behaved. It's an extreme pain to have to rewrite settings.json each time Transmission decides that It didn't like what you put in there in the first place.

Can anybody confirm/deny that the watch-dir feature actually works when transmission is installed from ipkg?

lazybones
Posts: 220
Joined: Sun Jan 24, 2010 12:41 am

Re: Tranmission-daemon with watch-dir

Post by lazybones » Mon Jan 25, 2010 8:11 am

I installed transmission 1.80 via ipkg on my linkstation nas seems to work great, I have confirmed that the watch directory works.. and have been running for several days.

naruto
Posts: 4
Joined: Thu Jan 07, 2010 7:47 pm

Re: Tranmission-daemon with watch-dir

Post by naruto » Wed Jan 27, 2010 9:56 am

So I upgrade to version 1.80 of transmission
Still cannot manage to get it working

Tried with a complete clean install
Same results... well not exactly the same

When I now enable the watch-dir option in the json file, I get just a segmentation fault
When I set watch-dir to: false, transmission starts fine

I will have a closer look this weekend and let you know

Fingers crossed :mrgreen:

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Tranmission-daemon with watch-dir

Post by x190 » Wed Jan 27, 2010 10:09 am

The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

naruto
Posts: 4
Joined: Thu Jan 07, 2010 7:47 pm

Re: Tranmission-daemon with watch-dir

Post by naruto » Wed Jan 27, 2010 4:04 pm

An strace on when I start the daemon, gave me the following:

inotify_init() = -1 ENOSYS (Function not implemented)
inotify_add_watch(-1, "/root/.config/transmission-daemon/watch/", IN_CLOSE_WRITE|IN_MOVED_TO|IN_CREATE) = -1 ENOSYS (Function not implemented)

It seems it is not implemented in this version (= 1.80 ipkg Qnap ARM architecture) or is it a problem with a kernel-module on my NAS.

I checked the maintainer with ipkg info and contacted him through mail. I'm waiting his reply.

Any other help is welcome

jackalope
Posts: 8
Joined: Sat Mar 13, 2010 11:00 am

Re: Tranmission-daemon with watch-dir

Post by jackalope » Sat Mar 13, 2010 11:04 am

same problem on ts-119 too...anyone can help?

thanks

Jordan
Transmission Developer
Posts: 2311
Joined: Sat May 26, 2007 3:39 pm
Location: Titania's Room

Re: Tranmission-daemon with watch-dir

Post by Jordan » Sun Mar 14, 2010 10:52 pm

If inotify doesn't work on your platform, then the package should compile transmission-daemon with inotify turned off. Seems pretty clear-cut to me...

naruto
Posts: 4
Joined: Thu Jan 07, 2010 7:47 pm

Re: Tranmission-daemon with watch-dir

Post by naruto » Mon Mar 15, 2010 7:30 pm

Thanks for your reply to my post
For you it seems clear, but not to me ;-)

I thougt of compiling the package for my system myself, but since I'am not a linux/unix expert, I don't dare to mess with my system

So any hints are welcome

Post Reply