QNAP 4.3.3

Feature requests not specific to either the Mac OS X or GTK+ versions of Transmission
Andrewkha
Posts: 8
Joined: Wed Sep 05, 2012 10:30 am

QNAP 4.3.3

Postby Andrewkha » Tue Apr 18, 2017 6:36 am

Hi!

I used Transmission on my QNAP device for a long time and was absolutely happy with it. Now I upgraded my NAS to 4.3.3 firmware and no longer supports Transmission. Are there any plans to make Transmission available and working on 4.3.3? Thanks!

wasabi
Posts: 1
Joined: Fri Apr 21, 2017 4:11 am

Re: QNAP 4.3.3

Postby wasabi » Fri Apr 21, 2017 4:17 am

Same here. Any help will be appreciated. 64 bits transmission needed for upgrading to firmware 4.3.3

Andrewkha
Posts: 8
Joined: Wed Sep 05, 2012 10:30 am

Re: QNAP 4.3.3

Postby Andrewkha » Fri Apr 21, 2017 7:06 am

I solved it. Downloaded manually from http://www.qnapclub.eu/index.php?act=detail&qpkg_id=208
Default login/pass qnap
You can later change it via settings.json

ryan618
Posts: 1
Joined: Mon Apr 24, 2017 2:12 pm

Re: QNAP 4.3.3

Postby ryan618 » Mon Apr 24, 2017 2:15 pm

Andrewkha wrote:I solved it. Downloaded manually from http://www.qnapclub.eu/index.php?act=detail&qpkg_id=208
Default login/pass qnap
You can later change it via settings.json

Hi~ Thanks for your post! Could you tell how to edit settings.json ? I can't find the correct way to edit it. Thanks!

Andrewkha
Posts: 8
Joined: Wed Sep 05, 2012 10:30 am

Re: QNAP 4.3.3

Postby Andrewkha » Mon Apr 24, 2017 2:18 pm

Stop Transmission, edit values
"rpc-username"
"rpc-password"

And then start transmission

lilsez
Posts: 2
Joined: Tue Apr 25, 2017 5:31 pm

Re: QNAP 4.3.3

Postby lilsez » Tue Apr 25, 2017 5:35 pm

Hi Sorry having issues login in

What is the default username and password?

Thanks


Andrewkha wrote:I solved it. Downloaded manually from http://www.qnapclub.eu/index.php?act=detail&qpkg_id=208
Default login/pass qnap
You can later change it via settings.json

Andrewkha
Posts: 8
Joined: Wed Sep 05, 2012 10:30 am

Re: QNAP 4.3.3

Postby Andrewkha » Tue Apr 25, 2017 5:38 pm

Read carefully. qnap is the default login/password

lilsez
Posts: 2
Joined: Tue Apr 25, 2017 5:31 pm

Re: QNAP 4.3.3

Postby lilsez » Tue Apr 25, 2017 5:49 pm

:) I knew it was something in front of me that I was missing thank!!!

I have been struggling and frustrated with this new qnap firmware for a few days now this was the final fix.

Thank you again!

Andrewkha wrote:Read carefully. qnap is the default login/password

Shubus
Posts: 1
Joined: Sun May 07, 2017 9:22 pm

Re: QNAP 4.3.3

Postby Shubus » Sun May 07, 2017 9:28 pm

Could someone give me a hint as to where Settings are? This version is is quite different.

Diejeitor
Posts: 2
Joined: Sat May 13, 2017 12:32 pm

Re: QNAP 4.3.3

Postby Diejeitor » Sat May 13, 2017 12:35 pm

Shubus wrote:Could someone give me a hint as to where Settings are? This version is is quite different.



/share/CACHEDEV1_DATA/.qpkg/QTransmission/etc/settings.json

First¡¡¡¡

Stop the QTransmission¡¡

aikideshi
Posts: 2
Joined: Mon May 22, 2017 11:02 am

Re: QNAP 4.3.3

Postby aikideshi » Mon May 22, 2017 11:05 am

Any idea when QNAP TS-431P will have a compatible Transmission client available? I tried Transmission and the one in the QNAP App Store. They both cause QNAP to hang with 4.3.3. So, no choice but to downgrade to 4.2.5 at the moment. Any ETA? Thanks.

aikideshi
Posts: 2
Joined: Mon May 22, 2017 11:02 am

Re: QNAP 4.3.3

Postby aikideshi » Mon May 22, 2017 6:16 pm

Andrewkha wrote:I solved it. Downloaded manually from http://www.qnapclub.eu/index.php?act=detail&qpkg_id=208
Default login/pass qnap
You can later change it via settings.json


I've tried this but it still crashes 4.3.3. I've gone back to 4.2.5. When will there be an update which will be compatible with 4.3.3? Thanks.

DocCaliban
Posts: 1
Joined: Thu Aug 31, 2017 12:26 am

Re: QNAP 4.3.3

Postby DocCaliban » Thu Aug 31, 2017 12:31 am

Hello, and thank you for the link to the installation package!

I have everything running, but I have two issues which are probably related.

1. If I change the user name and password from the default "qnap"/"qnap", none of the torrents can then connect to trackers. Switching it back makes it work again.

2. I log into my NAS with an admin account, but not the "Admin" account. It seems that Transmission is creating files as folders as "Admin", so I am not able to remove or change them without messing around with permissions. How can I get Transmission to use the other account?

Thanks in advance,

-Doc

EDIT: After further reading of the config file contents, it looks like changing the
"umask": 18, to "umask": 0, should fix it.


Return to “Requests”