Transmission cannot connect to tracker

Ask for help and report issues with the Mac OS X version of Transmission
pmmalmeida
Posts: 2
Joined: Tue May 14, 2013 8:57 pm

Re: Transmission cannot connect to tracker

Postby pmmalmeida » Fri May 17, 2013 11:09 pm

x190 wrote:Is your ISP blocking ports?


Sorry I forgot to mention... Using other torrent clientes on other machines in the same networks works fine.
How can I be sure my ISP is not blocking any ports?

sysmaster
Posts: 1
Joined: Mon Jul 08, 2013 10:21 pm

Re: Transmission cannot connect to tracker

Postby sysmaster » Mon Jul 08, 2013 10:32 pm

Funny I too have the same problem, also with 2.52, however not on Mac. (Updating this would be a horror here on my Debian (stable) box, since at least the .deb package of 2.7X requires libssl 1.0.0 and that would probably break more than 25 programs relating on 0.9.8 ...nah thanks)

Anyways...that problem is definitely there, and it must be T. related.

My scenario is probably way simpler than some of your guys' ones:

- Started downloading torrent, link was a magnet link (as usual these recent days). Worked perfectly.
- Figured out -OOPS- I don't have enough disk space, so I PAUSED the download, moved Location, and RESUMED the download.
- Now all trackers showed 'Connection error' in red.
- Even after 20 minutes, nothing happened.
[*]- Deleted files already downloaded (weren't much anyway) plus the torrent, then re-imported magnet link.

- Result: Magnetizing...yadayada...stayed at 0.00% for minutes, even though it dl'ed at hyper-speed when I first started it.
- OK. Set 'Randomize network port', restarted client, started from step [*] again, worked a treat.

Conclusion:
The fact THAT you have to restart the client everytime you pause magnet-driven downloads (because of the fact that it will NEVER connect to any tracker again after resuming d/l) is clearly a BUG. This simply must not happen, as it annoys the hell out of users.
As a provisorical approach, one could add a button that behaves as if the client was restarted (like 'Initialize all' or something). Because the way it is currently is not acceptable for me.

staxtopoutanos
Posts: 1
Joined: Wed Jul 31, 2013 6:31 pm

Re: Transmission cannot connect to tracker

Postby staxtopoutanos » Wed Jul 31, 2013 6:47 pm

I had this problem too.After reading some posts and a few re-install ...i changed the "the peer listening port" from manual (51413, the default port).... and checked "Randomize port on launch".It worked.Transmission is for me the best but this issue irritated me a lot hope it will be fixed in future updates.Thanx to the Transmission Team for their work.

harlock59
Posts: 5
Joined: Sat Mar 12, 2011 12:56 am

Re: Transmission cannot connect to tracker

Postby harlock59 » Thu Mar 30, 2017 11:11 am

i have the same issue on transmission 2.92+ on windows

BalleClorin
Posts: 13
Joined: Sun Jan 10, 2010 9:27 pm

Re: Transmission cannot connect to tracker

Postby BalleClorin » Mon Apr 10, 2017 8:20 am

I had a similar problem, and it turned out to be a fault in the "bind-address-ipv6" setting in settings.json.

slam
Posts: 4
Joined: Tue Apr 25, 2017 5:45 pm

Re: Transmission cannot connect to tracker

Postby slam » Mon May 15, 2017 4:06 pm

The Transmission app doesn't use settings.json, does it? My installation doesn't even have that file.


Return to “Mac Support”