Transmission Big Sur Issues

Ask for help and report issues with the Mac OS X version of Transmission
macbrush
Posts: 2
Joined: Wed Apr 14, 2021 7:48 am

Re: Transmission Big Sur Issues

Post by macbrush »

Well... at this point I pretty much given up on Transmission.
Carbonide
Posts: 1
Joined: Sun May 23, 2021 4:51 pm

Re: Transmission Big Sur Issues

Post by Carbonide »

Me too, after several frustrating months quitting and restarting Transmission ormaking sure I don't exceed a couple of simultaneous torrents, I'm now using qBittorrent. I don't like its interface and somehow it only downloads at a fraction of Transmission speeds, but at least I can let it running without any fear of my active connections to stop suddenly.
mgnewman
Posts: 2
Joined: Mon Jun 22, 2009 2:04 pm

Re: Transmission Big Sur Issues

Post by mgnewman »

I wonder if this is actually a Big Sur issue. I'm still on Catalina and have notice recently that the chosen port gets closed after a while and Transmission grinds to a halt. If I click "Randomize", Transmission eventually finds an open port and resumes transfers. I gave up on a Little Snitch and uninstalled it several months ago, so that's not the problem. I'm using an AirPort Extreme with "Enable NAT Port Mapping Protocol" enabled. This is with Transmission 3.0. I did not see this problem on prior versions.
cadoten306
Posts: 2
Joined: Sat Apr 10, 2021 7:03 pm

Re: Transmission Big Sur Issues

Post by cadoten306 »

What other apps are people using and how are they transferring their transmission half downloaded torrents to a new app?
auno
Posts: 1
Joined: Sat Jul 31, 2021 5:33 pm

Re: Transmission Big Sur Issues

Post by auno »

Im getting the same problems.
I add a torrent, it downloads a bit then stops downloading. It doesnt crash and I dont get the beachball but I have to quit and relaunch it otherwise it will just sit there doing nothing. When I relaunch, it starts downloading the torrents from 0%, even though it just downloaded some before and the part files are still there in the same folder.
Its really strange behaviour. I really hope they fix it soon. Its so bad that I cant use it any more. I cant remember the last time I used anything other than transmission. It must be ten years ago at least.
The client Im using now sucks.
Does anyone have a recommendation for a decent lightweight client to replace Transmission till they sort it out?
fuga
Posts: 35
Joined: Sun Feb 17, 2019 2:46 am

Re: Transmission Big Sur Issues

Post by fuga »

For whatever it might be worth, I'm merrily running Transmission v3.0 on Big Sur on an M1 iMac. 1,248 torrents.
laweco
Posts: 1
Joined: Tue Aug 10, 2021 10:39 pm

Re: Transmission Big Sur Issues

Post by laweco »

Try going into system preferences>Security & Privacy>Firewall>Firewall Settings. Add or remove and then re-add Transmission, set to allow incoming. This immediately fixed the issue for me.
scappata
Posts: 4
Joined: Sat Aug 07, 2021 2:16 am

Re: Transmission Big Sur Issues

Post by scappata »

FYI it's working perfectly for me. Transmission v3 on Big Sur on both a 16" 2.3 GHz i9 MacBook Pro and M1 iMac. And damn glad as my trusty qBittorrent sucks (just for me?) on the M1. :shrug:
jamver
Posts: 2
Joined: Wed Aug 18, 2021 3:37 am

Re: Transmission Big Sur Issues

Post by jamver »

After struggling with this issue for quite a while, I've reverted to Transmission 2.94, and can report that everything so far appears to be working (unlike Transmission 3).
rstone5
Posts: 1
Joined: Sun Feb 25, 2018 11:29 pm

Re: Transmission Big Sur Issues

Post by rstone5 »

Try on the Network screen in Preferences (with microTP on) - Automatically Map Port.

I dunno, it worked for me...
jamver
Posts: 2
Joined: Wed Aug 18, 2021 3:37 am

Re: Transmission Big Sur Issues

Post by jamver »

That’s the problem. Automatic port mapping works initially, but after a while it fails and will not remap the port until you restart Transmission.

Transmission 2.94 doesn’t seem to suffer this problem, though it does crash occasionally.
jonahlee
Posts: 1
Joined: Fri Oct 08, 2021 6:56 pm

Re: Transmission Big Sur Issues

Post by jonahlee »

Yea having the exact same issues, switched back to 2.94 for now, sucks that it freezes up and doesn't have dark mode, but at least it works consistently instead of stopping every couple of minutes.

Oops, spoke too soon, now 2.9.4 is having the same issue on Big Sur 11.6.
Okida
Posts: 1
Joined: Wed Oct 13, 2021 8:53 pm

Re: Transmission Big Sur Issues

Post by Okida »

I have the exact same issue, Big Sur 11.6, M1, Transmission 3.0
No port forwarding. Funny thing is, it sometimes works, if I let it sit for ages. But not always.
Common issue is: it will download for a little while, then stop dead. Stopping, relaunching the app makes it download everything anew.
Tried everything suggested here, nothing helped.
Addendum: Reducing the list of torrents did help.
Post Reply