'No data found' for files that haven't been moved?

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
Chessur
Posts: 2
Joined: Tue Mar 01, 2011 2:25 am

'No data found' for files that haven't been moved?

Post by Chessur »

Several days ago (Friday the 25th February, I believe), Transmission stopped recognising my files. I download to and seed from an external hard-drive which I had not disconnected.

The message I'm receiving is as follows: 'Error: No data found! Ensure your drives are connected or use "Move Data File To...". To re-download, remove the torrent and re-add it.'

I have disconnected and reconnected the external drive where the files are located and restarted the computer and Transmission several times to no avail. When I select a torrent and choose 'Move Data File To,' Transmission brings up its correct current location.

Perhaps the strangest part is that one torrent, the one I downloaded most recently (it finished downloading the day the problem started), is not giving me an error message and is seeding properly. It is on the same drive as all the others, so I have no idea why it is the exception. I'm not currently downloading any files, but I have 62 torrents seeding. Obviously I don't want to delete the perfectly good downloaded files and re-download them just so I can continue seeding.

If anybody has any suggestions for how to get these files to seed again, I would be so grateful! It's very frustrating - I have only the most rudimentary computer skills and have exhausted all of my ideas...

I am using Transmission 2.20 with Mac OS X Version 10.5.8.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: 'No data found' for files that haven't been moved?

Post by x190 »

For the troublesome torrents try the following:

•Use 'Move Data File To...' again, ensuring that you are selecting the enclosing folder of the data not the data folder/file itself.
•Next select 'Verify Local Data' from the Transfers menu. After verification you should be able to resume seeding.
•From the Finders 'Go' menu select 'Go to Folder...' and go to '/Volumes' and if there is an entry with the same name as your external drive delete that entry.

Your external drive may have become unmounted for some reason but remounting it should have taken care of the problem.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------
Chessur
Posts: 2
Joined: Tue Mar 01, 2011 2:25 am

Re: 'No data found' for files that haven't been moved?

Post by Chessur »

Thanks so much for your reply! I was trying to direct Transmission to the wrong folders just as you suspected. :roll:
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: 'No data found' for files that haven't been moved?

Post by x190 »

Не за что! :)
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------
daanielaa
Posts: 1
Joined: Tue May 03, 2011 6:48 pm

Re: 'No data found' for files that haven't been moved?

Post by daanielaa »

help me please:( i dont understand what the enclosing folder means! ive tried everything,but i cant ,same problem as chessur :( please
it was almost done and its really slow torrent i dont want to downloaded again ;((((
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: 'No data found' for files that haven't been moved?

Post by x190 »

Well, if you usually download everything to your Downloads folder that would be the "enclosing folder". You shouldn't select any of the sub-folders even if they have torrent names.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------
bradpaulp
Posts: 5
Joined: Wed Sep 07, 2011 2:18 am

Re: 'No data found' for files that haven't been moved?

Post by bradpaulp »

I am having a similar issue to this except that I have my files saved to an NAS plugged into my router. I have the download goto the "public" share and after downloading it seeds fine and everything. But if I restart my computer and remount the Public Share, I get the "Error: No Data File Found!" Move data file to etc etc.

My NAS Public Share also gets mounted on startup btw.

I click to MOVE the data file to its location, but never does anything, always a yellow flagged error.

I can't really see what Im doing wrong, the NAS has a static IP so its not like its refreshing every time and transmission can't find it.
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: 'No data found' for files that haven't been moved?

Post by x190 »

You may find that a recent nightly from trunk-mac will resolve this issue. Use at your own risk. :)

https://build.transmissionbt.com/job/trunk-mac/
I click to MOVE the data file to its location, but never does anything, always a yellow flagged error.
Try following that procedure with 'Verify Local Data'. Also, ensure that you are selecting the enclosing folder of the data not the data folder/file itself.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------
Fenris
Posts: 1
Joined: Thu Oct 27, 2011 4:49 am

Re: 'No data found' for files that haven't been moved?

Post by Fenris »

I have a similar problem, and it frustrates me to no end.

Using Transmission ver 2.22 on a PPC G5 Mac.

What happens is that at some point, Transmission (or Finder) creates a Hidden Volume with the same name and path as the volume originally selected as the download destination.

So I will have selected my 2nd internal drive "MacHD/Dowloads" as the target folder, then at some point Transmission starts writing to my boot drive "BootHD/Volumes/MacHD/Downloads".
The result is that I'll have 60% of a 10gb torrent in the intended destination, and 5% in the hidden volume, plus the error messages "Data not found...move data...", "pieces corrupt...", etc.
I have successfully recovered some torrents by removing the transfer from the list and staring it again while pointing it to the original target location, but sometimes it will only allow me to select the false volume on the Boot drive.
Is this a Transmission error or something in Finder itself? I suspect it's Transmission because it seem to be convinced that the hard drive I'm directing the downloads to exists on the boot drive, and not separately.

To recap: Start the torrent and the download destination is selected: MacHD-->Downloads

Double check in Finder, the downloaded file exists in MacHD-->Downloads

Come home from work, I have the error messages mentioned previously, and now I have the downloaded file in MacHD--> Downloads as well as in BootHD-->Volumes-->MacHD-->Downloads

Attempts to move data are often unsuccessful as Transmission now seems to think that MacHD--> Downloads is the same as BootHD-->Volumes-->MacHD-->Downloads
and will not allow me to select the former. or allows me to select it, but treats it as the latter.

A real PITA.

Help?
x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: 'No data found' for files that haven't been moved?

Post by x190 »

This usually occurs when a drive becomes unmounted or isn't mounted before starting Transmission.
or allows me to select it
Are you following that by "Verify Local Data" ?

To try to concatenate the split files, here's a couple of options:

Image

• The following was provided by a forum poster:

Code: Select all

// for two files - hacked together, messy, etc. - proper version coming

#include <stdio.h>

int main () {
   FILE *a, *b, *out;
   int ca, cb;

   a = fopen ("1", "r");
   b = fopen ("2", "r");
   out = fopen ("out", "w");

   while (! (feof (a))) {
      ca = fgetc (a);
      cb = fgetc (b);

      if (ca != 0) {
         fputc (ca, out);
      }
      else if (cb != 0) {
         fputc (cb, out);
      }
      else {
         fputc (0, out);
      }
   }

   fclose (a);
   fclose (b);
   fclose (out);
}
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------
andydlux
Posts: 1
Joined: Sun Sep 22, 2013 12:59 pm

Re: 'No data found' for files that haven't been moved?

Post by andydlux »

Hi...

i have a similar problem with the exact same message... i dont have a external drive connected though, just using the laptop. i downloaded some movies lately and they all finished, after they were done i tested them in vlc player and they all worked perfectly. so the files are completely downloaded.
today when i opened transmission behind every file i downloaded is that error message and if i go to finder i cant find any of those files... like they are vanished.

any ideas on how i can recover them and why they are gone? pls help thx
carharot
Posts: 13
Joined: Wed Sep 26, 2012 2:14 pm

Re: 'No data found' for files that haven't been moved?

Post by carharot »

And if my disk has been destroyed and I had about 120 torrents and want to redownload it for new disk)))? with various (my) settings (I can set that some files don't download in torrent) for each torrent node etc? Must I redownload each torrent and re setting all moments for each one?
For utorrent I can just to recheck lost (empty) data for all that ones and the end.
Post Reply