Transmission 2.92 BREAKS PERMISSIONS - Stalls reboot/breaks OS if executed

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
VyseLegendaire
Posts: 3
Joined: Tue Mar 08, 2016 8:39 pm

Transmission 2.92 BREAKS PERMISSIONS - Stalls reboot/breaks OS if executed

Post by VyseLegendaire » Tue Mar 08, 2016 8:48 pm

transmission 2.92 - DO NOT INSTALL - BREAKS PERMISSIONS - Stalls reboot/breaks OS if executed

A few hours after installing 2.92, my computer shut down without warning and when starting up, gave permissions errors about 'Security Agent can only be accessed by Apple software' - and wouldn't start up at all, forcing me to run permissions and disk repair checks via external drives until I could boot without T 2.92 running an active process.

I know 2.92 was the issue because the problem shut down my OS with beach ball as I started up 2.92 again on a clean isntall.
I remembered that 2.92 was to contain a script to eliminate the ransomware KeRanger and realized it might be working behind the scenes and causing a permissions/security issue.

I realized T 2.92 was the issue and reverted back to 2.91, booted again and no problem this time..
2.92 introduces its own security-breaching 'malware' to eliminate the ransomware packaged with 2.90 which can break your system entirely.

Instead remove the 2.90 KeRanger malware using the manual methods outlined here:
http://researchcenter.paloaltonetworks. ... installer/

——————

Here is my system
Image

yes I did Google the issue but came up with nothing. I know T 9.2 caused it because the system ran fine until I tried executing it on a fresh reboot, and it broke menubar/dock and locked up all applications with beach ball. No I'm not entirely sure what the cause is, but I decided to post this as a warning.
Last edited by VyseLegendaire on Wed Mar 09, 2016 8:14 pm, edited 1 time in total.

mike.dld
Transmission Developer
Posts: 285
Joined: Wed Dec 25, 2013 10:56 pm

Re: Transmission 2.92 BREAKS PERMISSIONS - Stalls reboot/breaks OS if executed

Post by mike.dld » Tue Mar 08, 2016 9:36 pm

Did you try searching the web before posting this here?

What version of OS X have you tried running it on? How many times have you tried running Transmission before you concluded that it's indeed the cause? Have you tried suggestions other people made on the internet (e.g. cleaning the /var/folders directory or booting into the safe mode)? Have you tried running Transmission after these other fixes, or after you yourself performed permissions and disk repair? When you downgraded to 2.91 and decided that that helped, could it be that what really helped is a reboot?

What do you mean by "boot without T 2.92 running an active process"? Transmission doesn't start on boot. You could add it to Login Items list in Users & Groups system preferences, but then it starts on login and not during boot.

Post Reply