Can't update to the lattest version

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
scrutinizer1
Posts: 3
Joined: Thu Aug 10, 2017 9:51 pm

Can't update to the lattest version

Post by scrutinizer1 »

Hi,
When I launched Transmission an update notification popped up. I hit "Update now" but a pop-up alert immediately followed telling me "An SSL error occurred. Wasn't able to establish a secure connection with the server. Try again later". I tried but no matter what still get that message. I had Transmission put in a subfolder of /Applications folder. Thinking it looks for the possibly hard-coded path /Applications I moved it there but no difference.
I'm still on Transmission 2.92, OS X is Lion.
Last edited by scrutinizer1 on Fri May 04, 2018 1:56 pm, edited 1 time in total.
mcandre
Posts: 40
Joined: Wed Dec 19, 2007 4:42 am

Re: Can't update to the lattest version

Post by mcandre »

I also have trouble auto-updating Transmission on macOS. My Transmission client reports the error "An error occurred while extracting the archive."
ze3bar
Posts: 1
Joined: Wed May 02, 2018 4:43 am

Re: Can't update to the lattest version

Post by ze3bar »

me too, I can't get it to update either.
T'hain Esh Kelch
Posts: 27
Joined: Sun Feb 15, 2009 9:32 am

Re: Can't update to the lattest version

Post by T'hain Esh Kelch »

Same here, I also get the "An error occurred while extracting the archive." trying to update from 2.92 to 2.94.
mike.dld
Transmission Developer
Posts: 290
Joined: Wed Dec 25, 2013 10:56 pm

Re: Can't update to the lattest version

Post by mike.dld »

ams0
Posts: 1
Joined: Wed May 02, 2018 7:45 pm

Re: Can't update to the lattest version

Post by ams0 »

Same here. This popup shows immediately after it finished downloading (2.92 > 2.94).

Image
thehamburger
Posts: 16
Joined: Tue Jul 24, 2012 9:50 am

Re: Can't update to the lattest version

Post by thehamburger »

Same here
2.92 > 2.94
OSX 10.13.4
Image
Image
flaubert
Posts: 4
Joined: Mon Apr 09, 2018 5:59 pm

Re: Can't update to the lattest version

Post by flaubert »

For me problem solved by downloading the .dmg file of the 2.94 version and copying in the applications folder this version replacing the previous one.
Attachments
screenshot_11.png
screenshot_11.png (67.87 KiB) Viewed 9101 times
kutitomi
Posts: 2
Joined: Sun May 06, 2018 8:54 am

Re: Can't update to the lattest version

Post by kutitomi »

same here
Image
:?: :?: :?:
scrutinizer1
Posts: 3
Joined: Thu Aug 10, 2017 9:51 pm

Re: Can't update to the lattest version

Post by scrutinizer1 »

I solved that by downloading the installer and updating manually. I extracted the app file from the installer DMG using Pacifist and then copied it to a location of preference. All went OK and the app launched seamlessly.
Last edited by scrutinizer1 on Sat Jul 21, 2018 12:16 am, edited 1 time in total.
joeholmes
Posts: 1
Joined: Wed May 09, 2018 6:45 pm

Re: Can't update to the lattest version

Post by joeholmes »

I'm having the same issue with extracting the archive. I'll try the suggestions here.
crackerboy
Posts: 2
Joined: Thu May 10, 2018 1:11 am

Re: Can't update to the lattest version

Post by crackerboy »

Re scrutinizer1's solution to this update fault: Seems the Transmission can solve this issue for the many Mac users. If not how not? Get with it guys. I've consistently donated and....
crackerboy
Posts: 2
Joined: Thu May 10, 2018 1:11 am

Re: Can't update to the lattest version

Post by crackerboy »

Actually, I found the easiest way to do this update was to uninstall the older version and download the most recent. Problem solved....
Anansi1
Posts: 2
Joined: Sun May 13, 2018 7:02 am

Re: Can't update to the latest version

Post by Anansi1 »

The issue is with how High Sierra and Sparkle handle volumes and is basically a permissions issue. See the discussion here: https://github.com/transmission/transmission/issues/600 The developers report this will probably be fixed in the 3.0 release if the Sparkle issue is resolved. In the mean-while, uninstall, download the new version, reinstall.

<Not a developer. Just an interested by-stander>
Post Reply