Can't update app. to 2.94

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
shmerls
Posts: 36
Joined: Thu Jun 12, 2008 4:03 am

Can't update app. to 2.94

Post by shmerls » Sun Aug 18, 2019 12:36 pm

I have version 2.92 and when I try to update to 2.94 I get:

Update Error!

An error occurred while extracting the archive. Please
try again later.

[ Cancel Update ]

I've tried numerous times all don't work and get the same error message.

Thoughts?

Thanks,
S

WindsorS
Posts: 1
Joined: Thu Sep 05, 2019 11:23 pm
Location: San Francisco Bay Area

Re: Can't update app. to 2.94

Post by WindsorS » Fri Sep 06, 2019 12:19 am

I just had the same problem (although in my case I was trying to update a much older version -- 1.92, almost ten years old!). The workaround I used was simply to reinstall it:
  • 1. Download Transmission-2.94.dmg (or the current release) from https://transmissionbt.com/download.
    2. Double-click the downloaded file (a disk image) to open it.
    3. Drag the enclosed Transmission app into the Applications folder.
    4. Click "Replace" if the Finder asks about replacing the older item.
I'm pretty sure all my preferences have been preserved.

Post Reply