Transmission causes leopard slow death

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
Posts: 2
Joined: Thu Apr 10, 2008 10:36 pm

Transmission causes leopard slow death

Post by cameron0110 »

Moderator Edit: Please see ... 681#p39681

When I run transmission, after a while leopard will hang. It isn't a typical hang, however.

The first symptom of such a hang is that the airport desynchronises with the access point and the icon goes grey. After this, it seems that the system cannot perform any further disk I/O. The system is still technically responsive, but as soon as I perform any action which causes a program to attempt to access the hard disk, the process will hang indefinitely (beachball).

Every once in a while, the system recovers from this state, but usually it will remain semi-crashed until I hold the power button down to turn off the system.

This happens typically when accessing a good torrent and not on speed limit mode.
Jethryn Freyman
Posts: 695
Joined: Wed Oct 31, 2007 6:11 am
Location: Australia

Post by Jethryn Freyman »

You mentioned disk activity: next time this happens, look at the "disk activity" tab of the Activity Monitor (or have it open while you start Transmission.) See what the disk usage (MB/sec) is like.
Posts: 2
Joined: Thu Apr 10, 2008 10:36 pm

Post by cameron0110 »

Will do. Though for further reference, my hard drive makes no noise when I'm in the state described above. Usually if it's in use it makes a fair bit of noise.
Posts: 19
Joined: Fri Apr 04, 2008 1:33 am

Post by kine »

I think i'm a victim of this as well.

What happens is i'll be minding my own business, typically browsing in Firefox, when all of a sudden pages don't load anymore. I can switch between tabs and i can open new tabs and i can click links and things, just the pages never start downloading (including stuff on the local network like my router configuration). So i think, OK, maybe something's wrong with my wireless, and i go up to disable/re-enable it from the Airport icon... but then the menu bar beach-balls.

So then i go to QuickSilver to launch Activity Monitor. QuickSilver pops up when i hit the hot key, but promptly beach-balls after that.

So then i go to the Dock to launch the Terminal to kill all that other stuff. The Dock shows the mouse-over effects and responds to my click... but then beach-balls.

So then i go to the Finder to open Activity Monitor or Terminal through the file system... but you know what happens.

Throughout the whole thing the only thing that continues to work is the window manager. I can move and switch between windows, the mouse works, &c., i just can't actually click on anything, i can't access any menus, i can't bring up the Force Quit window with the hot key, i can't restart with the hot key. (Even Firefox usually stops responding to clicks if i try to switch back to it.) Eventually i end up having to hold down the power button to kill everything. When the system comes back up everything is perfectly normal. Console shows absolutely nothing out of the ordinary, it just kinda stops around the time the machine locked up and then the next entry is OS X booting back up.

Through experimenting (i've had it happen a half-dozen times) i've determined that this only occurs when Transmission is running, and only when i have several active torrents running at the same time (as in, like, more than two or three actively downloading and more than two or three actively uploading at once). So my guess is that it is indeed related to disk usage/activity... but of course i can't get the Activity Monitor or anything to respond when it happens, so i can't really back that up with numbers or anything.

After limiting myself to two active downloads and three or four active uploads at a time, i haven't had any more lock-ups. :shrug: Maybe i just have an unrealistic expectation of how many disk operations the system can perform at once, but i don't know, pretty sure i've seen people with a lot more active torrents than that....

(This is a 24-inch aluminium iMac with 10.5.2 by the way.)
Posts: 2
Joined: Sat May 03, 2008 6:03 am
Location: Hutchinson, KS

Transmission kills all

Post by malagent »

I've been struggling with this problem for some time now but with 1.11 it has gotten much worse.
My Mac: iMac 17 inch (Late 2006 CD), 2GB RAM (Apple), Leopard 10.5.2, internal 160GB SATA, AirPort networking.

The problem sometimes starts with Firefox becoming unresponsive and eventually spreads to the rest of the applications and the Finder. On a rare occasion I can wait this out and can get the Mac to restart or shutdown, although when it does it takes a long, very long time.

Sometimes I notice that it starts with the mouse pointer turning into the beach ball when its moved to the AirPort menu bar icon. (the clock in the menu bar also stops.

I can still click and move some windows although they do not change focus. Sometime sI can click tabs in Firefox or Safari and the tab will change but the content of the window does not.

Force Quit does not work although sometimes the FQ window will appear but I've never been able to click anything with the beach ball.

I found that if I disconnected the external FireWire drive I used for downloads the Mac would sometimes recover. This lead me to switch the drive and eventually discard it and the FW enclosure it had resided in. All was well for a while.

Then after a Transmission update (sorry I don't remember which, it's been a couple back) this all started again but was much more severe and now happens several times per day. the only option I am left with is to hold the power button down or pull the power plug out.

There has hardly ever been any sign of this in the logs. I have spent the last 36 hours running various combinations of applications and watching activity monitor. The only things I have noticed are:

1: Transmission is always running.
2: Transmission + Parallels Desktop = instant failure.
3: mDNSResponder shows impossibly high resource usage at the onset of the problem. (Virtual Memy usage in the terabyte range and 90%+ processor usage
4: SystemUIServer will show in Activity Monitor as "Not Responding"
5: Problem occurs whether connected with Ethernet or AirPort.
(If connected to ethernet recovery is sometimes possible if the cable is removed)
6: Problem occurs whether downloading to the internal drive or an external drive.
(If downloading to an external drive recovery is sometimes possible when the drive is turned off or disconnected from the iMac)
7: If the power is not cut to the Mac the problem persists indefinitely with no actual crash or log of any problem. (I've left it as long as 16 hours).
8: Occurs with as few as one active transfer but increases in frequency with more transfers.
9: Occurs more frequently when other apps such as FTP clients or web browsers are used.
10: Occurs almost instantly if Spotlight Indexing starts with Transmission running.
11: No Hard Drive activity is apparent during the hang state.

as an experiment I went to another Mac that has been running Leopard and active on the internet with no hangs or crashes for months and I installed Transmission 1.11. the issue was replicated after a couple of hours of active transfers.

For now I am left with no option but to discontinue use of Transmission. Since it's the only worthwhile BT client in existence, I suppose I will just have to do without until I am aware of a fix. There is just too much work to be done to be restarting the mac that much.

I hope my long winded description provided something useful. I am willing to do some more tests if it may help resolve the issue for others.
Posts: 19
Joined: Fri Apr 04, 2008 1:33 am

Re: Transmission kills all

Post by kine »

malagent wrote:7: If the power is not cut to the Mac the problem persists indefinitely with no actual crash or log of any problem. (I've left it as long as 16 hours).
This is the same for me, now that you mention it. Once i started up some torrents like an hour before i left for work. Everything was fine, but then two or three hours later when i tried to remote into the machine from work using VNC i couldn't get anything to respond. I actually couldn't even ping my home modem/router, and when i checked my OpenDNS logs it showed that all DNS activity had ceased maybe an hour or two after i started up the torrents!

When i returned that night (10 or 11 hours later), i found the display in sleep like i left it. When i moved the mouse the display came back on and everything looked OK (no kernel panic or anything like that), but then as soon as i tried to actually do anything the problem became apparent.

Shutting off and/or restarting the router and modem had no effect. They looked OK judging by the lights, but the Mac definitely wasn't coming back out of it. Once again, after force-restarting the Mac everything was fine.

edit: Oh, i noticed this happens to you regardless of how many active transfers you have. FWIW, though, i have been free of lock-ups since my last post by using Transmission's queueing feature to limit my downloads to two at a time.
Posts: 2
Joined: Sat May 03, 2008 6:03 am
Location: Hutchinson, KS

Even more info on Transmission hanging other Apps.

Post by malagent »

I've been doing more testing of this tonight and I have found a couple of interesting things...

I've started launching Activity Monitor to watch what is happening with Transmission. Interestingly enough Transmission is not hanging when the problem occurs. But - simply getting info about transmission in Activity Monitor will cause the problem to occur. Specifically AM hangs indefinitely as soon as the process info window appears. I'm still able to switch apps and move windows, even force Quit Activity monitor.

But when the issue occurs on it's own I can not force quit anything.

I've used the Apple developer tools such as Spin Control and I've found that everything else will hang except Transmission, even though at that point I still can not use transmission and the network / disk activity also stops.

kine - if you get a chance could you try replicating the Activity Monitor hang with Transmission - just so I know if it's isolated or not?

Since you mentioned the router I decided to check that here as well.
During "indefinite spinning beach ball mode" the router is not responding to pings or any external traffic. As soon as the offending Mac's power is cut it returns to normal. I tried accessing the internet from a different Mac on the same network while the issue was occurring and the connections simply time out after a while.
Posts: 19
Joined: Fri Apr 04, 2008 1:33 am

Post by kine »

I'm reluctant to go messing around with it naturally, but i will try later this week end if i get a chance. :p

Weird that the router locks up in both cases. Maybe it's flooding, or it's sending bad packets or whatever? I have a second computer now so maybe i can get one of those packet-inspection things and see what it looks like from there.

Will report back within a week hopefully!

edit: What kind of router have you got? Mine is a Linksys WRT54GL running the Tomato firmware.
Posts: 2
Joined: Sun May 04, 2008 5:12 pm

Post by Caprica »

..and add me to the list. Transmission 1.11/10.5.2.. Etc my problem seems to be worse, my mac still has all the problems after it was powered off ( as in pulled the cord out) start back up & its still there :(

Sorry I can't post more details atm, I'm posting this from my iPod touch.
Posts: 2
Joined: Sun May 04, 2008 5:12 pm

Post by Caprica »

I discovered something interesting, I can completly control the effected imac via Screen Sharing ( have a networked mac mini with 10.5.2 also)

I've tried force quitting SystemUIServer, it worked but problem still there. Fixed disk permission too, that had a few errors but they were about java. Oh & even when I logged off the back & log in buttons didn't respond either.
Posts: 2
Joined: Thu May 08, 2008 7:44 am

Post by Squozen »

This has been happening to me for a while now. I had to switch to Azureus to get anything done.

One thing I did notice is that it seems to be dependent on the size and amount of torrents. If I'm dealing with, say, one 200Mb torrent the machine will run fine for days, but if I try to start 5 2Gb+ torrents, Leopard will lock up within 15 minutes and I need to cold-boot the machine to get control back.
Posts: 2
Joined: Thu May 08, 2008 9:16 pm

Post by kevspace2 »

Experiencing same issue..Trans will give me the beach ball, and then it spreads to the rest of the programs in the system. Here is today's crash log.


Process: Transmission [315]
Path: /Applications/
Identifier: org.m0k.transmission
Version: 1.11 (5504)
Code Type: PPC (Native)
Parent Process: launchd [84]

Date/Time: 2008-05-08 12:17:59.677 -0400
OS Version: Mac OS X 10.5.2 (9C7010)
Report Version: 6

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000008
Crashed Thread: 3

Thread 0:
0 libSystem.B.dylib 0x93658978 mach_msg_trap + 8
1 libSystem.B.dylib 0x9365f89c mach_msg + 56
2 0x92b5d618 CFRunLoopRunSpecific + 1828
3 0x958633a4 RunCurrentEventLoopInMode + 264
4 0x958631c8 ReceiveNextEventCommon + 412
5 0x95863008 BlockUntilNextEventMatchingListInMode + 84
6 0x900a03bc _DPSNextEvent + 580
7 0x9009fd84 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 112
8 0x90099a40 -[NSApplication run] + 736
9 0x9006a444 NSApplicationMain + 440
10 org.m0k.transmission 0x00002ba0 main + 116
11 org.m0k.transmission 0x00002afc _start + 744
12 org.m0k.transmission 0x0000280c start + 44

Thread 1:
0 libSystem.B.dylib 0x936d8c10 accept$UNIX2003 + 12
1 0x9300c4e4 _backgroundActivity + 284

Thread 2:
0 libSystem.B.dylib 0x9369a3d8 kevent + 12
1 org.m0k.transmission 0x0002c1c0 -[UKKQueue watcherThread:] + 124
2 0x92fa14f4 __NSThread__main__ + 1004
3 libSystem.B.dylib 0x9369ab98 _pthread_start + 316

Thread 3 Crashed:
0 org.m0k.transmission 0x000554e0 tr_runInEventThread + 32
1 org.m0k.transmission 0x0006072c verifyThreadFunc + 584
2 org.m0k.transmission 0x0006072c verifyThreadFunc + 584
3 org.m0k.transmission 0x00047f14 ThreadFunc + 84
4 libSystem.B.dylib 0x9369ab98 _pthread_start + 316

Thread 3 crashed with PPC Thread State 32:
srr0: 0x000554e0 srr1: 0x0000d030 dar: 0x00000008 dsisr: 0x40000000
r0: 0x00060730 r1: 0xf0206910 r2: 0x00000000 r3: 0x00186050
r4: 0x0004610c r5: 0x0087b000 r6: 0xffffffff r7: 0x000e82a4
r8: 0x00800000 r9: 0x00000001 r10: 0x000455bc r11: 0xa05e7da0
r12: 0x000455b4 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0x000854c8 r19: 0x000804ec
r20: 0x000804ec r21: 0x000804ec r22: 0x000804ec r23: 0x000854d8
r24: 0x000804ec r25: 0xf02069f8 r26: 0x0000000e r27: 0x000804ec
r28: 0x00186050 r29: 0x0087b000 r30: 0x0004610c r31: 0x000604ec
cr: 0x24002444 xer: 0x00000001 lr: 0x00060730 ctr: 0x000455b4
vrsave: 0x00000000

Binary Images:
0x1000 - 0x80ffb +org.m0k.transmission 1.11 (5504) <13204fc5f1159470e2d0aea143c2255f> /Applications/
0xa5000 - 0xb2fe7 +org.andymatuschak.Sparkle ??? (1.1) /Applications/
0xbe000 - 0xdfff1 libmx.A.dylib ??? (???) /usr/lib/libmx.A.dylib
0xf6000 - 0xf7fff +net.culater.SIMBL 0.2 (6) /Library/InputManagers/SIMBL/SIMBL.bundle/Contents/MacOS/SIMBL
0x2a5000 - 0x38effb 2.0.4 (2.0.4) /System/Library/CoreServices/RawCamera.bundle/Contents/MacOS/RawCamera
0x3fda000 - 0x3fe0fff libCGXCoreImage.A.dylib ??? (???) <4e1cd099b993b5ad9637cd0435a3a182> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGXCoreImage.A.dylib
0x8fe00000 - 0x8fe30b23 dyld 96.2 (???) <39109181acbf30fed542e6c9abcf1798> /usr/lib/dyld
0x90003000 - 0x90023ff7 libJPEG.dylib ??? (???) <92341083256fbcd28888a179ebf941ef> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib
0x90024000 - 0x90043fff libresolv.9.dylib ??? (???) <181fb3defd2942f00201507cfa4efdb5> /usr/lib/libresolv.9.dylib
0x90044000 - 0x9005cffb 1.0.0 (1.0.0) <fe37191e732eeb66189185cd000a210b> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/DictionaryServices
0x90064000 - 0x907d9fff 6.5.2 (949.26) <8d6ce96921254cbc787b9fe0526bef42> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x907e4000 - 0x907f0ff3 3.9.2 (3.9.2) <79588842bcaf6c747a95b2120304397a> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
0x907f1000 - 0x90840ff7 libGLImage.dylib ??? (???) <1b1db85f633ad1eed75cd6645ec99a5c> /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLImage.dylib
0x90841000 - 0x90897fff libGLU.dylib ??? (???) /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLU.dylib
0x90ce9000 - 0x90d70ffb 3.1.0 (3.1) <880a5a35ef1c5158271ee4b305b35626> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x90d71000 - 0x90f54ffb 5.0.2 (33001) <5e841904ba22d381672679180d4b0f4a> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x911d2000 - 0x911e5ffb 3.6.59 (3.6.59) <7c299626d6167de473e85327699cdb9c> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x91203000 - 0x9120efff 3.7.24 (3.7.24) <ae3dc890a43a9269388301f6b59d3091> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
0x9120f000 - 0x91294fff libsqlite3.0.dylib ??? (???) <f2a33fe2663eab9c7f4806d2cf05b4ee> /usr/lib/libsqlite3.0.dylib
0x91295000 - 0x9137efff libxml2.2.dylib ??? (???) <271fc4d25f101b60a8e7514d1c32a91c> /usr/lib/libxml2.2.dylib
0x9137f000 - 0x91386ffb 218.0.2 (220.1) <c7e0e618d5867ae227403ae385aacd82> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framework/Versions/A/Print
0x91387000 - 0x9138ffff libbsm.dylib ??? (???) <c1fca3cbe3b1c21e9b31bc89b920f34c> /usr/lib/libbsm.dylib
0x91390000 - 0x91426ff3 286.5 (286.5) <1a1a73b91deacb172d15745ec73e5959> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x91427000 - 0x914affff 101.3 (86) <66a99ad6bc695390a66dd24789e23dcc> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework/Versions/A/Ink
0x915a6000 - 0x916eeff3 libicucore.A.dylib ??? (???) <250daed2fb2e6bf114480e2e4da0728b> /usr/lib/libicucore.A.dylib
0x916ef000 - 0x917b4ffb 100.1 (186) <9cf54cb19b18e53ee22edb7ababa6e6c> /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData
0x917b5000 - 0x917b6ff8 34 (34) <6aa5ee485bb2e656531b3505932b845f> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x917b7000 - 0x91851ff7 3.2 (???) <4258842969dc8d4fa37e01a80aa3d409> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
0x91852000 - 0x91902fff 6.0.12 (6.0.12) <9a85ee3fd8fb95d4537725b035297fe7> /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos
0x91903000 - 0x919d2fff 4.5.0 (4.5.0) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
0x919d3000 - 0x919feff7 libauto.dylib ??? (???) <b3a3a4b0f09653bd6d58f1847922b533> /usr/lib/libauto.dylib
0x919ff000 - 0x920e0ff3 5525.13 (5525.13) <737bfd9a30be77ecb1e6cf339727f13a> /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
0x922f7000 - 0x9233efff 3.5.1 (161) <b245f17b2b2902e1f9eeaaa6773f8126> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
0x9233f000 - 0x923d8fc3 libvDSP.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
0x923d9000 - 0x9243bffb 68 (1.1.3) <e852db1c007de975fae2f0c2769c88ef> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering.framework/Versions/A/HTMLRendering
0x9243c000 - 0x92447ffb libgcc_s.1.dylib ??? (???) <ea47fd375407f162c76d14d64ba246cd> /usr/lib/libgcc_s.1.dylib
0x92467000 - 0x92517fff 3.11.52 (???) <f33191c288897dd4d2e2c4b87bcc09b4> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
0x92518000 - 0x9262cffa 3.0 (3.0) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
0x9262d000 - 0x92656ffb 1 (1.0) <032016a45147a2f3f191ce70187587c9> /System/Library/PrivateFrameworks/Shortcut.framework/Versions/A/Shortcut
0x926bd000 - 0x926bdfff 1.4.2 (Accelerate 1.4.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x926be000 - 0x92af3ffa libGLProgrammability.dylib ??? (???) <6d71574167a838789ab0ee27f92af626> /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLProgrammability.dylib
0x92af4000 - 0x92c19ffb 6.5.1 (476.10) <e71eaa358523eae0e45280bca8a90e98> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x92c1a000 - 0x92c21fff 1.2.4 (85) <0d1256175c5512c911ede094d767acfe> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels.framework/Versions/A/CommonPanels
0x92c22000 - 0x92d6bffb 2.0.1 (2.0.1) <ea98d04f3ecfec65edfafe3796d6d442> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
0x92d6c000 - 0x92d6cfff 136 (136) <6a6a209ec9179368db7ead8382b8ee63> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x92d6d000 - 0x92de8fff 1.2.0 (1.2.0) <1b448fbae02460eae76ee1c6883f45d6> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x92f8a000 - 0x92f97fff libCSync.A.dylib ??? (???) <e7073e93982e6872ed72e5873b791462> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
0x92f98000 - 0x931dcffb 6.5.4 (677.15) <0cb0eec2a47f915404236f64abf7c384> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x931dd000 - 0x931dfffd libRadiance.dylib ??? (???) <3d70fcb7557347829c96c9753074b3f1> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRadiance.dylib
0x931e0000 - 0x932feff7 1.5.1 (1.5.1) /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
0x932ff000 - 0x93600ff7 785.8 (785.8) <d56076bc0fe62dd58002bdd581a3f3c0> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x93601000 - 0x9360afff 2.2.1 (2.2.1) <a389b4c2badce39540f24402f7df35e7> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x9360b000 - 0x9360bfff 1.5 (1.5) /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
0x93657000 - 0x937f0fe3 libSystem.B.dylib ??? (???) <754231f5e52ed8418f89f1f3369caf58> /usr/lib/libSystem.B.dylib
0x93827000 - 0x93842ffb libPng.dylib ??? (???) <c51ec88c87a3f0a646471165e16acd43> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
0x93843000 - 0x93847ffe libGIF.dylib ??? (???) <d6e2a570359313a39c6783c2ecfee608> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libGIF.dylib
0x938d6000 - 0x938faffb libGL.dylib ??? (???) /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
0x9393d000 - 0x93940fff 1.1 (36) <7106d6e074a3b9835ebf1e6cc6c822ce> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framework/Versions/A/Help
0x93942000 - 0x93a14fff 224.4 (224.4) <1972b141810adcc01c30c31fcbab5af3> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x93a16000 - 0x93a1bff6 libmathCommon.A.dylib ??? (???) /usr/lib/system/libmathCommon.A.dylib
0x93ad5000 - 0x93ad8ffb 3.0 (30817) <e50c0cac9048f8923b95797753d50b5c> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
0x93ad9000 - 0x94093fff libBLAS.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
0x94094000 - 0x940d5ffb libTIFF.dylib ??? (???) <0d0a3107d26786c3708e6a511d5acec9> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
0x940d6000 - 0x940d7fff libffi.dylib ??? (???) <11b77dbce4aa0f0b66d40014230abd1d> /usr/lib/libffi.dylib
0x9414e000 - 0x9416dfff 3.4.2 (vecLib 3.4.2) /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib
0x941fa000 - 0x94208fff libz.1.dylib ??? (???) <1a70dd3594a8c5ad39d785af5da23237> /usr/lib/libz.1.dylib
0x943f4000 - 0x9442cfff 1.9.1 (1.9.1) <50bc5b4d50a2e1f7743e729381467537> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x9442d000 - 0x9448dfff 2.0.1 (???) <2ecbcac842c4864bdd3de0a68e4d2f2c> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreText.framework/Versions/A/CoreText
0x9448e000 - 0x94499ff9 1.0 (14) /System/Library/PrivateFrameworks/HelpData.framework/Versions/A/HelpData
0x9449a000 - 0x94581ff7 5525.13 (5525.13) <69e777d18dea5320096554dca986ce4a> /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
0x945bf000 - 0x945f4fff 402.2 (402.2) <0b15a08da8ec38b74fb9dd6e579ed25f> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x945f5000 - 0x945f5ff8 6.5 (???) <e9a4f1c636d00893db0494c4040176ba> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x945f6000 - 0x9465dffb libstdc++.6.dylib ??? (???) <a4e9b10268b3ffac26d0296499b24e8e> /usr/lib/libstdc++.6.dylib
0x9465e000 - 0x946f1fff 1.5.1 (???) <590e7f24d3cbfc072c8659173d2141e3> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x94757000 - 0x947a2ffb 10.5.2 (398.7) <f0c3c28205af67a29a2ed728ee297648> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
0x947a3000 - 0x94accfe7 libLAPACK.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
0x94b0d000 - 0x94b0dffb 1.0 (8) /System/Library/PrivateFrameworks/InstallServer.framework/Versions/A/InstallServer
0x94b0e000 - 0x94b3ffff 1.1 (61) /System/Library/PrivateFrameworks/CoreUI.framework/Versions/A/CoreUI
0x94b40000 - 0x94b7cfff libRIP.A.dylib ??? (???) <7bc908a7317a00fe3c659571c50cdd46> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
0x94b7d000 - 0x94b85ffb libCGATS.A.dylib ??? (???) <f08869e380cd4b55e14714fe723cbc66> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGATS.A.dylib
0x94b86000 - 0x94b86ffa 32 (32) <42b6dda539f7411606187335d9eae0c5> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x94bc6000 - 0x94c80fff libcrypto.0.9.7.dylib ??? (???) <4ea3d7e9a1c28ac7b17ed80873fe6598> /usr/lib/libcrypto.0.9.7.dylib
0x94c81000 - 0x94c9afff 1.5.0 (1.5.0) <aebfdc3d092810ff35a8e92b8f966010> /System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo
0x94c9b000 - 0x94ca8ff3 1.5.6 (1.5.6) <4ec145eba41b94cff1322a041dfdb437> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x94d14000 - 0x94d3bfff libxslt.1.dylib ??? (???) <3700d04090629deddb436aa2d516c56d> /usr/lib/libxslt.1.dylib
0x94d97000 - 0x94db2ffb 1.2.6 (???) <12270fbb14905644f78975f227328a98> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
0x94db3000 - 0x94e2dffd 221.5 (221.5) <ef2672379d6fcb1470dc9361ce68e7f7> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x94e3c000 - 0x94e53ffb 4.0 (5.0.0) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/ImageCapture
0x94e54000 - 0x94f16fff 5525.13 (5525.13) <f1df0c201af5b2002f8de2409ebdbb39> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
0x94f17000 - 0x94f2afff 1.6.4 (1.6.4) <c184bb5b2859e82c5740a6fdb1e3d0bc> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
0x94f5e000 - 0x94fe8fff libvMisc.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
0x94fe9000 - 0x95008fff 3.4.2 (vecLib 3.4.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
0x95184000 - 0x951aafff libcups.2.dylib ??? (???) <d60807e6cfdc208c2e5520f7acb473f6> /usr/lib/libcups.2.dylib
0x951ab000 - 0x9522cfff 5.5.2 (245.1) <df7cf3aa9f046c543b9e27f08860b692> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
0x9522d000 - 0x952bcffb 1.4.5 (1.4.5) <b6bd34467a57cc899612152caac2a789> /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
0x952bd000 - 0x95831ff7 1.351.21 (???) <44bbf8c3a4e8bc97e8b3e35737001742> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
0x95832000 - 0x95b6bff3 1.5.2 (???) <687d476c6a3809efaba68bc11dc894c1> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x95b77000 - 0x95ed4ff2 1.5.1 (1.5.1) <f364682e96d58c5849cad532f6bf2f91> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
0x96019000 - 0x960fcfeb libobjc.A.dylib ??? (???) <23a407d7dac6090562827e97bac3cb86> /usr/lib/libobjc.A.dylib
0x96109000 - 0x96165ffb 1.7.0 (???) <48d200891cc9dd795ee547d526c6a45b> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
0xc0000000 - 0xc0008fff +com.growl.growlframework 1.1.2 (1.1.2) <fac96f36aeb8c1bf4a478390a5ac22db> /Applications/
0xfffec000 - 0xfffeffff libobjc.A.dylib ??? (???) /usr/lib/libobjc.A.dylib
0xffff8000 - 0xffff9703 libSystem.B.dylib ??? (???) /usr/lib/libSystem.B.dylib
Posts: 2
Joined: Thu May 15, 2008 12:18 am

Post by lucas »

+1 here. my pc can run for weeks without an issue. I start transmission and soon enough it experiences this strange step-by-step freezing and requires being power cycled.

I'm glad to see it's not just me. the machine in question is a home built hackintosh and I wasn't sure if it was a transmission problem or something deeper. looks like I wont need to reimage the machine, though I may have to find a new torrent client. No solution for this yet?
Posts: 19
Joined: Fri Apr 04, 2008 1:33 am

Post by kine »

FYI i haven't been able to reproduce for a while. I'm not sure if that has something to do with the 1.20 update or if i'm just not trying hard enough, but i'll keep working on it....
Posts: 2
Joined: Thu May 08, 2008 7:44 am

Post by Squozen »

Interesting, I'll try it out. I am currently seeding about 20-25Gb of data using Azureus, and that would have crashed Transmission within 10 minutes. I'll follow up to this post if I can successfully seed with the latest build overnight.
Post Reply