Permission Denied

Ask for help and report issues with the Mac OS X version of Transmission
Rebel
Banned
Posts: 29
Joined: Tue May 22, 2007 8:43 pm

Permission Denied

Postby Rebel » Wed Apr 30, 2008 7:24 pm

Recently I encountered a problem downloading torrents, and I'm posting this thread so that it may help someone else.

For some reason, all of the newer torrents I had added would start, and then after a few seconds they would automatically pause. Each one said Error: Permission Denied. Every time I restarted them, they would pause again.:?

My first thought was this was a tracker issue, and I needed to be registered with them. However, this was happening with a bunch of torrents, and they were downloaded from sites that I've never had a problem with before. I had 2 torrents that were still functioning just fine. I searched the Torrent site's forums, and then searched the Transmission forums, but there was no answer.

I didn't realize at that time that this was only occurring with the newer torrents.

After a few days, for unrelated reasons, I was messing with the permissions for my external drives. I set them all to ignore ownership on this volume. When I opened Transmission and hit Resume, all the torrents began downloading normally.:D After thinking about it, I remembered I had changed the permissions a few days before, as I was diagnosing a system issue.

So the entire problem was a simple permissions issue. 8-) Transmission was being denied access to to its Download folder on one of my external drives. Only the torrents that had been in progress before I had changed the permissions the first time were working properly.

jh
Posts: 62
Joined: Fri Apr 04, 2008 6:11 pm

Postby jh » Thu May 01, 2008 5:07 pm

One suggestion could be to change the error message to indicate it is a file system permission error.

matt
Posts: 11
Joined: Fri Apr 27, 2007 4:37 pm

Postby matt » Tue May 13, 2008 4:48 pm

Thanks

Not sure how my download directory became read only but this topic helped be track down the problem.

masrapido
Posts: 1
Joined: Sun Nov 09, 2008 5:41 pm

Re: Permission Denied

Postby masrapido » Wed Apr 15, 2009 2:43 am

+1. Helped me too. I agree that the "Permission Denied" error could be more descriptive, to distinguish between file system and tracker permission problems.

videoflyer
Posts: 6
Joined: Sat Jun 10, 2006 2:00 am
Location: Chicago area

Re: Permission Denied

Postby videoflyer » Mon Feb 01, 2010 5:22 pm

I'm getting the "Permission Denied" error, as well, on v.1.83 (10040). Everything was fine using the previous build of Transmission but now all of the torrents that were already in the queue are giving me that error message. At the same time, though, I can start new torrents downloading to the very same directory on my external drive and they're working just fine. So within the same folder I have all the files I'd previously downloaded or was in the process of downloading and which now give me the error message (I've checked and the ones which were complete are whole and open just fine in their respective apps)...and the new torrents I've started since the update which are downloading without a problem.
"If morons could fly it'd be pitch black." - Anonymous

audition
Posts: 5
Joined: Mon Feb 01, 2010 12:18 pm

Re: Permission Denied

Postby audition » Mon Feb 01, 2010 6:15 pm

i tried checking this out due to my problems with transmission not wanting to start downloads on any of my torrents viewtopic.php?f=4&t=9470 but still nothing.
I frind it really weird as my transmission was actually running better than ever just before I updated it... bugger!

scotnik
Posts: 2
Joined: Sun Feb 07, 2010 1:30 am

Re: Permission Denied

Postby scotnik » Sun Feb 07, 2010 1:49 am

Bugger, indeed. I cannot download either new torrent files or prior files in the process of downloading. I can't remember, however, when I last updated my Transmission build. I can't seem to change the permissions to my external disk as suggested last April by Rebel. Get Info tells me that I can read and write to the drive in question. I see no option on my MacBook Pro that allows me to "ignore ownership on this volume" and reset.

Elric
Posts: 5
Joined: Mon Feb 08, 2010 12:31 pm

Re: Permission Denied

Postby Elric » Mon Feb 08, 2010 12:36 pm

Having the same problem. I usually have this problem once I download a new update of Transmission, but this time, the usual fixes do not work.

I wish they would just include a fix for this automatically with each new version...

americaskate
Posts: 3
Joined: Mon Feb 08, 2010 7:03 pm

Re: Permission Denied

Postby americaskate » Mon Feb 08, 2010 7:05 pm

Got an account to comment on this.
Getting the same issue as described above.
I save my torrents to an external drive and permissions seem to be fine.

Elric
Posts: 5
Joined: Mon Feb 08, 2010 12:31 pm

Re: Permission Denied

Postby Elric » Tue Feb 09, 2010 3:43 am

Yeah, is there no one on these boards? I was able to get 2 Torrents to download, don't even ask me how, I rebooted, and 2 worked. none since then, this is getting REALLY annoying.

Update please.

americaskate
Posts: 3
Joined: Mon Feb 08, 2010 7:03 pm

Re: Permission Denied

Postby americaskate » Thu Feb 11, 2010 3:15 pm

It's interesting that you were able to get 2 to download.
Has anyone been able to find a work around?

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: Permission Denied

Postby x190 » Thu Feb 11, 2010 4:31 pm

The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

squashboy
Posts: 1
Joined: Sat Feb 13, 2010 12:59 am

[Posible Solution] Permission Denied

Postby squashboy » Sat Feb 13, 2010 1:12 am

Try this it worked for me :

Quit Transmission
delete ~/Library/Preferences/org.m0k.transmission.LSSharedFileList.plist
delete ~/Library/Preferences/org.m0k.transmission.plist
delete ~/Library/Application Support/Transmission
Open Transmission
Add your torrent

It removes all your settings and active torrents but it solved the errors for me.

Can anyone else confirm?

-sb

Elric
Posts: 5
Joined: Mon Feb 08, 2010 12:31 pm

Re: Permission Denied

Postby Elric » Thu Feb 18, 2010 4:53 am

It seems I have to do this once a week? The problem has never been this bad before.... as for the Wiki link up there, that has no solutions, but thanks.

dani4wd
Posts: 7
Joined: Thu Feb 18, 2010 1:36 pm

Re: Permission Denied (Lost the data in Transmision)

Postby dani4wd » Thu Feb 18, 2010 1:50 pm

Hi i have the problem with permission denied with new and old torrents .

it happened when i turn on the MBP after 5 days before it was ok .

now i lost my files inside the program but it is still on the hard drive but it is showing a 0% in there : (

how do i show or verify that the files already downloaded it is a big file 45 GB ! i dont wanna lose it pleaseeeee .

sorry for my english

here is my system :
1.90 (10223)

Model: MacBookPro3,1, BootROM MBP31.0070.B07, 2 processors, Intel Core 2 Duo, 2.2 GHz, 4 GB
Graphics: GeForce 8600M GT, GeForce 8600M GT, spdisplays_pcie_device, 128 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), 1.4.16.2
Bluetooth: Version 2.1.9f10, 2 service, 0 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
PCI Card: pci168c,24, sppci_othernetwork, PCI Slot 5
Serial ATA Device: FUJITSU MHY2120BH, 111.79 GB
Parallel ATA Device: HL-DT-ST DVDRW GSA-S10N
USB Device: Built-in iSight, (null) mA
USB Device: Bluetooth USB Host Controller, (null) mA
USB Device: Apple Optical USB Mouse, (null) mA
USB Device: IR Receiver, (null) mA
USB Device: Apple Internal Keyboard / Trackpad, (null) mA
FireWire Device: My Book, WD, 800mbit_speed

Date/Time: 2010-02-18 21:41:33 +0800
OS Version: 10.5.8 (Build 9L30)
Architecture: i386
Report Version: 4

Command: Transmission
Path: /Applications/Transmission.app/Contents/MacOS/Transmission
Version: 1.90 (10223)
Parent: launchd [107]

PID: 885
Event: hang
Time: 4.91s
Steps: 17


Process: Transmission [885]
Path: /Applications/Transmission.app/Contents/MacOS/Transmission

ADDRESS BINARY

Thread id: ada0a78

Please help looks like so many people having this problem !!! over 7000 view on this topic !!!

and i dont want to move to Vuze !!! i like this program : ( !


Return to “Mac Support”