Version 1.42 - very poor download performance

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
sortof
Posts: 5
Joined: Thu Jan 01, 2009 7:48 pm

Version 1.42 - very poor download performance

Post by sortof » Thu Jan 01, 2009 8:33 pm

This is not really comparison with previous versions, I´ll do that later. It´s just what I found how version 1.42 performs. Since the upgrade to 1.42 I have these issues:

1. Transmission is loosing connections to peers. E.g. during a download it´s at some stage connected to say 8 out of 10 peers and the download speed is actually pretty good. However, after a while the number of peers and/or the number of connections to peers starts to drop until the download more or less ceases. After quitting and immediate restart of transmission the reasonably good download (as above 8/10 peers) is again established until it starts to drop again. A bug or a feature?

2. I run a download for which more than 50 seeds and over 1500 leechers are active. Poor Transmission connects at best however to only 2/42 peers. This is very good for my share ratio (right now at 2.52) but the download speed is obviously truly ridiculous.There is one more active download at the same time for which more than 40 seeds/600 leechers are active, Transmission connects only to 7 out 33, and the download speed is really very poor (mostly way below 10KB/s). Six other downloads are at the same time paused, because I was hoping that this could speed things up, but it doesn´t. Variation of the upload maximum speed doesn´t help either.

My connection to the web allows downloads speeds up too about 600KB/s, and the upload max is around 60KB/s. Transmisson has sometimes reached speeds above 500KB/s, which is really very, very good. Right now version 1.42 delivers mostly less than 10KB/s down, which is actually close to being unusable.

System OS: 10.5.6
Transmission settings for "Peers" at default

sortof
Posts: 5
Joined: Thu Jan 01, 2009 7:48 pm

Downgrade to version 1.34...

Post by sortof » Thu Jan 01, 2009 9:16 pm

... now the downloads are running at acceptable speeds.

If "1.41+ = 1.50 beta" it would have been nice to clearly call 1.42 what it is, a beta. This is slightly alienating I must say.

merlyn3d
Posts: 16
Joined: Wed Sep 24, 2008 3:40 am

Re: Version 1.42 - very poor download performance

Post by merlyn3d » Thu Jan 01, 2009 11:32 pm

I have the same issue. I open the new uTorrent client with the same torrent and I get well over 100KB/s within 5 minutes, however with the latest transmission nightly as well as 1.42 I get only about 10-15KB/s after half an hour.





PS - on a side note, the profile page (to change your forum password on these forums) isn't working.

Post Reply