Transmission 1.42 won't launch.

Ask for help and report issues with the Mac OS X version of Transmission
Post Reply
SyracuseMug
Posts: 2
Joined: Sat Jan 03, 2009 6:13 pm

Transmission 1.42 won't launch.

Post by SyracuseMug » Sun Jan 04, 2009 5:07 am

I'm running Mac OS 10.4.11, and I'm currently using Transmission 1.11. I recently tried upgrading to 1.42, but each time I try to launch it, the icon bounces in my dock for a few seconds, and then disappears.

I've read that I need to run 10.4.11 with Security Update 2008 - 002, but I don't know where to look to see what my current update number is. When I check my Software Update, it indicates that 2008 - 008 is available for download, so I assume that my current one is lower than that. I went to Apple Support and downloaded the .dmg for 2008 - 002, but the image failed to mount. It referred to an "invalid checksum."

I also checked my crash log, and here's what it showed, if that will be helpful:


Date/Time: 2009-01-03 12:55:52.318 -0500
OS Version: 10.4.11 (Build 8S165)
Report Version: 4

Command: Transmission
Path: /Volumes/Transmission 1/Transmission.app/Contents/MacOS/Transmission
Parent: WindowServer [3981]

Version: 1.42 (7494)

PID: 26467
Thread: Unknown

Link (dyld) error:

Library not loaded: /usr/lib/libcurl.4.dylib
Referenced from: /Volumes/Transmission 1/Transmission.app/Contents/MacOS/Transmission
Reason: image not found

Ryoujin
Posts: 576
Joined: Sat Jan 05, 2008 3:43 pm

Re: Transmission 1.42 won't launch.

Post by Ryoujin » Sun Jan 04, 2009 1:25 pm

SyracuseMug wrote:I've read that I need to run 10.4.11 with Security Update 2008 - 002, but I don't know where to look to see what my current update number is. When I check my Software Update, it indicates that 2008 - 008 is available for download, so I assume that my current one is lower than that. I went to Apple Support and downloaded the .dmg for 2008 - 002, but the image failed to mount. It referred to an "invalid checksum."
Are you trying to download it via Software Update as well? As for the invalid checksum, are you doing it with Safari or Firefox? If its one or the other try doing it with the one you aren't and see if there's any change? Like, if you are using Safari try downloading with Firefox, or vice-versa. Either that or use directly the Software Update.

SyracuseMug
Posts: 2
Joined: Sat Jan 03, 2009 6:13 pm

Re: Transmission 1.42 won't launch.

Post by SyracuseMug » Sun Jan 04, 2009 3:06 pm

When I go to my Software Update, it only offers the most recent version, which is Security Update 2008 - 008, and it also says the following: "Security Update 2008-008 is recommended for all users and improves the security of Mac OS X. Previous security updates have been incorporated into this security update."

I went to the Apple website to download the earlier version, and that's the .dmg I'm not able to open. However, since it appears that 2008-002 has been incorporated into 2008-008, one would think that Transmission 1.42 should run just fine. So perhaps the problem lies elsewhere.

Would you happen to know how I can determine which Security Update I'm currently running? I haven't yet been able to figure out where to look.

BTW, my current browser is AOL Desktop for Mac 1.21, but I also have Safari and Firefox, so I'll give them both a try.

livings124
Transmission Developer
Posts: 3141
Joined: Fri Jan 13, 2006 8:08 pm

Re: Transmission 1.42 won't launch.

Post by livings124 » Sun Jan 04, 2009 3:16 pm

Just download the latest security update offered by Apple.

Ryoujin
Posts: 576
Joined: Sat Jan 05, 2008 3:43 pm

Re: Transmission 1.42 won't launch.

Post by Ryoujin » Sun Jan 04, 2009 3:31 pm

SyracuseMug wrote:When I go to my Software Update, it only offers the most recent version, which is Security Update 2008 - 008, and it also says the following: "Security Update 2008-008 is recommended for all users and improves the security of Mac OS X. Previous security updates have been incorporated into this security update."
Just get the update, it's not so difficult. When there are new Security Updates they usually take over the old ones, so you won't find a stack of old updates (unlike Windows).

Post Reply