port closed since 1.93

Feature requests for the Mac OS X version of Transmission
Post Reply
direwolf
Posts: 2
Joined: Sat May 08, 2010 1:33 pm

port closed since 1.93

Post by direwolf »

Hello. Ever since I updated to version 1.93, I am unable to upload. The port is closed and I have tried everything suggested on this forum to no avail. Do you have any tips. If you like I can post the debug message log.

Thanks.
T'hain Esh Kelch
Posts: 27
Joined: Sun Feb 15, 2009 9:32 am

Re: port closed since 1.93

Post by T'hain Esh Kelch »

Having the same problem.
Jordan
Transmission Developer
Posts: 2311
Joined: Sat May 26, 2007 3:39 pm
Location: Titania's Room

Re: port closed since 1.93

Post by Jordan »

In 1.93 Transmission upgraded the port forwarding libraries it uses for port forwarding (miniupnpc and libnatpmp) ... if your ports started being closed when you upgraded to 1.93, maybe there's a bug in the new version of one of those libraries.

To test this theory, try running 1.92 again (which can be found at http://mirrors.m0k.org/transmission/files/) and report back whether the ports open correctly again under 1.92
T'hain Esh Kelch
Posts: 27
Joined: Sun Feb 15, 2009 9:32 am

Re: port closed since 1.93

Post by T'hain Esh Kelch »

Jordan wrote:To test this theory, try running 1.92 again (which can be found at http://mirrors.m0k.org/transmission/files/) and report back whether the ports open correctly again under 1.92
I can confirm that downgrading to 1.92 reopens the port. :)
Thinine
Posts: 19
Joined: Fri Jan 27, 2006 4:36 am

Re: port closed since 1.93

Post by Thinine »

Mine also indicates closed but it seems to work fine. Going back to 1.92 didn't open it back up, but I can still up and download just fine. :?:
T'hain Esh Kelch
Posts: 27
Joined: Sun Feb 15, 2009 9:32 am

Re: port closed since 1.93

Post by T'hain Esh Kelch »

Well, it turns out that the port closing was apparently random.. At least my 2.00 isn't closed right now. And 1.92 was also closed sometimes.. A bit weird.
Post Reply