[feature request] stop seeding at certain ratio

Feature requests for the GTK+ version of Transmission
pupis
Posts: 1
Joined: Fri Apr 10, 2009 6:40 pm

Re: [feature request] stop seeding at certain ratio

Postby pupis » Fri Apr 10, 2009 6:50 pm

I am now using the 1.60 nightly. The feature is there but there is a problem: there is a "hardcoded mininum ratio limit" of 0.5. Really IMHO this is a very bad design decision.

The only reason I am still using deluge is that deluge lets me set the limit to "whatever ratio I want". Why would the transmission developer be determining what is a "proper ratio to use" in our behalf?

I'm hoping this can still be revised and changed. If the accuracy for the value is 0.05, then the minimum should be 0.05, I would think.

cheers

livings124
Transmission Developer
Posts: 3131
Joined: Fri Jan 13, 2006 8:08 pm

Re: [feature request] stop seeding at certain ratio

Postby livings124 » Fri Apr 10, 2009 7:17 pm

There is no minimum in the current trunk.

drcabrejos
Posts: 1
Joined: Wed Jan 05, 2011 5:21 pm

Re: [feature request] stop seeding at certain ratio

Postby drcabrejos » Wed Jan 05, 2011 5:35 pm

Just updating a little bit the code trpause.sh.
Renamed mine to trcompleted.sh

Using FreeNAS version 0.7.2 (5543)
Transmission version 2.11 (11322)

Now that transmission has an option to stop a global seed ratio by using a command, makes it simpler and looks better on the web interface.

The following script works for me and after the seeding ratio is complete, it will remove from the list instead of still leaving a completed seeded torrent there.

trcompleted.sh

Code: Select all

#!/bin/sh

TR_R=/usr/local/bin/transmission-remote
PORT=1551
USER=myusername
PASS=mypassword
RATIO=3.00

$TR_R $PORT -n $USER:$PASS -gsr $RATIO

for i in `$TR_R $PORT -n $USER:$PASS -l | \
  awk '$5 ~ "Done" { print $1 }'`
do
  $TR_R $PORT -n $USER:$PASS -t $i -r
done


Notice: For me, the previous code using $3 using awk command did not work. Mine was $5 instead.


Make sure of the location of "transmission-remote". Previous code had /usr/bin/transmission-remote. Mine is /usr/local/bin/transmission-remote.
You can make sure of your location by issuing the command: find / -name transmission-remote
Select the port you are using for your transmission. My case is 1551.
Replace "myusername" with your transmission login username.
Replace "mypassword" with your transmission login password.
Select your Seeding Ratio. This is set to 3.0

After creating the file, make sure you have executable permissions.

chmod 775 trcompleted.sh

Make sure to add a cron job to this file.

System -> Advanced -> Cron
I set mine to do it every minute.

Hope that helps anyone trying to make this all work. ;)


Return to “GTK+ Requests”