Problems using web interface

Discussion of the Web Interface for Transmission, formerly known as Clutch. This applies to all version of Transmission
Lemming
Posts: 4
Joined: Sun Aug 15, 2010 3:19 pm

Problems using web interface

Postby Lemming » Sun Aug 15, 2010 3:21 pm

Hi everyone,

I'm trying to set up transmission-daemon on Ubuntu and use the web interface, but I'm not having much luck. It brings up the web interface but I can't do anything with it - it pops up the window to add a torrent but then doesn't add it when I click "import". I also can't change the preferences, when I try to save them I get an error in the Firefox error console: tr.remote.savePrefs is not a function.

I'm using 1.51 on an Ubuntu Jaunty server and Firefox 3.5.3 on a Mac. Is there anything obvious I should look for to troubleshoot this?

Thanks,
Colin

rb07
Posts: 1400
Joined: Sun Aug 24, 2008 3:14 am

Re: Problems using web interface

Postby rb07 » Sun Aug 15, 2010 7:56 pm

Lemming wrote:Is there anything obvious I should look for to troubleshoot this?

Change to a recent version for starters.

One improvement you'll get is the log output, so you can see what error is happening when your added torrent doesn't start... probably permission problems, or configuration problems (find your settings.json and see if the values look sane).

Lemming
Posts: 4
Joined: Sun Aug 15, 2010 3:19 pm

Re: Problems using web interface

Postby Lemming » Sun Aug 15, 2010 9:16 pm

Thanks for the reply - that version is the one that comes with Jaunty by default. I couldn't find any obvious way to upgrade this, so I added the apt source manually:

Code: Select all

deb http://ppa.launchpad.net/transmissionbt/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/transmissionbt/ppa/ubuntu jaunty main


I also added the appropriate key. I then removed my existing install:

Code: Select all

sudo apt-get remove transmission-cli transmission-common transmission-daemon


However I now can't reinstall due to a package conflict:

Code: Select all

colin@ubuntu:~$ sudo apt-get install transmission-common transmission-cli transmission-daemon
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  transmission-cli: Depends: transmission-common (= 1.51-0ubuntu3.1) but 2.04-0ubuntu1.09.04.1 is to be installed
  transmission-daemon: Depends: transmission-common (= 1.51-0ubuntu3.1) but 2.04-0ubuntu1.09.04.1 is to be installed
E: Broken packages


So it looks like the cli and daemon packages for 2.04 have dependencies on 1.51. Is that right? Unfortunately if I understand correctly that's the part I need to upgrade since that's where Clutch is.

Thanks for any and all help.

rb07
Posts: 1400
Joined: Sun Aug 24, 2008 3:14 am

Re: Problems using web interface

Postby rb07 » Sun Aug 15, 2010 9:54 pm

Lemming wrote:So it looks like the cli and daemon packages for 2.04 have dependencies on 1.51. Is that right?

No.

I don't use Ubuntu so I don't really know how to fix that mess, perhaps the package changed name, I would start by listing what is available... actually why don't you just try to install the daemon, it should resolve dependencies by itself and install what is needed (or is dpkg the one that does that?).
Lemming wrote:Unfortunately if I understand correctly that's the part I need to upgrade since that's where Clutch is.

Wrong, there is no Clutch in modern versions, the daemon does what Clutch used to do.

Longinus00
Posts: 137
Joined: Fri Aug 21, 2009 5:46 am

Re: Problems using web interface

Postby Longinus00 » Mon Aug 16, 2010 2:43 am

Lemming wrote:Thanks for the reply - that version is the one that comes with Jaunty by default. I couldn't find any obvious way to upgrade this, so I added the apt source manually:

Code: Select all

deb http://ppa.launchpad.net/transmissionbt/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/transmissionbt/ppa/ubuntu jaunty main


I also added the appropriate key. I then removed my existing install:

Code: Select all

sudo apt-get remove transmission-cli transmission-common transmission-daemon


However I now can't reinstall due to a package conflict:

Code: Select all

colin@ubuntu:~$ sudo apt-get install transmission-common transmission-cli transmission-daemon
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  transmission-cli: Depends: transmission-common (= 1.51-0ubuntu3.1) but 2.04-0ubuntu1.09.04.1 is to be installed
  transmission-daemon: Depends: transmission-common (= 1.51-0ubuntu3.1) but 2.04-0ubuntu1.09.04.1 is to be installed
E: Broken packages


So it looks like the cli and daemon packages for 2.04 have dependencies on 1.51. Is that right? Unfortunately if I understand correctly that's the part I need to upgrade since that's where Clutch is.

Thanks for any and all help.


Did you remember to fetch the new package lists with apt-get update? I just checked the transmissionbt ppa package and the dependency for transmission-common is correct.

Code: Select all

$ dpkg-deb -I transmission-daemon_2.04-0ubuntu1.09.04.1_amd64.deb | grep "^ Depends"
 Depends: libc6 (>= 2.7), libcurl3-gnutls (>= 7.16.2-1), libevent-1.4-2 (>= 1.4.11-stable), libssl0.9.8 (>= 0.9.8f-5), zlib1g (>= 1:1.1.4), transmission-common (= 2.04-0ubuntu1.09.04.1), lsb-base (>= 3.0)

Also, only explicitly install the packages you want and let the package manager install the rest because otherwise your likely to end up with lots of cruft floating around.

Lemming
Posts: 4
Joined: Sun Aug 15, 2010 3:19 pm

Re: Problems using web interface

Postby Lemming » Mon Aug 16, 2010 8:24 am

Thanks for all the replies. I did use apt-get update:

Code: Select all

colin@ubuntu:~$ sudo apt-get update
Hit http://ppa.launchpad.net jaunty Release.gpg
<snip>
Reading package lists... Done


I removed the old version using apt-get remove --purge, but I still get:

Code: Select all

colin@ubuntu:~$ sudo apt-get install transmission-daemon
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  transmission-daemon: Depends: transmission-common (= 1.51-0ubuntu3.1) but 2.04-0ubuntu1.09.04.1 is to be installed
                       Recommends: transmission-cli (>= 1.50-1) but it is not going to be installed
E: Broken packages


Could this be an architecture problem? I'm doing all this on an ARM-based SheevaPlug - could it be that the versions are bad or that only certain versions exist on ARM?

Longinus00
Posts: 137
Joined: Fri Aug 21, 2009 5:46 am

Re: Problems using web interface

Postby Longinus00 » Mon Aug 16, 2010 3:34 pm

Your hunch is correct, the ppa only has packages for amd64, i386, and lpia.

Lemming
Posts: 4
Joined: Sun Aug 15, 2010 3:19 pm

Re: Problems using web interface

Postby Lemming » Mon Aug 16, 2010 10:28 pm

Ok, thanks for all the help, I'll look into building from source.


Return to “Web Interface”