[SOLVED] 403: Forbidden!!!!!!

Discussion of the Web Interface for Transmission, formerly known as Clutch. This applies to all version of Transmission
thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

[SOLVED] 403: Forbidden!!!!!!

Postby thebrandon » Mon Sep 13, 2010 3:45 am

so every time i try to bring up the webui i get the following msg on my browser :

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

I have tried to adjust the rpc settings and I cannot get anything to fix the problem. The only thing that works is for me to connect to my server and run this command : transmission-daemon -p 9091 -f -T -a 192.168.2.4

The last part is of course the exact ip of my laptop. How to I get access when my server runs the regular daemon at startup?

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: 403: Forbidden!!!!!!

Postby x190 » Mon Sep 13, 2010 4:34 am

https://trac.transmissionbt.com/wiki/Ed ... gFiles#RPC

Please note that daemon must be stopped when editing settings.json in order for changes to stick.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

Re: 403: Forbidden!!!!!!

Postby thebrandon » Mon Sep 13, 2010 1:31 pm

I am still getting the msg even though stopped the daemon before changing it :

brandon@server:~$ sudo /etc/init.d/transmission-daemon stop
[sudo] password for brandon:
* Stopping bittorrent daemon transmission-daemon [ OK ]
brandon@server:~$ sudo nano ~/.config/transmission/settings.json
brandon@server:~$ sudo /etc/init.d/transmission-daemon start
* Starting bittorrent daemon transmission-daemon [ OK ]
brandon@server:~$

Maybe there is something in my json file thats wrong?

{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-date": 1284303977,
"blocklist-enabled": false,
"blocklist-updates-enabled": true,
"dht-enabled": true,
"download-dir": "/home/brandon/Downloads",
"encryption": 1,
"filter-mode": "show-all",
"incomplete-dir": "/home/brandon/Downloads",
"incomplete-dir-enabled": false,
"inhibit-desktop-hibernation": false,
"lazy-bitfield-enabled": true,
"main-window-height": 500,
"main-window-is-maximized": 0,
"main-window-layout-order": "menu,toolbar,filter,list,statusbar",
"main-window-width": 467,
"main-window-x": 50,
"main-window-y": 50,
"message-level": 2,
"minimal-view": false,
"open-dialog-dir": "/home/brandon",
"open-file-limit": 32,
"peer-limit-global": 240,
"peer-limit-per-torrent": 60,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": 0,
"pex-enabled": true,
"play-download-complete-sound": true,
"port-forwarding-enabled": true,
"preallocation": 1,
"prompt-before-exit": true,
"proxy": "",
"proxy-auth-enabled": false,
"proxy-auth-password": "",
"proxy-auth-username": "",
"proxy-enabled": false,
"proxy-port": 80,
"proxy-type": 0,
"ratio-limit": 2.0000,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": false,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": false,
"rpc-password": "{7a2106cf3cea9d3f0f441f43d0732f80ca117948zOlM4FoI",
"rpc-port": 9091,
"rpc-username": "brandon",
"rpc-whitelist": "192.168.2.4",
"rpc-whitelist-enabled": true,
"show-backup-trackers": false,
"show-desktop-notification": true,
"show-extra-peer-details": false,
"show-filterbar": true,
"show-notification-area-icon": false,
"show-options-window": true,
"show-statusbar": true,
"show-toolbar": true,
"show-tracker-scrapes": false,
"sort-mode": "sort-by-name",
"sort-reversed": false,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"statusbar-stats": "total-ratio",
"trash-original-torrent-files": false,
"umask": 18,
"upload-slots-per-torrent": 14,
"user-has-given-informed-consent": true,
"watch-dir": "/home/brandon/Downloads",
"watch-dir-enabled": false
}

I have tried putting everything from 0.0.0.0 to *.*.*.* and even 192.168.2.* on the whitelist. Ive tried turning the whitelist enabling to false.

Longinus00
Posts: 137
Joined: Fri Aug 21, 2009 5:46 am

Re: 403: Forbidden!!!!!!

Postby Longinus00 » Mon Sep 13, 2010 2:26 pm

"rpc-enabled": false,


This disables the webui.

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

Re: 403: Forbidden!!!!!!

Postby thebrandon » Mon Sep 13, 2010 3:24 pm

I changed it to true, stopping the daemon before doing so, and upon restart it still doesnt work.

oxygen8
Posts: 3
Joined: Wed Apr 28, 2010 5:31 am

Re: 403: Forbidden!!!!!!

Postby oxygen8 » Mon Sep 13, 2010 3:44 pm

I use Transmission 2.04 on ARM9 Kirkwood.

Use

"rpc-whitelist": "*.*.*.*",
"rpc-whitelist-enabled": 1,

in settings.json an you can connect one time.

By killing transmission-daemon your 1 will be replaced with true. On next boot you get an error.

I start transmission daemon with -a *.*.*.*

This works fine.


My S95transmission in /etc/init.d/


/opt/bin/transmission-daemon -a *.*.*.* -g /root/.config/transmission-daemon

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

Re: 403: Forbidden!!!!!!

Postby thebrandon » Mon Sep 13, 2010 4:47 pm

Ok you kinda lost me there at the end. So can I change the init.d script to startup like that, or do I have to make a different one? Like I said earlier the command transmission-daemon -p 9091 -f -T -a 192.168.2.4 works so if I could make it run that on startup that would be great, I just dont know how to do it.

Longinus00
Posts: 137
Joined: Fri Aug 21, 2009 5:46 am

Re: 403: Forbidden!!!!!!

Postby Longinus00 » Tue Sep 14, 2010 12:25 am

thebrandon wrote:I changed it to true, stopping the daemon before doing so, and upon restart it still doesnt work.


Was the whitelist disabled as well?

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

Re: 403: Forbidden!!!!!!

Postby thebrandon » Tue Sep 14, 2010 3:31 am

No but I have tried it enabled and disabled with the same result

Longinus00
Posts: 137
Joined: Fri Aug 21, 2009 5:46 am

Re: 403: Forbidden!!!!!!

Postby Longinus00 » Tue Sep 14, 2010 3:03 pm

thebrandon wrote:No but I have tried it enabled and disabled with the same result


Well, you need to have both the rpc enabled and the whitelist disabled at the same time for this to work. If you disabled the rcp it doesn't matter what you set your whitelist to and if you have a bad whitelist it doesn't matter if you enabled rpc or not.

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

Re: 403: Forbidden!!!!!!

Postby thebrandon » Tue Sep 14, 2010 4:10 pm

Ok so I went back and stopped the daemon and made sure rpc was enabled and the whitelist was disabled, here is a copy of my settings :

{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-date": 1284303977,
"blocklist-enabled": false,
"blocklist-updates-enabled": true,
"dht-enabled": true,
"download-dir": "/home/brandon/Downloads",
"encryption": 1,
"filter-mode": "show-all",
"incomplete-dir": "/home/brandon/Downloads",
"incomplete-dir-enabled": false,
"inhibit-desktop-hibernation": false,
"lazy-bitfield-enabled": true,
"main-window-height": 500,
"main-window-is-maximized": 0,
"main-window-layout-order": "menu,toolbar,filter,list,statusbar",
"main-window-width": 467,
"main-window-x": 50,
"main-window-y": 50,
"message-level": 2,
"minimal-view": false,
"open-dialog-dir": "/home/brandon",
"open-file-limit": 32,
"peer-limit-global": 240,
"peer-limit-per-torrent": 60,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": 0,
"pex-enabled": true,
"play-download-complete-sound": true,
"port-forwarding-enabled": true,
"preallocation": 1,
"prompt-before-exit": true,
"proxy": "",
"proxy-auth-enabled": false,
"proxy-auth-password": "",
"proxy-auth-username": "",
"proxy-enabled": false,
"proxy-port": 80,
"proxy-type": 0,
"ratio-limit": 2.0000,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": false,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-password": "{7a2106cf3cea9d3f0f441f43d0732f80ca117948zOlM4FoI",
"rpc-port": 9091,
"rpc-username": "brandon",
"rpc-whitelist": "192.168.2.4",
"rpc-whitelist-enabled": false,
"show-backup-trackers": false,
"show-desktop-notification": true,
"show-extra-peer-details": false,
"show-filterbar": true,
"show-notification-area-icon": false,
"show-options-window": true,
"show-statusbar": true,
"show-toolbar": true,
"show-tracker-scrapes": false,
"sort-mode": "sort-by-name",
"sort-reversed": false,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"statusbar-stats": "total-ratio",
"trash-original-torrent-files": false,
"umask": 18,
"upload-slots-per-torrent": 14,
"user-has-given-informed-consent": true,
"watch-dir": "/home/brandon/Downloads",
"watch-dir-enabled": false
}

Then rather than just restarting the daemon I rebooted my server and when i went to the address http://192.168.2.3:9091/ I still get the exact same message :

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

The command I am using to pull up my settings file is sudo gedit ~/.config/transmission/settings.json is it possible that transmission is actually looking at a different settings file somewhere else?

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

Re: 403: Forbidden!!!!!!

Postby thebrandon » Tue Sep 14, 2010 4:35 pm

Well I realize one thing I was definitely doing wrong which was editing the file ~/.config/transmission/settings.json when I should have been editing ~/.config/transmission-daemon/settings.json but once I realized this I went through and changed it appropriately and yet im still getting the 403 Forbidden message. Here is my ~/.config/transmission-daemon/settings.json file.

{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"dht-enabled": true,
"download-dir": "/home/brandon/Downloads",
"encryption": 1,
"incomplete-dir": "/home/brandon/Downloads",
"incomplete-dir-enabled": false,
"lazy-bitfield-enabled": true,
"message-level": 2,
"open-file-limit": 32,
"peer-limit-global": 240,
"peer-limit-per-torrent": 60,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": 0,
"pex-enabled": true,
"port-forwarding-enabled": true,
"preallocation": 1,
"proxy": "",
"proxy-auth-enabled": false,
"proxy-auth-password": "",
"proxy-auth-username": "",
"proxy-enabled": false,
"proxy-port": 80,
"proxy-type": 0,
"ratio-limit": 2.0000,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": false,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-password": "{d6e9c24411cb941e21beeb7e7f8d98a1c2dc33a5N1YgXXMh",
"rpc-port": 9091,
"rpc-username": "",
"rpc-whitelist": "*.*.*.*",
"rpc-whitelist-enabled": false,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"umask": 18,
"upload-slots-per-torrent": 14
}

Should I add a username or leave the whitelist field blank? What about changing the rpc-password to blank?

Longinus00
Posts: 137
Joined: Fri Aug 21, 2009 5:46 am

Re: 403: Forbidden!!!!!!

Postby Longinus00 » Tue Sep 14, 2010 5:23 pm

The daemon probably doesn't use ~/.config/bla if you're running it from the init script. I assume you're on a debian based system so go look at this https://trac.transmissionbt.com/wiki/UnixServer/Debian

thebrandon
Posts: 8
Joined: Mon Sep 13, 2010 3:38 am

<SOLVED> Re: 403: Forbidden!!!!!!

Postby thebrandon » Wed Sep 15, 2010 3:58 am

Well that definitely did it! I was editing the wrong file, the correct path is /etc/transmission-daemon/settings.json

Thanks for all your help!

n_i_x
Posts: 2
Joined: Thu Dec 30, 2010 5:13 am

Re: 403: Forbidden!!!!!!

Postby n_i_x » Thu Dec 30, 2010 5:42 am

x190 wrote:https://trac.transmissionbt.com/wiki/EditConfigFiles#RPC

Please note that daemon must be stopped when editing settings.json in order for changes to stick.


Sorry for responding to a thread 3 months old... but...

`killall -HUP transmission-daemon` will cause transmission-daemon to reload the settings and the changes stick after a service restart.


Return to “Web Interface”