Can't add .torrent files

Discussion of the Web Interface for Transmission, formerly known as Clutch. This applies to all version of Transmission
scarleo
Posts: 4
Joined: Sun Nov 14, 2010 12:42 pm

Can't add .torrent files

Postby scarleo » Sun Nov 14, 2010 1:03 pm

Hi, I've seen that there are a few posts on this matter, however none of them seem to solve my problem.

I'm running a transmission-daemon on openSUSE 11.2 and I'm unable to add .torrent files. I've tried both uploading and adding through URL but both fails. If I add a magnet link URL it works great. I have tried from open trackers so no username/password needed. I've also tried with a lot of different permissions on my folders; owned and writeable by 'root', 'transmission', a LINUX 'user' and also writable by everyone (chmod 777). Transmission is run as user 'transmission' None of this helps. My transmission version is 'Transmission 2.03 (11030)'.

Is this a known problem that is solved in most recent version? Is there anyway for me to fix/workaround it in this version (2.03)?

Thanks.

scarleo
Posts: 4
Joined: Sun Nov 14, 2010 12:42 pm

Re: Can't add .torrent files

Postby scarleo » Sun Nov 14, 2010 1:48 pm

Ok, I have now tried version 2.11 with same result as above, still unable to add .torrent files. I have ran it with '-f' to see what happens when I try to add torrents but there is just no output, neither in the log. All is quiet and non-functioning.

This is my settings.json in case that helps:

Code: Select all

{
    "alt-speed-down": 50000,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 100,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-date": 1287936452,
    "blocklist-enabled": true,
    "blocklist-updates-enabled": true,
    "cache-size-mb": 2,
    "compact-view": false,
    "dht-enabled": true,
    "download-dir": "/home/oscar/Videos/Download",
    "encryption": 1,
    "filter-mode": "show-all",
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/home/oscar/Videos/Download/Torrents",
    "incomplete-dir-enabled": true,
    "inhibit-desktop-hibernation": false,
    "lazy-bitfield-enabled": true,
    "lpd-enabled": false,
    "main-window-height": 691,
    "main-window-is-maximized": 0,
    "main-window-layout-order": "menu,toolbar,filter,list,statusbar",
    "main-window-width": 795,
    "main-window-x": 165,
    "main-window-y": 151,
    "message-level": 2,
    "minimal-view": false,
    "open-dialog-dir": "/home/oscar/Download/Torrents",
    "open-file-limit": 32,
    "peer-limit-global": 3000,
    "peer-limit-per-torrent": 300,
    "peer-port": 6881,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": 0,
    "pex-enabled": true,
    "play-download-complete-sound": true,
    "port-forwarding-enabled": true,
    "preallocation": 2,
    "prompt-before-exit": false,
    "proxy": "",
    "proxy-auth-enabled": false,
    "proxy-auth-password": "",
    "proxy-auth-username": "",
    "proxy-enabled": false,
    "proxy-port": 80,
    "proxy-type": 0,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "recent-download-dir-1": "/media",
    "recent-download-dir-2": "/media/disk/Torrents",
    "recent-download-dir-3": "/home/oscar/Download/Torrents",
    "remote-session-enabled": false,
    "remote-session-host": "localhost",
    "remote-session-password": "",
    "remote-session-port": 9091,
    "remote-session-requres-authentication": true,
    "remote-session-username": "webuser",
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-password": "{e863381713ac2789c4b4e5c5f45fa80f84dbd964PaDChPAc",
    "rpc-port": 9091,
    "rpc-username": "webuser",
    "rpc-whitelist": "192.168.0.*",
    "rpc-whitelist-enabled": false,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "/home/oscar/Documents",
    "show-backup-trackers": true,
    "show-desktop-notification": true,
    "show-extra-peer-details": true,
    "show-filterbar": true,
    "show-notification-area-icon": true,
    "show-options-window": true,
    "show-statusbar": true,
    "show-toolbar": true,
    "show-tracker-scrapes": true,
    "sort-mode": "sort-by-name",
    "sort-reversed": false,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 200,
    "speed-limit-up-enabled": true,
    "start-added-torrents": true,
    "statusbar-stats": "total-ratio",
    "trash-original-torrent-files": true,
    "umask": 18,
    "upload-slots-per-torrent": 14,
    "user-has-given-informed-consent": true,
    "watch-dir": "/home/oscar/Download",
    "watch-dir-enabled": false
}



EDIT: Sorry about the one man show here :). Just wanted to say that I am able to add some torrents. This of course makes it even harder to troubleshoot. The torrents are from the same source/tracker. There is no apparent difference but some adds fine and some doesn't.

Rolcol
Posts: 337
Joined: Sun Aug 10, 2008 8:00 am

Re: Can't add .torrent files

Postby Rolcol » Mon Nov 15, 2010 12:39 pm

Are there any problems with magnet links disappearing after restarting Transmission? That would mean that permissions might be the issue even after setting it to a+rwx.

How many torrents have you tried? The one(s) you're trying may be "corrupted".

I don't have many ideas to try, sorry.

scarleo
Posts: 4
Joined: Sun Nov 14, 2010 12:42 pm

Re: Can't add .torrent files

Postby scarleo » Fri Nov 19, 2010 3:28 pm

No, magnet links are fine, even after restarting transmission. I've tried a lot of torrents (abt. 100), I haven't kept an exact score but I'd say that about half of them works. The ones that doesn't work adds fine on local transmission (not the web UI on server), the same download also works in web UI if added as magnet link (I know this isn't the same but still). I don't believe all those torrents are currupt, especially as they add fine in local transmission, what would be the difference? I have noticed that some trackers are more frequent in the ones that doesn't work but I have to look into that further before I can say for sure.


Return to “Web Interface”