webUI bug with Basic access authentication

Discussion of the Web Interface for Transmission, formerly known as Clutch. This applies to all version of Transmission
Anton9121
Posts: 8
Joined: Mon Jul 14, 2014 4:47 am

webUI bug with Basic access authentication

Postby Anton9121 » Wed May 04, 2016 2:01 am

Hello! I try open webUI using link like

Code: Select all

http://login:password@192.168.0.1:9091/

but when tab open (Chrome) - webUI always refresh.

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: webUI bug with Basic access authentication

Postby x190 » Wed May 04, 2016 7:41 pm

What's in the loaded settings.json file?

https://trac.transmissionbt.com/wiki/EditConfigFiles
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

Anton9121
Posts: 8
Joined: Mon Jul 14, 2014 4:47 am

Re: webUI bug with Basic access authentication

Postby Anton9121 » Thu May 05, 2016 2:18 am

x190 wrote:What's in the loaded settings.json file?

https://trac.transmissionbt.com/wiki/EditConfigFiles


Default settings.json

Code: Select all

{
    "alt-speed-down": 3072,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 960,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": true,
    "alt-speed-time-end": 0,
    "alt-speed-up": 1024,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/torrents",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "download-queue-enabled": true,
    "download-queue-size": 15,
    "encryption": 2,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/torrents/incomplete",
    "incomplete-dir-enabled": false,
    "lpd-enabled": true,
    "max-peers-global": 200,
    "message-level": 2,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 40,
    "peer-limit-per-torrent": 10,
    "peer-port": 44444,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 1.5000,
    "ratio-limit-enabled": true,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "192.168.0.1",
    "rpc-enabled": true,
    "rpc-password": "<password>",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "Username",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 1328,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 102,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-limit": 100,
    "upload-limit-enabled": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true
}

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: webUI bug with Basic access authentication

Postby x190 » Thu May 05, 2016 3:26 pm

Connect with something like "http://192.168.0.1:9091/transmission/web/" and you should then be asked for your credentials.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

Anton9121
Posts: 8
Joined: Mon Jul 14, 2014 4:47 am

Re: webUI bug with Basic access authentication

Postby Anton9121 » Thu May 05, 2016 3:58 pm

x190 wrote:Connect with something like "http://192.168.0.1:9091/transmission/web/" and you should then be asked for your credentials.

I enter username and password in url, and page always refresh with 409 error. If i enter http://192.168.0.1:9091/transmission/web/ all work fine, problem when url with username and password.

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: webUI bug with Basic access authentication

Postby x190 » Thu May 05, 2016 11:00 pm

I enter username and password in url, and page always refresh with 409 error.

Does another page refresh fix it?

If i enter http://192.168.0.1:9091/transmission/web/ all work fine, ...

Does it then correctly ask for your credentials?
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

Anton9121
Posts: 8
Joined: Mon Jul 14, 2014 4:47 am

Re: webUI bug with Basic access authentication

Postby Anton9121 » Fri May 06, 2016 11:10 am

Does another page refresh fix it?

Don't fix, while I don't enter url without username and password. If I enter full path
http://<username>:<password>@192.168.0.1:9091/transmission/web/
page refresh too. Page don't reload, It clear and load resource again, I can see torrents but it blinking.

Does it then correctly ask for your credentials?

Yes ask credentials and after manual enter work fine.

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: webUI bug with Basic access authentication

Postby x190 » Fri May 06, 2016 1:57 pm

If you think this is still a problem, there is a lot of info on the forum.

Sample:
viewtopic.php?f=8&t=8393&p=60629&hilit=409+error&sid=f66a42311a672b209e04cc5ecf56bedf#p53778
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

Anton9121
Posts: 8
Joined: Mon Jul 14, 2014 4:47 am

Re: webUI bug with Basic access authentication

Postby Anton9121 » Fri May 06, 2016 4:11 pm

x190 wrote:If you think this is still a problem, there is a lot of info on the forum.

Sample:
viewtopic.php?f=8&t=8393&p=60629&hilit=409+error&sid=f66a42311a672b209e04cc5ecf56bedf#p53778


I think that 409 error because often refresh, this bug in js webUI.


Return to “Web Interface”