Web UI on a headless ubuntu server 9.04

Discussion of the Web Interface for Transmission, formerly known as Clutch. This applies to all version of Transmission
leoplanet
Posts: 3
Joined: Sat Aug 01, 2009 8:29 am

Web UI on a headless ubuntu server 9.04

Postby leoplanet » Mon Aug 03, 2009 9:43 am

Hey Guys,

I am new to the command line environment and have recently setup a ubuntu server 9.04 for learning purpose.

After spending a lot (read LOT) of hours I have still not been able to use Transmission web UI. I get error
--------------------------------------------------start------------------------------------------------------------------------------------
401: Unauthorized
Unauthorized IP Address.
Either disable the IP address whitelist or add your address to it.
If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.
If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.
======================================end===========================================================
Here is how I set Transmission up and some other details to help you help me...

I setup transmission using sudo apt-get install transmission
then I setup a user transmission without password
I also edited the file /etc/init.d/transmission-daemon and updated USER transmission
I changed the file /home/transmission/.config/transmission/settings.json and made rpc-whitelist-enabled 0 and rpc whitelist *.*.*.*
then I retarted transmission

I still get the same error

Here is a dump when I run transmission-daemon --debug -si
-----------------------------------------------------------------------start-----------------------------------------------------------
* Couldn't find host localhost in the .netrc file, using defaults
* About to connect() to localhost port 9091 (#0)
* Trying ::1... * Unknown error 111
* Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.51 (7963)
Host: localhost:9091
Accept: */*
Content-Length: 69
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 401 Unauthorized
< Server: Transmission
< WWW-Authenticate: Basic realm="Transmission"
< Date: Mon, 03 Aug 2009 09:14:50 GMT
< Content-Length: 43
< Content-Type: text/html; charset=ISO-8859-1
<
* Connection #0 to host localhost left intact
got response:
--------
<h1>401: Unauthorized</h1>Unauthorized User
--------
[19:14:50.031] JSON parser failed at line 1, column 1: "< h1>401: Unautho"
[19:14:50.031] transmission-remote: Unable to parse response "<h1>401: Unauthorized</h1>Unauthorized User"
============================================end======================================================

I am unsure as to what I can do next???

Please please if you could help I would really appreciate it.

I must warn you though that I am not an advanced linux user but can follow instructions well.

Thankyou

leoplanet

dude
Posts: 14
Joined: Fri Feb 20, 2009 9:20 am

Re: Web UI on a headless ubuntu server 9.04

Postby dude » Mon Aug 03, 2009 6:09 pm

I also have headless ubuntu server 9.04 and transmission-daemon works very well there. The problem is the default configuration of transmission on ubuntu, which is a bit paranoid: as far as I remember, access is allowed from localhost by default, and also a password is required. So you need to edit the config file to make it work (although right now I cannot say specifically what you did wrong).

I believe the safest way with these things is to make as little changes as possible if you are not sure what you do. For example, I do not see any reason to edit the init script, the one provided in the package works fine. Also why don't you try access with a password first (as that is the default setting). And you could also first try access from the server itself (access fro localhost is allowed by default) by using transmission-remote. If that works, you at least know that the daemon is ok, and then you can go ahead and edit the config further.

Also, remember that you need to edit the config while the daemon is stopped, otherwise your changes will be overwritten.
transmission-daemon on ubuntu-server 9.10

leoplanet
Posts: 3
Joined: Sat Aug 01, 2009 8:29 am

Re: Web UI on a headless ubuntu server 9.04

Postby leoplanet » Wed Aug 05, 2009 3:00 pm

Thanks so much 'dude'.

I did exactly as you said and it worked well.

Thanks again.

Leo

leoplanet
Posts: 3
Joined: Sat Aug 01, 2009 8:29 am

Re: Web UI on a headless ubuntu server 9.04

Postby leoplanet » Thu Aug 06, 2009 11:04 am

Just for the benefit of others here is what I did and worked for me.

Objective: Install transmission on a headless Ubuntu server 9.04 Jaunty. Use it though the Web Interface.

SSH into your server

Install transmission using the following command

sudo apt-get install transmission

If you have installed it before and made changes etc and want to start fresh then uninstall it first like so

sudo apt-get --purge autoremove transmission (this will remove all config files as well)

Also check that you have not left any transmission files or folders behind and delete them for a fresh clean start

sudo find / -iname transmission
sudo find /-iname settings.json


Once installed find the settings.json file using

sudo find / -iname settings.json

You will most likely find it in two places.

/var/lib/transmission-daemon/info/settings.json
/etc/transmission-daemon/settings.json


Don't touch the one under

/var/lib/transmission-daemon/info/settings.json

First stop the transmission-daemon using

sudo /etc/init.d/transmission-daemon stop

Now edit the settings.json file using

sudo nano /etc/transmission-daemon/settings.json

Change "rpc-whitelist": "127.0.0.1", to "rpc-whitelist": "*.*.*.*",

Change the username and password on the following lines to what you like
"rpc-password": "password",
"rpc-username": "username",


save the file and exit

now start transmission using

sudo /etc/init.d/transmission-daemon start

Make sure that the ports 9091 and 51413 is forwarded to your ubuntu server. ( not entirely sure if you need 51413 forwarded or not but I have it and it works so give it a go or not whichever works for you)

Now go to any computer in your house and try the URL http://your-ubuntu-server-IP:9091

Voila!

Good luck guys I just thought since I spent so much time on it I might be able to save someone elses...

Leo

0control
Posts: 3
Joined: Sat Mar 07, 2009 9:37 pm

Re: Web UI on a headless ubuntu server 9.04

Postby 0control » Sun Aug 09, 2009 12:54 am

Thank you for sharing your walk-through.

As a side-note I just want to inform that to get it to work I also had to install transmission-daemon in addition to transmission.

dude
Posts: 14
Joined: Fri Feb 20, 2009 9:20 am

Re: Web UI on a headless ubuntu server 9.04

Postby dude » Sun Aug 09, 2009 3:59 pm

For a headless server it would probably be a better choice to install "transmission-daemon" package, as it has less dependencies than regular "transmission". It will not pull the GTK stuff, etc. Here's what I've got:

Code: Select all

user@server:~$ sudo aptitude search transmission
p   transmission                                  - lightweight BitTorrent client                             
p   transmission-cli                              - lightweight BitTorrent client (command line interface)   
i A transmission-common                           - lightweight BitTorrent client (common files)             
i   transmission-daemon                           - lightweight BitTorrent client (daemon)                   
p   transmission-dbg                              - lightweight BitTorrent client (debugging symbols)         
p   transmission-gtk                              - lightweight BitTorrent client (graphical interface) 
transmission-daemon on ubuntu-server 9.10

playcat
Posts: 2
Joined: Mon Aug 17, 2009 9:01 am

Re: Web UI on a headless ubuntu server 9.04

Postby playcat » Mon Aug 17, 2009 9:36 am

Hello everyone,

I installed transmission daemon, edited config files following all the information found here. My router is set to fwd ports from 0-10999 and 12001-65535 (I reserved some space for my laptop w Vista, so I can play worms :) ) .
Just to be on a safe side (avoid rewriting) I stopped transmission-daemon, started it again and then copied settings.json file. Here it is:

Code: Select all

{
    "blocklist-enabled": 0,
    "download-dir": "\/home\/hidden\/SHARED",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "encryption": 1,
    "lazy-bitfield-enabled": 1,
    "max-peers-global": 200,
    "message-level": 2,
    "open-file-limit": 32,
    "peer-limit-global": 240,
    "peer-limit-per-torrent": 60,
    "peer-port": 33999,
    "peer-port-random-enabled": 0,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 1024,
    "peer-socket-tos": 0,
    "pex-enabled": 1,
    "port-forwarding-enabled": 0,
    "preallocation": 1,
    "proxy": "",
    "proxy-auth-enabled": 0,
    "proxy-auth-password": "",
    "proxy-auth-username": "",
    "proxy-enabled": 0,
    "proxy-port": 80,
    "proxy-type": 0,
    "rpc-authentication-required": 1,
    "rpc-enabled": 1,
    "rpc-password": "hidden",
    "rpc-port": 44250,
    "rpc-username": "hidden",
    "rpc-whitelist": "*.*.*.*",
    "rpc-whitelist-enabled": 1,
    "upload-limit": 4,
    "upload-limit-enabled": 1,
    "upload-slots-per-torrent": 14,
    "watch-dir": "\/home\/hidden\/.config\/transmission\/torrents"
}


However, while web ui looks nice and works perfectly when accessed via 192.168.1.7:44250, it totally doesn't work with my.ip.num.num:44250.

I tried to telnet to this address, but connection could not be established. When I used some web port-scanner, this is what I got:

Code: Select all

Scanning ports on 79.masked.masked.132

79.masked.masked.132 is responding on port 44250 ().


Any ideas?

BTW, peer port 33999 works just fine...

Thx,
Dan

playcat
Posts: 2
Joined: Mon Aug 17, 2009 9:01 am

Re: Web UI on a headless ubuntu server 9.04

Postby playcat » Thu Aug 20, 2009 7:47 pm

Hello again,

This thing works now. Not sure why... From few days ago, I was trying to install some server on my computer, and maybe my restarting the computer made things work. Not sure.

Best,
Dan

mysoogal
Posts: 4
Joined: Sat Dec 12, 2009 7:09 pm

Re: Web UI on a headless ubuntu server 9.04

Postby mysoogal » Sat Dec 12, 2009 8:07 pm

if you can't download in /var/www directory

just sudo chmod 777 -R /var/www

now when you add torrents in WebUI should start downloading

chippyash
Posts: 1
Joined: Sun Jan 30, 2011 3:53 pm

Re: Web UI on a headless ubuntu server 9.04

Postby chippyash » Sun Jan 30, 2011 4:08 pm

Just a note - on Ubuntu Lucid (10.04) you should replace

Code: Select all

sudo apt-get install transmission

with

Code: Select all

sudo apt-get install transmission-daemon


the transmission client isn't required - just the daemon

Otherwise thanks for this - I spent hours trying to get it to work and then stumbled on this thread. had it working in minutes. ;-)


Return to “Web Interface”