Cannot access web gui through hostname only IP

Ask for help and report issues with the GTK+ version of Transmission
Posts: 1
Joined: Thu Jan 18, 2018 4:12 pm

Cannot access web gui through hostname only IP

Postby rdurrance » Thu Jan 18, 2018 4:26 pm

I have Transmission Daemon installed on a headless Ubuntu server 16.04 LTS. From the time I installed it (back when the LTS was 14.04), I could access it by using the hostname in the browser address box: (http://<hostname>:9091/transmission/web/) I recently ran an update and now I can only access it with the IP: (http://192.168.x.x:9091/transmission/web/). When I try to use the hostname I get the: "Connection FailedCould not connect to the server. You may need to reload the page to reconnect" pop-up. I am using Transmission 2.84 (14307). As a note, I can ping via hostname. Also Sabnzbd, and sickrage, which are also running on the same server can be accessed via hostname.
More info, I could access it from ANY device as long as I was in the network (home)

Any thoughts?

Thank you,

Posts: 1
Joined: Sat Feb 03, 2018 4:13 pm

Re: Cannot access web gui through hostname only IP

Postby fluxweed » Sat Feb 03, 2018 4:19 pm

I am SO glad you posted this!

I have been going crazy as I have the exact same problem that you describe only I haven't updated anything, it just started doing this!

Like you, I can ping hostname:9091 and it replies with 10.0.x.x ... but if i access the web UI with hostname I'll get connection failed. Access it via it's IP address and boom, no problem. I have NO idea what has started causing this behaviour and ordinarily I wouldn't care too much except for the fact that I can't access my transmission client remotely unless I have the IP of my ISP which is given dynamically ... my dyndns service doesn't work anymore for it since it doesn't let me access my transmission web ui with a hostname anymore. Very frustrating and I hope we can figure this out soon!

Posts: 1
Joined: Mon Feb 19, 2018 10:23 am

Re: Cannot access web gui through hostname only IP

Postby pest85 » Mon Feb 19, 2018 10:27 am

I had the same issue and today i've finally fixed it!
you need to change rpc-host-whitelist in your settings
1) sudo service transmission-daemon stop
2) sudo nano /etc/transmission-daemon/settings.json

Code: Select all


3) sudo service transmission-daemon start

After that it finally works.
Whole settings wiki here

Return to “GTK+ Support”