[BUG FIXED] Web-seeds never seem to work

Ask for help and report issues with the GTK+ version of Transmission
Post Reply
xCrucialDudex
Posts: 4
Joined: Mon Dec 27, 2010 12:12 pm

[BUG FIXED] Web-seeds never seem to work

Post by xCrucialDudex » Mon Dec 27, 2010 12:21 pm

I've created a torrent with a HTTP web-seed with the help of mktorrent but transmission never seem to initiate a file transfer via the specified HTTP link. There was absolutely nothing related to web-seeds in debug level log (via GTK+ GUI), and it was confirmed via apache's logs that transmission didn't try to transfer a file.

For example, uTorrent for linux works just fine so it's not an issue with firewall, apache or something else. Here's the illustration of this http://simplest-image-hosting.net/png-0-screenshot-112: uTorrent found and connected to the web-seed, and started uploading immediately to transmission. Before that transmission stayed there reporting 0 seeder, never finding a web-seed and never initiating a file transfer.

So, is it a bug? Or is it something else?

ArchLinux
transmission 2.13 (11501)
gtk2 2.22.1-1
glib2 2.26.1-1
Last edited by xCrucialDudex on Fri Jan 14, 2011 6:26 am, edited 1 time in total.

xCrucialDudex
Posts: 4
Joined: Mon Dec 27, 2010 12:12 pm

Re: Web-seeds never seem to work

Post by xCrucialDudex » Mon Dec 27, 2010 12:23 pm

Oh, btw here's the torrent file http://okayserver.ath.cx/etc/TheCrisiso ... ed.torrent and I'll leave the test torrent data in place for some reasonable time (a month or so) so if you want to test anything, please, do it.

gunzip
Posts: 272
Joined: Wed May 05, 2010 2:12 am

Re: Web-seeds never seem to work

Post by gunzip » Mon Dec 27, 2010 8:06 pm

no your torrent didn't work for me either using transmission-daemon 2.13+ (11564) in Linux Debian. i tried a different client aria2 and it connected and downloaded in minutes. there is an open ticket re webseeds here:

https://trac.transmissionbt.com/ticket/3519

i hardly run across these type of torrents much so never really paid much attention to them.

xCrucialDudex
Posts: 4
Joined: Mon Dec 27, 2010 12:12 pm

Re: Web-seeds never seem to work

Post by xCrucialDudex » Mon Dec 27, 2010 8:24 pm

and that's exactly the problem. the ticket was opened 4 months ago, well let's just hope this will get fixed soon.

gunzip
Posts: 272
Joined: Wed May 05, 2010 2:12 am

Re: Web-seeds never seem to work

Post by gunzip » Fri Jan 14, 2011 4:07 am

just as a followup, the issues with webseeds were fixed in the recent nightly builds ( r11632 and r11638).

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Web-seeds never seem to work

Post by x190 » Fri Jan 14, 2011 4:16 am

gunzip wrote:just as a followup, the issues with webseeds were fixed in the recent nightly builds ( r11632 and r11638).
Test torrent above now d/ls immediately. :)
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

xCrucialDudex
Posts: 4
Joined: Mon Dec 27, 2010 12:12 pm

Re: Web-seeds never seem to work

Post by xCrucialDudex » Fri Jan 14, 2011 6:25 am

Awesome. Thanks a lot for tackling this quick!

Post Reply