Gtk3

Ask for help and report issues with the GTK+ version of Transmission
Post Reply
Hairy_palms
Posts: 6
Joined: Fri Oct 07, 2011 8:00 pm

Gtk3

Post by Hairy_palms » Fri Oct 07, 2011 8:07 pm

i recently noticed that the ticket at
https://trac.transmissionbt.com/ticket/4320
was closed and marked fixed, but i cannot seem to get it to compile against the gtk3 dev headers with the latest svn checkout, any attempt to compile the gtk interface fails unless i install the gtk2 development headers, is there a compile option that ive not noticed that i should be using?

Jordan
Transmission Developer
Posts: 2311
Joined: Sat May 26, 2007 3:39 pm
Location: Titania's Room

Re: Gtk3

Post by Jordan » Fri Oct 07, 2011 8:30 pm

Pastebin the compile error and let's take a look.

Hairy_palms
Posts: 6
Joined: Fri Oct 07, 2011 8:00 pm

Re: Gtk3

Post by Hairy_palms » Sat Oct 08, 2011 7:19 am

well, there is no specific error other than

Code: Select all

configure: error: "GTK+ not found!"
command im using to compile is

Code: Select all

./autogen.sh --prefix=/usr --enable-gtk
if i install the gtk2 headers, libgtk2.0-dev on ubuntu it compiles fine, but only as gtk2
libgtk-3-dev is installed but transmission will not use it to compile,
running

Code: Select all

export GTK_PATH=/usr/lib/gtk-3.0
has no effect
Last edited by Hairy_palms on Sat Oct 08, 2011 7:33 am, edited 2 times in total.

Hairy_palms
Posts: 6
Joined: Fri Oct 07, 2011 8:00 pm

Re: Gtk3

Post by Hairy_palms » Sat Oct 08, 2011 7:32 am

symlinking /usr/include/gtk-3.0 to /usr/include/gtk-2.0 doesnt fix anything either

Hairy_palms
Posts: 6
Joined: Fri Oct 07, 2011 8:00 pm

Re: Gtk3

Post by Hairy_palms » Sun Oct 09, 2011 7:23 pm

changing the cflags inside the makefile to /usr/include/gtk-3.0 instead of /usr/include/gtk-2.0 doesnt help either

Hairy_palms
Posts: 6
Joined: Fri Oct 07, 2011 8:00 pm

Re: Gtk3

Post by Hairy_palms » Mon Oct 10, 2011 2:02 pm

pls, tell me if im being stupid and missing something obvious here, but transmission seems to be unable to use gtk3 to compile against?

if you want the config.log output its just

Code: Select all

configure:17863: checking for GTK
configure:17875: $PKG_CONFIG --exists --print-errors "gtk+-2.0 >= $GTK_MINIMUM
                   glib-2.0 >= $GLIB_MINIMUM
                   gio-2.0 >= $GIO_MINIMUM,
                   gmodule-2.0 >= $GLIB_MINIMUM
                   gthread-2.0 >= $GLIB_MINIMUM"
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
configure:17882: $? = 1
configure:17905: $PKG_CONFIG --exists --print-errors "gtk+-2.0 >= $GTK_MINIMUM
                   glib-2.0 >= $GLIB_MINIMUM
                   gio-2.0 >= $GIO_MINIMUM,
                   gmodule-2.0 >= $GLIB_MINIMUM
                   gthread-2.0 >= $GLIB_MINIMUM"
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
configure:17912: $? = 1
No package 'gtk+-2.0' found
configure:17952: result: no
configure:17977: error: "GTK+ not found!"
doesnt seem to even look for gtk3

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Gtk3

Post by x190 » Tue Oct 11, 2011 4:40 am

The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

Hairy_palms
Posts: 6
Joined: Fri Oct 07, 2011 8:00 pm

Re: Gtk3

Post by Hairy_palms » Tue Oct 11, 2011 7:59 am

ah thx, i got it to build now, but it still wont build without the gtk2 headers installed , but it did build as gtk3 with them installed, gtk3 transmission up and running now, the trayicon works, but the ubuntu style appindicator doesnt under gtk, even tho it built the indicator support according to the output, but thats a minor thing, toggling the "Show Transmission icon in the Notification Area" option gives

Code: Select all

(transmission-gtk:25154): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -3 and height 24
not sure if thats related

Code: Select all

line 18035
pkg_failed=no
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GTK2" >&5
$as_echo_n "checking for GTK2... " >&6; }

if test -n "$PKG_CONFIG"; then
    if test -n "$GTK2_CFLAGS"; then
        pkg_cv_GTK2_CFLAGS="$GTK2_CFLAGS"
    else
        if test -n "$PKG_CONFIG" && \
    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 >= \$GTK2_MINIMUM\""; } >&5
  ($PKG_CONFIG --exists --print-errors "gtk+-2.0 >= $GTK2_MINIMUM") 2>&5
  ac_status=$?
  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
  test $ac_status = 0; }; then
  pkg_cv_GTK2_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 >= $GTK2_MINIMUM" 2>/dev/null`
else
  pkg_failed=yes
fi
    fi
else
	pkg_failed=untried
fi
if test -n "$PKG_CONFIG"; then
    if test -n "$GTK2_LIBS"; then
        pkg_cv_GTK2_LIBS="$GTK2_LIBS"
    else
        if test -n "$PKG_CONFIG" && \
    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 >= \$GTK2_MINIMUM\""; } >&5
  ($PKG_CONFIG --exists --print-errors "gtk+-2.0 >= $GTK2_MINIMUM") 2>&5
  ac_status=$?
  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
  test $ac_status = 0; }; then
  pkg_cv_GTK2_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 >= $GTK2_MINIMUM" 2>/dev/null`
else
  pkg_failed=yes
fi
    fi
else
	pkg_failed=untried
fi



if test $pkg_failed = yes; then

if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
        _pkg_short_errors_supported=yes
else
        _pkg_short_errors_supported=no
fi
        if test $_pkg_short_errors_supported = yes; then
	        GTK2_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "gtk+-2.0 >= $GTK2_MINIMUM"`
        else
	        GTK2_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gtk+-2.0 >= $GTK2_MINIMUM"`
        fi
	# Put the nasty error message in config.log where it belongs
	echo "$GTK2_PKG_ERRORS" >&5

	as_fn_error $? "Package requirements (gtk+-2.0 >= $GTK2_MINIMUM) were not met:

$GTK2_PKG_ERRORS

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK2_CFLAGS
and GTK2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
" "$LINENO" 5
elif test $pkg_failed = untried; then
	{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
as_fn_error $? "The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables GTK2_CFLAGS
and GTK2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see <http://www.freedesktop.org/software/pkgconfig>.
See \`config.log' for more details" "$LINENO" 5; }
else
	GTK2_CFLAGS=$pkg_cv_GTK2_CFLAGS
	GTK2_LIBS=$pkg_cv_GTK2_LIBS
        { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
	gtk_version="2" with_gtk_default="yes"
fi
seems to be checked regardless of whether gtk3 is present or not

Post Reply