"no data found" stays even after correcting the folder

Ask for help and report issues with the GTK+ version of Transmission
tuxolero
Posts: 43
Joined: Mon Mar 11, 2013 8:05 pm

"no data found" stays even after correcting the folder

Postby tuxolero » Mon Oct 27, 2014 10:54 pm

Hi there,

I just moved some files manually and then I changed the location in the torrent's properties using the "data is already there" option.
Unfortunately, I selected the wrong folder, and when I tried to "verify local data", i got the "no data found" error. OK, that was my fault.
But when I corrected the folder in the properties, the error message did not go away. I still could not "verify local data".
After closing and restarting Transmission, the torrent was fine and I could successfully "verify local data".

It looks like once a torrent is flagged errorneous, no user action (except restart) can remove this flag.

Is there a trick to remove the error without restart or is that a bug ?

I am using Transmission-GTK 2.84 on Arch Linux (64 bit).

Thanks and Regards,
Tuxolero

cfpp2p
Posts: 279
Joined: Sat Aug 08, 2009 3:14 pm

Re: "no data found" stays even after correcting the folder

Postby cfpp2p » Mon Oct 27, 2014 11:59 pm

peace doesn't come without a price...
there is nothing truer on Earth or of the Universe

tuxolero
Posts: 43
Joined: Mon Mar 11, 2013 8:05 pm

Re: "no data found" stays even after correcting the folder

Postby tuxolero » Tue Oct 28, 2014 12:34 am

Known bug ... I see ...

tuxolero
Posts: 43
Joined: Mon Mar 11, 2013 8:05 pm

Re: "no data found" stays even after correcting the folder

Postby tuxolero » Wed Jan 14, 2015 8:10 pm

I have just found a workaround how to fix the torrent without restarting transmission:

You just need to open the context menu of the torrent and
  • Set Location ...
  • Start

Starting the torrent will trigger a re-check and if the location was set correctly, it is fixed.


Return to “GTK+ Support”