Changing sound file

Ask for help and report issues with the GTK+ version of Transmission
CaperAsh
Posts: 1
Joined: Thu Nov 13, 2014 11:36 am

Changing sound file

Postby CaperAsh » Thu Nov 13, 2014 11:56 am

I recently changed distros (now using Linux Lite 2) and the sound in the settings.json file doesn't work but I don't know how to write in a change (and there appears to be no GUI interface to effect this).

Am not very experienced with adjusting things manually.
Was not able to find out where the sound file being called in the .json script is supposed to be located so could move a sound file into that folder.

A sound file I can use is at:
/usr/share/sounds/Fresh and Clean/stereo/message-new-instant.ogg

I am hoping someone can write out the line or to in the settings file so it will call that sound.

Current file reads from line 84:
"torrent-complete-notification-enabled": true,
"torrent-complete-sound-command": "canberra-gtk-play -i complete-download -d 'transmission torrent downloaded'",
"torrent-complete-sound-enabled": false,

I made last line flase (in GUI) to prevent error messages causing crash (it said in logs).

Thank you. Great app.



Transmission Version: 2.82 (14160)

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: Changing sound file

Postby x190 » Fri Nov 14, 2014 4:02 am

That looks like distro specific code.

https://trac.transmissionbt.com/wiki/EditConfigFiles
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------


Return to “GTK+ Support”