unable to access daemon web interface now that vpn is set up

Ask for help and report issues with the GTK+ version of Transmission
lesterfarnsworth
Posts: 5
Joined: Sat Sep 05, 2015 11:51 pm

unable to access daemon web interface now that vpn is set up

Postby lesterfarnsworth » Sat Sep 05, 2015 11:59 pm

hello!

so i set up a transmission daemon on my htpc and it worked really well, too well perhaps (i got dinged by my isp for torrenting). so i decided to set up a vpn. i got the vpn running but i have lost the ability to use the web interface. when i go to http://[vpnipaddress]:port it does not allow me to connect. can anyone give me some help or even point me in the right direction? thanks

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: unable to access daemon web interface now that vpn is set up

Postby x190 » Sun Sep 06, 2015 5:21 am

settings.json?

localhost:9091?
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

lesterfarnsworth
Posts: 5
Joined: Sat Sep 05, 2015 11:51 pm

Re: unable to access daemon web interface now that vpn is set up

Postby lesterfarnsworth » Sun Sep 06, 2015 5:45 am

i have my settings.json set up in a way that should work with rpc whitelist disabled ect. is there some setting i should be paying closer attention to?

i get nothing when i connect to localhost:9091. should that be working even if i have a vpn set up? if it should that might point to me having something going wrong with the settings on my computer, as i have also not been able to ssh into my computer locally.

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: unable to access daemon web interface now that vpn is set up

Postby x190 » Sun Sep 06, 2015 6:13 am

http://localhost:9091/transmission/web/

worksforme --- post your settings.json, obscured as necessary.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

lesterfarnsworth
Posts: 5
Joined: Sat Sep 05, 2015 11:51 pm

Re: unable to access daemon web interface now that vpn is set up

Postby lesterfarnsworth » Sun Sep 06, 2015 9:30 pm

so i logged into my linux machine to copy my json into this forum (previously i have been trying to look at it from my laptop) and localhost;9091 works from this machine! which is great so now i can start some downloads, but this machine is a htpc and being able to control transmission from my laptop is the goal. i wonder if i have the wrong local ip address? anyways heres my settings.json:


{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"blocklist-url": "http://www.example.com/blocklist",
"cache-size-mb": 4,
"dht-enabled": true,
"download-dir": "/media/lfarnsworth/HD-LCU3/completed",
"download-limit": 100,
"download-limit-enabled": 0,
"download-queue-enabled": true,
"download-queue-size": 5,
"encryption": 1,
"idle-seeding-limit": 30,
"idle-seeding-limit-enabled": false,
"incomplete-dir": "/home/lfarnsworth/Downloads/transmission/incomplete",
"incomplete-dir-enabled": true,
"lpd-enabled": false,
"max-peers-global": 200,
"message-level": 1,
"peer-congestion-algorithm": "",
"peer-id-ttl-hours": 6,
"peer-limit-global": 200,
"peer-limit-per-torrent": 50,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": false,
"preallocation": 1,
"prefetch-enabled": 1,
"queue-stalled-enabled": true,
"queue-stalled-minutes": 30,
"ratio-limit": 5,
"ratio-limit-enabled": true,
"rename-partial-files": true,
"rpc-authentication-required": true,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-password": REDACTED,
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": REDACTED,
"rpc-whitelist": "127.0.0.1,*.*.*.*",
"rpc-whitelist-enabled": false,
"scrape-paused-torrents-enabled": true,
"script-torrent-done-enabled": false,
"script-torrent-done-filename": "",
"seed-queue-enabled": false,
"seed-queue-size": 10,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"trash-original-torrent-files": false,
"umask": 2,
"upload-limit": 100,
"upload-limit-enabled": 0,
"upload-slots-per-torrent": 14,
"utp-enabled": true
}

lesterfarnsworth
Posts: 5
Joined: Sat Sep 05, 2015 11:51 pm

Re: unable to access daemon web interface now that vpn is set up

Postby lesterfarnsworth » Sun Sep 06, 2015 10:12 pm

so i feel like i am getting to the bottom of this. after i added some torrents to test my daemon it says its trying to download them to somewhere in var/lib. this is not where i told it to download the files in settings.json, which makes it look like something is wrong and it is not loading the correct settings.json. when i installed i followed the instructions here: http://www.htpcbeginner.com/install-tra ... untu-1204/. this worked fine for me for several weeks, however when i was setting up my vpn i ended up having to reinstall lubuntu. i followed those instructions like i did the first time, in the instructions it has you copy settings.json to a seperate folder, delete the original, and then link the copied file to /etc/transmission-daemon. this link is working and my settings.json is the same as above, do you have any idea what is going wrong?

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: unable to access daemon web interface now that vpn is set up

Postby x190 » Mon Sep 07, 2015 1:03 am

any idea what is going wrong?

Yeah, you're not doing any troubleshooting! Search 'man transmission-daemon' and use the -g option. Bump your message level up to 3 and find out which settings.json file is being used.

https://trac.transmissionbt.com/wiki/EditConfigFiles
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

lesterfarnsworth
Posts: 5
Joined: Sat Sep 05, 2015 11:51 pm

Re: unable to access daemon web interface now that vpn is set up

Postby lesterfarnsworth » Tue Sep 08, 2015 11:09 pm

yeah sorry i am really new to linux, using daemons AND vpn so i dont super know what i am doing. i got to man transmission-daemon, and i see the -g config-dir option, but i cant figure out how to select it? i tried entering "transmission-daemon -g" in the terminal and it came up with a different list of options

plainzwalker
Posts: 6
Joined: Thu Sep 10, 2015 12:28 am

Re: unable to access daemon web interface now that vpn is set up

Postby plainzwalker » Thu Sep 10, 2015 12:43 am

Code: Select all

transmission-daemon -g /path/to/
where /path/to would be what ever directory is the settings.json you were editing


Return to “GTK+ Support”