Page 1 of 1

High Memory Usage

Posted: Sun Dec 11, 2016 9:10 pm
by User328
What the average memory usage of Transmission running upwards off 500 torrents? This number seems low to me in comparison to past numbers but as of the last few days I have memory usages ranging between 800 MB and 2 GB to the point where my desktop is freezing out. I have never had this issue before. What can be done about this?

Re: High Memory Usage

Posted: Mon Dec 12, 2016 4:20 am
by x190
A troublesome .resume file or specific torrent, perhaps? Have you changed anything on your system lately? HD in good shape?

Windows user?
https://trac.transmissionbt.com/ticket/5682

Re: High Memory Usage

Posted: Mon Dec 12, 2016 11:41 am
by User328
How would I be able to isolate if it was .resume file or specific torrent? Also no changes in the system and the HD is in good working order.

Re: High Memory Usage

Posted: Tue Dec 13, 2016 4:31 am
by x190
User328 wrote:How would I be able to isolate if it was .resume file or specific torrent?
Start them up in batches of 50, for example, and watch for memory issues.

Re: High Memory Usage

Posted: Thu Jun 04, 2020 8:01 pm
by PaulAnthony
I am seeing this issue too.
As I add torrents the memory usage is creeping up.
With 106 torrents, transmission is using 557M memory. When I had about 70 torrents it was about 300M.
This is version 2.92 (14714) for 32bit linux.
The fact that it has gradually crept up as I add torrents, rather implies I do not have a 'dodgy' torrent.
This is a new install (less than 3 months) and nothing untoward has happened.
Any thoughts? I cannot afford for transmission to use more memory, and would like to add another couple of hundred torrents in due course.