[Solved] Building on Debian 6.0.0 squeeze

Ask for help and report issues with the GTK+ version of Transmission
Locked
Tchangalo
Posts: 7
Joined: Wed May 26, 2010 4:10 am

[Solved] Building on Debian 6.0.0 squeeze

Post by Tchangalo »

Hi, i am trying to build Transmission 2.20 from tarball on debian 6. I get this error:

Code: Select all

configure: error: Package requirements (libevent >= 2.0.10) were not met:

No package 'libevent' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBEVENT_CFLAGS
and LIBEVENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
libevent (1.4.13) and libevent-dev (1.4.13) are alredy installed. Is the version 2.0.10 really needed?
Is there another solution?
Thanks!
Last edited by Tchangalo on Tue Feb 08, 2011 12:46 am, edited 1 time in total.
livings124
Transmission Developer
Posts: 3141
Joined: Fri Jan 13, 2006 8:08 pm

Re: Building on Debian 6.0.0 squeeze

Post by livings124 »

libevent 2.0 is required.
Tchangalo
Posts: 7
Joined: Wed May 26, 2010 4:10 am

Re: Building on Debian 6.0.0 squeeze

Post by Tchangalo »

livings124 wrote:libevent 2.0 is required.
installed libevent-dev 2.0.10 and worked perfectly.
Thanks!
DJArty
Posts: 5
Joined: Sat Nov 13, 2010 10:03 pm
Location: Kharkiv, Ukraine

Re: [Solved] Building on Debian 6.0.0 squeeze

Post by DJArty »

There is the source of libevent 2.0.10 ??
P.S. ok - found here
Locked