[SOLVED] Connection failed! - Web GUI

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
ChairmanSaab
Posts: 2
Joined: Sun Jan 11, 2015 12:49 am

[SOLVED] Connection failed! - Web GUI

Postby ChairmanSaab » Sun Jan 11, 2015 2:57 am

Hello,

After scratching head with transmission for 1 hour, i finally made it to load the web interference. I've followed this guide here! and web interference now loads at port i specified. Immediately after it loads, it greets me with "Connection failed! Could not connect to the server, you may need to reload the page to reconnect "

What i've done wrong ?

This is my settings.json, If there is any need to provide more information, let me know!

Code: Select all

    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "http://www.example.com/blocklist",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/home/chairmansaab/transmission/completed",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/home/chairmansaab/transmission/incomplete",
    "incomplete-dir-enabled": true,
    "lpd-enabled": false,
    "max-peers-global": 120,
    "message-level": 2,
    "peer-congestion-algorithm": "",
    "peer-limit-global": 120,
    "peer-limit-per-torrent": 30,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "prefetch-enabled": 0,
    "queue-stalled-enabled": false,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-password": "sshhhhhhhhhh",
    "rpc-port": 48305,
    "rpc-url": "/transmission/",
    "rpc-username": "chairmansaab",
    "rpc-whitelist": "127.0.0.1,172.17.0.117",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 5,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-limit": 100,
    "upload-limit-enabled": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": false


Image
Last edited by ChairmanSaab on Mon Jan 12, 2015 11:42 pm, edited 1 time in total.

x190
Posts: 5094
Joined: Sun Nov 30, 2008 4:59 am

Re: Connection failed! - Web GUI

Postby x190 » Sun Jan 11, 2015 6:42 am

"rpc-whitelist": "127.0.0.1,172.17.0.117",
"rpc-whitelist-enabled": false,

Try setting "rpc-whitelist-enabled" to true.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

ChairmanSaab
Posts: 2
Joined: Sun Jan 11, 2015 12:49 am

Re: Connection failed! - Web GUI

Postby ChairmanSaab » Mon Jan 12, 2015 11:41 pm

hey, thanks for reply.

Just for information, it was VPS related issue, I've moved to new one with dedicated IP (earlier one had shared ip and it was using docker). Now everything loads real quick , i even got deluge to load. Both torrent client works now!

x190 wrote:
"rpc-whitelist": "127.0.0.1,172.17.0.117",
"rpc-whitelist-enabled": false,

Try setting "rpc-whitelist-enabled" to true.


I tried it, didn't work. With new vps, everything work as it supposed to be! I'm using deluge for now!

Close this topic.


Return to “Support”