Stop folder/directory creation

Discussion of Transmission that doesn't fit in the other categories
mboy
Posts: 1
Joined: Sun Dec 27, 2015 10:58 pm

Stop folder/directory creation

Postby mboy » Sun Dec 27, 2015 11:00 pm

Hi all,

I've been using Transmission quite a while now and I really like it. It only has one downside for me at this point.
When I download a torrent in a particular folder, transmission automatically creates a subfolder in that one I specified with the name of the torrent.

So basically /volume1/<place I specify>/<torrent name>/<files ....>

I want to disable this, so that the torrent content goes directly in my download folder, and doesn't create a subfolder first. Is that possible ?

x190
Posts: 5095
Joined: Sun Nov 30, 2008 4:59 am

Re: Stop folder/directory creation

Postby x190 » Mon Dec 28, 2015 6:08 am

It's part of the torrent. You could rename, maybe.
The stone age didn’t end because we ran out of stones.
---The Great Disruption - by Paul Gilding
https://paulgilding.com/
-------------------------------------------------

no_dir
Posts: 1
Joined: Fri Jun 22, 2018 7:39 am

Re: Stop folder/directory creation

Postby no_dir » Fri Jun 22, 2018 8:39 am

apologies for the necro-post, but i would like to see a feature to support this too. utorrent has it. i've searched around and the usual response is that the directory is part of the torrent, so i did some digging.

i'm running transmission 2.93 as a plugin on a freenas 11.1-u4 machine and access it with transgui. i used this torrent file editor to look at a multi-file torrent. this is an example of what i got.

Code: Select all

{
 "announce" : "http://some-url",
 "announce-list" : [
  [
   "http://some-url"
  ]
 ],
 "created by" : "uTorrent/2210",
 "creation date" : 1435055859,
 "encoding" : "UTF-8",
 "info" : {
  "files" : [
   {
    "length" : 11819525651,
    "path" : [
     "file.mkv"
    ]
   },
   {
    "length" : 6608,
    "path" : [
     "file.nfo"
    ]
   }
  ],
  "name" : "name_of_torrent",
  "piece length" : 4194304,
  "pieces" : a really long line
  "private" : 1,
  "source" : "tracker_site.org"
 }
}

i don't see anything in there indicating a directory to put the files in. a single file torrent is similar except most of the info is under "info" and it doesn't have a torrent name. the only name is the name of the 1 file to download.

in the "Add new torrent" window in transgui, i noticed that the "Save as" box would be filled in with the torrent name, for a multi-file torrent. for a single file torrent, it would be the filename. for a multi-file torrent, if i wanted to save the files under /home/downloads, they would go in /home/downloads/name_of_torrent instead. for a single-file torrent, the file would go in /home/downloads. the single-file torrent behaves the way i want. the multi-file torrent doesn't. i want the files to go in /home/downloads and not a subdirectory under it.

i tried an experiment with a multi-file torrent. for the "Destination folder" field in the "Add new torrent" window, i put /home instead of /home/downloads. for "Save as" i put downloads. the files went in /home/downloads like i wanted! the downside to this trick is that this torrent got listed as "downloads" in the list of torrents in the main transmission window. if i keep using this trick, i'll have multiple torrents with the name "downloads." the only way to tell them apart will be to look at the other tabs like files.

what this tells me is that a torrent doesn't tell transmission where to save the files. transmission constructs the path based on the data in the "Add new torrent" window. for a single file torrent, the file goes in "Destination folder." for multi-file torrents, the files go in "Destination folder/Save as." it should be easy to add an option to enable or disable the creation of a subdirectory. if this option is enabled by default, then the behavior of transmission is the same as it's always been. if the option is disabled or the torrent is for just 1 file, then the download path is "Destination folder." otherwise, the files go in "Destination folder/Save as."

please make this happen!


Return to “General”